If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Home" button and menu item access wrong location under certain conditions

RESOLVED DUPLICATE of bug 223331

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 223331
15 years ago
11 years ago

People

(Reporter: Jonathan Louie, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030519 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030519 Mozilla Firebird/0.6

i've set my homepage to be a different page, and when i open new windows, it
goes to the appropriate page.  however, when i hit the home button on the
toolbar or choose go->home from the menu, it goes to www.mozilla.org instead of
the page i've specified.

Reproducible: Always

Steps to Reproduce:
1.set a different home page
2.open a new window
3.hit home button

Actual Results:  
i'm at mozilla.org

Expected Results:  
taken me to my actual homepage

Comment 1

15 years ago
WFM Mozilla/5.0 (Windows 2000; en-US; rv:1.4b) Gecko/20030519 Mozilla Firebird/0.6
(Reporter)

Comment 2

15 years ago
hehe, yes, it should.  it's a mac-specific bug.

Updated

15 years ago
Keywords: qawanted
Whiteboard: need reproducing

Comment 3

15 years ago
WorksForMe using Firebird/Mac/2003-05-16 (0.6).
(Reporter)

Comment 4

15 years ago
heh, okay, thought i was going crazy there, but i've got more detailed
reproduction instructions.  (home works fine for the first window that comes up
which is probably why it works for you guys.)

having set a different homepage:

1. launch firebird
2. close initial browser window/close all browser windows
3. open new browser window
4. hit home button or select home menu item

i swear i'm not making this up :)

Comment 5

15 years ago
Confirmed using Firebird/Mac/2003-05-16 (0.6) following the steps in comment 4.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Summary: toolbar home button and menu item always take me to mozilla.org → "Home" button and menu item access wrong location under certain conditions
Whiteboard: need reproducing

Comment 6

15 years ago
*** Bug 206663 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
I am experiencing this problem with the Windows version of the official Firebird
0.6 release, i.e.:
"Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla
Firebird/0.6"

This means it actually isn't a Mac-only bug. :-)
(Reporter)

Comment 8

15 years ago
what are your steps to reproduce on windows?  i use firebird on windows as well
and haven't run into this bug there.  (and obviously, you can't close all
firebird windows on windows without it quitting, so my steps to reproduce won't
work.)

Comment 9

15 years ago
OK, I just figured out what I did on Windows to get this behavior.  I had
removed bookmarks.xpt from the components directory (don't ask,
experimenting...), which didn't seem to have any effect at the time.  Copying
bookmarks.xpt back into the components directory makes the problem go away.  Is
that a clue to what could be happening in the Mac world since the symptoms are
the same?

Comment 10

14 years ago
reassigning mac bugs, sorry for the spam.
Assignee: blake → nobody

Comment 11

14 years ago
*** Bug 215180 has been marked as a duplicate of this bug. ***
--> hyatt
Assignee: nobody → hyatt

Comment 13

14 years ago
In the first window that opens at the startup, The Home-Button and the links in
the toolbar work without any problems. When opening a second page, the
Home-Button leads not to the given URL, instead it leads to
http://www.mozilla.org. Links in the Toolbar don't have any effect in this
second window!

(Reporter)

Comment 14

14 years ago
there's a workaround:  if you close all browser windows, the first window you
open will be busted (this bug as well as bug 206752 occur), but if you open
another browswer window (while this busted one is open) the new window works
properly.

Updated

14 years ago
QA Contact: asa
(Reporter)

Comment 15

14 years ago
*** Bug 221220 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
Fixed 20031024 Firebird/0.7+ (see bug 223331). Needs to be set as fixed or duped
to that bug.

*** This bug has been marked as a duplicate of 223331 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: General → Toolbars
QA Contact: bugzilla
Resolution: --- → DUPLICATE

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.