The default bug view has changed. See this FAQ.

[FIXr]The GIF Animation is very slowed down, where explorer makes it very fast as intended by myself

RESOLVED FIXED in mozilla1.7alpha

Status

Core Graveyard
Image: Painting
P1
normal
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: Asja Sinn, Assigned: bz)

Tracking

Trunk
mozilla1.7alpha
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-ie, URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

The animated GIF file should change fast from frame to frame, as I intended to
make it, and as it does in MS i-explorer. For some reason there showed very slow
after each other and it also contains an empty frame each loop.

Reproducible: Always

Steps to Reproduce:
1.Go to http://aszazin.tk in mozilla
2.watch the animated Gif
3.Open the GIF-file in another program wich support Animated GIF, and notice the
difference in speed.

Actual Results:  
You notice a very different frame speed.

Expected Results:  
It should have showed the different frames very fast after each other to create
a stroboscopic effect.

Comment 1

14 years ago
Worksforme in build 2003052307 on Mac OS X 10.2.6

I tested with Mozilla 1.4, Safari and Internet Explorer. IE was the fastest,
Mozilla was second, and Safari the slowest. With sound off, Mozilla was faster
than IE.

What was the frame interval for this image ? 100ms or less ? Then you should
know that Mozilla will limit this to 100ms, because IE (on a PC) does that too.
Unfortunately a lot of images depend on that, so we can't change it, otherwise
we get stroboscopic effects everywhere. IE (on a Mac) doesn't have that
limitation, so that's why you can see that IE can be faster than Mozilla. See
bug 139677.

BTW : 'Petroliumkaai' ? Als je alternatief wil zijn, moet je wel consequent
zijn. Het woord staat 3 keer op de pagina, en slechts 1 keer is het juist.

Comment 2

14 years ago
GIMP's Layers, Channels, and Paths window says the image is timed for
60ms per frame, and IE draws it that way.  I think IE's limit is somewhere
faster than 100ms on my machine (PIII 866, NV TNT2, Windows 2000).

Component: Browser-General → Image: GFX

Comment 3

14 years ago
please reassign when changing components
Assignee: general → jdunn
QA Contact: general → tpreston
(Reporter)

Comment 4

14 years ago
In don't understand limiting the frame rate to 100 ms, it should at least be
possible to reach a speed similar to 25 frames/second, and even better 30.
Otherwise it would become impossible for many artists to make use of Animated
GIF in their site while it is a very appropriate format for moving images with
not to many colors. If it should be limited due to GIF-files without defined
speed or something, it should only do that when no speed is defined in the GIF,
or in the options should be a checkbox which turns the limit on or off.
This file is 16,666 fps, so I guess the limitation is better set to 30ms. I
don't know IE is limited, but it shows the file just like every other program.

ps:"meestal zeggen we gewoon petrolkaai, als't maar verstaanbaar is ben ik
kontent" ~grtz

Comment 5

14 years ago
Bug 139677 comment 11 states that the limit for animated GIFs in Internet
Explorer 6 is now 50 ms. The limit of 100 ms was originally imposed on Mozilla
because that's what IE 5 and Opera 6 did. Now that both IE 6 and Opera 7 and
even Safari display animated GIFs with down to 50 ms frame rates correctly,
Mozilla should be changed to match either the behavior of IE 6 or Opera 7.
Blocks: 119597
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: parity-ie

Comment 6

14 years ago
I suppose we want Mozilla to support fast animated GIFs on all platforms.
Hardware/OS -> All/All
OS: Windows 2000 → All
Hardware: PC → All
Blocks: 139677
Created attachment 136851 [details] [diff] [review]
Patch per bug 139677 comment 13
Comment on attachment 136851 [details] [diff] [review]
Patch per bug 139677 comment 13

I agree that doing this makes the most sense.  Arron, tor, could you review
please?
Attachment #136851 - Flags: superreview?(tor)
Attachment #136851 - Flags: review?(paper)

Comment 9

14 years ago
Comment on attachment 136851 [details] [diff] [review]
Patch per bug 139677 comment 13

Sure, but run this by stuart.

Be prepared for more "CPU pegged on GIF animation" bugs with examples using 20
- 90 ms frame delays.
Attachment #136851 - Flags: review?(paper) → review+

Comment 10

14 years ago
oh, one other note, your patch doesn't say what IE or Opera do with 0ms frames.
 I assume it's the same that's done for 10ms.  Might want to add that to the
comments, but I don't require another patch to be put up (tor might though ;) )
pav, thoughts?

Comment 12

14 years ago
Comment on attachment 136851 [details] [diff] [review]
Patch per bug 139677 comment 13

sr=tor.  gfx2 is a dead module and doesn't need patching.
Attachment #136851 - Flags: superreview?(tor) → superreview+
nab.
Assignee: jdunn → bz-vacation
Priority: -- → P1
Summary: The GIF Animation is very slowed down, where explorer makes it very fast as intended by myself → [FIX]The GIF Animation is very slowed down, where explorer makes it very fast as intended by myself
Target Milestone: --- → mozilla1.7alpha

Comment 14

14 years ago
> Be prepared for more "CPU pegged on GIF animation" bugs...

Let's check this patch in, and see how many of those bugs we get. If we get too
many, we can then try to fix any performance bugs that can help, or we can
change Mozilla's behavior to match IE6's defacto standard, which is much less
likely to cause the CPU to be 100% utilized. Just my $0.02.

Comment 15

14 years ago
Animated GIFs are very slow in this nightly:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031214 MultiZilla/1.6.0.0c
Summary: [FIX]The GIF Animation is very slowed down, where explorer makes it very fast as intended by myself → [FIXr]The GIF Animation is very slowed down, where explorer makes it very fast as intended by myself
Checked in for 1.7a.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 17

13 years ago
*** Bug 231692 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
*** Bug 139677 has been marked as a duplicate of this bug. ***

Comment 19

13 years ago
force2k reported at http://forums.mozillazine.org/viewtopic.php?t=48944 that a
specific GIF was too fast.  The consensus seems to be that Firebird and GIMP are
correct in letting the GIF animate quickly.
Well, that matches the data we have -- that for gifs with less than 50ms delay
IE will force them to 100ms...

Comment 21

13 years ago
Continued in bug 232769, "Animated GIF file animates too quickly" (already
marked wontfix).

Updated

7 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.