Preferences is under Mozilla menu, not Edit menu on Mac OS X

VERIFIED FIXED

Status

Documentation
Help Viewer
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: Doug Lerner, Assigned: stefanh)

Tracking

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030612

Here is what it currently reads in the "Help" documentation

Turning Buttons On and Off

   1. Open the Edit menu and choose Preferences.
   2. Click Navigator.
   3. Under "Select the buttons you want to see in the toolbars," choose the
buttons that you want on your toolbar.
   4. Click OK. 

With regards to (1) Preferences is actually in the Mozilla Menu.

WIth regards to (3) the specified item does not exist.

Reproducible: Always

Steps to Reproduce:
1.Open Help
2.Go to the section on personal toolbars
3.

Actual Results:  
Described above

Expected Results:  
I don't know. I was reading the docs to tell me how to get rid of the "home" and
"bookmarks" items from my personal toolbar by the docs were incorrect and I
don't know what it should have said. :-)

Comment 1

15 years ago
-->robin.
Assignee: rudman → robinf
(Reporter)

Comment 2

15 years ago
I did find the settings there in the Navigator item itself. So the only part of
the docs that are wrong with regards to this was the actual location of the
Preferences menu.

By the by, all the docs are written from the view of somebody who has a
right-mouse button. Mac users typically don't. It isn't standard. So it would be
nice to also explain how to find the right-mouse features for Mac users.

Thanks,

doug

Comment 3

15 years ago
*** Bug 210732 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 46917
Summary: personal toolbar documentation is incorrect in various places → Preferences is under Mozilla menu, not Edit menu on Mac OS X

Comment 4

15 years ago
robinf and rudman don't work on Mozilla anymore. This needs to be reassigned,
and I'm not the right person because I don't have access to a mac.

Daniel: Do you know of anyone who would be appropriate to assign this to?

Comment 5

15 years ago
Keller, we need to change references to Edit menu. Based on dupe, I'm pretty
sure it's in Mozilla menu on Mac.

For Mac, option+click == right click
Assignee: robinf → rlk
QA Contact: rudman → stolenclover

Comment 6

15 years ago
Daniel: So for everywhere it shows using the Edit menu to access Preferences, we
need to add "(or Mozilla menu for Mac)"? Is this correct?

Comment 7

15 years ago
In "Mail & Newsgroup Preferences" I see
  1. Open the Edit menu and choose Preferences.
    (Mac OS X) Open the Mozilla menu and choose Preferences.

(which is too long)

In "Searching on Selected Words in a Web Page" I see
   Right-click and choose "Web Search for [your selected words]"
   for the menu. (To right-click on Mac OS, press Ctrl and click
   the mouse button.)

(I think it should be option+click. Doug, can you verify?)

In the Help file, keyboard shortcuts are refer to as XXX (YYY on Mac OS). Let's
keep it consistent and put (Mozilla menu on Mac OS)
(Assignee)

Comment 8

14 years ago
If nobody minds, I can take this. I would suggest the following change:

Open the Edit menu and choose Preferences --> Open the Edit menu (Mozilla menu
on Mac OS X) and choose Preferences.

It seems that the Preferences are under the Edit menu in Mozilla on Mac Classic
- at least in the 1.2.1 release. So "Mac OS" doesn't sounds 100% correct.

Right-click <--> Ctrl-click.

Comment 9

14 years ago
> Right-click <--> Ctrl-click.

isn't that Option+Click?
(Assignee)

Comment 10

14 years ago
> > Right-click <--> Ctrl-click.
> isn't that Option+Click?

From http://www.apple.com/macosx/features/finder/:

"Putting it in context
The Action menu gives you access to contextual Finder commands based on the 
current selection. Maybe you want to label files, or move items to the trash. 
The Action menu also gives you a handy way to get more information about a 
file. If you have a two-button mouse, you can also right-click on an item to 
bring up the menu, or hold down the control key while clicking on an item with 
a one-button mouse."


(Assignee)

Comment 11

14 years ago
Created attachment 142370 [details] [diff] [review]
Changed references to Edit menu in xhtml files

This patch changes all the references to the Edit menu in the xhtml files in
mozilla/extensions/help/resources/locale/en-US/: "Open the Edit menu and choose
Preferences" becomes "Open the Edit menu (Mozilla menu on Mac OS X) and choose
Preferences" etc.

I'm not sure that "Mozilla menu on Mac OS X" is the best option, but at least
it's short...

I also found two references to "Netscape" in certs_help.xhtml, which I replaced
with "Mozilla".

The reference to the Edit menu in the Quicklaunch section in nav_help.xhtml is
not changed, since it's windows (and Linux?)-only. That could probably be added
to bug 111484.

I do wonder if changing the xhtml files is enough, I suspect there are some
html files that are still in use (there are plenty of links to html files in
the xhtml files...). Would appreciate if someone informed me which files that
are used.

I don't know if composer_help.xhtml should be altered now. There seem to be a
patch in bug 95770, attachment 88 [details] [diff] [review] that should (?) be checked in.
(Assignee)

Comment 12

14 years ago
> The reference to the Edit menu in the Quicklaunch section in nav_help.xhtml is
> not changed, since it's windows (and Linux?)-only. That could probably be added
> to bug 111484.

Forget this - it actually says that Quick Launch is windows-only...

Comment 13

14 years ago
Comment on attachment 142370 [details] [diff] [review]
Changed references to Edit menu in xhtml files

r=rlk@trfenv.com.

Looks good! I'll check this in soon!
Attachment #142370 - Flags: review+

Comment 14

14 years ago
--> stefan
Assignee: rlk → stefan_h

Comment 15

14 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 16

14 years ago
reopen. looks like we have some mistakes in composer_help.*html
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

14 years ago
Yes, something probably happened when the patch 
(http://bugzilla.mozilla.org/attachment.cgi?id=154320&action=view)in bug 95770 
was checked in. Looks like the changes since version 1.15 isn't included. Hmm.
(Assignee)

Comment 18

14 years ago
Created attachment 154773 [details] [diff] [review]
fix - includes previous changes (1.15 - recent)

Made a diff with composer_help.xhtml on my hard disk. The file in the en-US
directory the 1.14 revision converted to xhtml. This patch should fix all
regressions. Hmm, wonder what happened?
(Assignee)

Comment 19

14 years ago
Comment on attachment 154773 [details] [diff] [review]
fix - includes previous changes (1.15 - recent)

RJ: please take a look asap - the composer_help file in the en-US directory is
not the correct version.
Attachment #154773 - Flags: review?(rlk)
(Assignee)

Comment 20

14 years ago
Comment on attachment 154773 [details] [diff] [review]
fix - includes previous changes (1.15 - recent)

This will also fix the regressions in bug 233647, bug 243349 and bug 90984.

Updated

14 years ago
Attachment #154773 - Flags: review?(rlk) → review+
(Assignee)

Comment 21

14 years ago
Created attachment 154819 [details] [diff] [review]
Corrected version of fix

Found an error in the previous version, so here's a new patch.
Attachment #154773 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #154819 - Flags: review?(rlk)

Updated

14 years ago
Attachment #154819 - Flags: review?(rlk) → review?(neil.parkwaycc.co.uk)

Comment 22

14 years ago
Comment on attachment 154819 [details] [diff] [review]
Corrected version of fix

>-   <title>Creating Web Pages with &brandShortName; Composer</title>
>-   <link rel="stylesheet" type="text/css" href="chrome://help/locale/helpFileLayout.css"/>
>+<title>Creating Web Pages with &brandShortName; Composer</title>
>+<link rel="stylesheet" type="text/css"
>+  href="chrome://help/locale/helpFileLayout.css"/>
Why this change?

>     <tt>http://www.mozilla.org</tt>) in the Location Bar and pressing Enter (Return on
>-	Macintosh OS).</li>
>+	Mac OS).</li>
Hmm... sometimes I see Mac OS X, and sometimes just Mac OS... it looks as if
Mac OS X is in the majority though.

>-    <li><a href="#formatting_paragaphs_headings_and_lists">Formatting Paragraphs, Headings, and Lists</a></li>
>+    <li><a href="#formatting_paragraphs_headings_and_lists">Formatting Paragraphs, Headings, and Lists</a></li>
>-<h2 id="formatting_paragaphs_headings_and_lists">Formatting Paragraphs, Headings, and Lists</h2>
>+<h2 id="formatting_paragraphs_headings_and_lists">Formatting Paragraphs, Headings, and Lists</h2>
I found another of these that needs changing...

>-<h1 id="adding_pictures_to_your_web_page">Adding Pictures (Images) to Your Web Page</h1>
>+<h1 id="adding_images_to_your_web_page">Adding Pictures (Images) to Your Web Page</h1>
And three more of these...

>-    <li><a href="#composer_preferences_composer">Composer</a></li>
>-	<li><a href="#composer_preferences_new_page_settings">New Page Settings</a></li>
>+    <li><a href="#composer">Composer</a></li>
>+	<li><a href="#new_page_settings">New Page Settings</a></li>
>-<h2 id="composer_preferences_composer">Composer Preferences - Composer</h2>
>+<h2 id="composer">Composer Preferences - Composer</h2>
>-<h2 id="composer_preferences_new_page_settings">Composer Preferences - New Page Settings</h2>
>+<h2 id="new_page_settings">Composer Preferences - New Page Settings</h2>
And three more of both of these...
Attachment #154819 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Comment 23

14 years ago
Created attachment 156287 [details] [diff] [review]
New version

> >-   <title>Creating Web Pages with &brandShortName; Composer</title>
> >-   <link rel="stylesheet" type="text/css"
href="chrome://help/locale/helpFileLayout.css"/>
> >+<title>Creating Web Pages with &brandShortName; Composer</title>
> >+<link rel="stylesheet" type="text/css"
> >+  href="chrome://help/locale/helpFileLayout.css"/>
> Why this change?

I'm too used to the 80 char width rule (and my own indentation). But I changed
it back - not really nice when you're just changing a few lines.
> 
> >	<tt>http://www.mozilla.org</tt>) in the Location Bar and pressing Enter
(Return on
> >-	Macintosh OS).</li>
> >+	Mac OS).</li>
> Hmm... sometimes I see Mac OS X, and sometimes just Mac OS... it looks as if
> Mac OS X is in the majority though.

This is an issue in all the help files. The thing is that in Mac OS classic the
preferences is in the "Edit" menu, but in Mac OS X the preferences is in the
"Mozilla" menu. That's why the references to Mac OS X where added in the first
place. But I suggest we fix all these references in a separate bug instead or
when the content of the files are updated.

> 
> >-	<li><a href="#formatting_paragaphs_headings_and_lists">Formatting
Paragraphs, Headings, and Lists</a></li>
> >+	<li><a href="#formatting_paragraphs_headings_and_lists">Formatting
Paragraphs, Headings, and Lists</a></li>
> >-<h2 id="formatting_paragaphs_headings_and_lists">Formatting Paragraphs,
Headings, and Lists</h2>
> >+<h2 id="formatting_paragraphs_headings_and_lists">Formatting Paragraphs,
Headings, and Lists</h2>
> I found another of these that needs changing...

Sorry about that - Fixed!
> 
> >-<h1 id="adding_pictures_to_your_web_page">Adding Pictures (Images) to Your
Web Page</h1>
> >+<h1 id="adding_images_to_your_web_page">Adding Pictures (Images) to Your
Web Page</h1>
> And three more of these...
>
Fixed

> >-	<li><a href="#composer_preferences_composer">Composer</a></li>
> >-	<li><a href="#composer_preferences_new_page_settings">New Page
Settings</a></li>
> >+	<li><a href="#composer">Composer</a></li>
> >+	<li><a href="#new_page_settings">New Page Settings</a></li>
> >-<h2 id="composer_preferences_composer">Composer Preferences - Composer</h2>

> >+<h2 id="composer">Composer Preferences - Composer</h2>
> >-<h2 id="composer_preferences_new_page_settings">Composer Preferences - New
Page Settings</h2>
> >+<h2 id="new_page_settings">Composer Preferences - New Page Settings</h2>
> And three more of both of these...

Fixed as well - but I just found two "new_page _settings" errors :)
(Assignee)

Updated

14 years ago
Attachment #154819 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #156287 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 24

14 years ago
Neil, I can fix the Mac stuff in bug 111484 (or when I update a specific help
file). I'll hide/show the platform-specific references to the preferences in all
the files at the same time. Just so we don't end up with some files not altered.

Updated

14 years ago
Attachment #156287 - Flags: review?(neil.parkwaycc.co.uk) → review+

Comment 25

14 years ago
Fix checked in.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.