The navbar sometimes does not display at www.mozillazine.org

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: chrisn, Assigned: harishd)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
In the December 6 Windows build, the navbar of Mozillazine
(http://www.mozillazine.org) does not always display. I thought this might be a
reflow problem, and the last content of the HTML wasn't being reflowed for
some reason, but what's weird is that the navbar isn't the last content in the
HTML -- the copyright notice is -- yet the copyright notice displays properly
even when the navbar doesn't.

Asa Dotzler has also seen this same bug.
(Reporter)

Comment 1

19 years ago
Created attachment 3291 [details]
Image of page missing navbar
(Reporter)

Comment 2

19 years ago
Also note that the navbar doesn't appear even in the event of a page resize or
sidebar collapse.

Comment 3

19 years ago
Just noted that this occurs on recent (12/12) M12 Mac builds. In my case the

navbar will NOT appear when the following is done.
1. go to

http://www.mozilla.org/ (the default homepage for the builds)
2. simply type

zine in between the 'a' and '.' of the url and press return.
3. mozillazine page

loads without the navbar

To load the sidebar do any of the following. Sometimes

these work, other times
they don't.
1. when at www.mozilla.org, erase the whole

url and retype the mozillazine url
2. if you load www.mozillazine.org and the

navbar is not there, add chrome/ to
the url, go to the chrome page (the sidebar

should be there), then erase chrome/
and hit return and now the homepage will

load with the navbar.

All in all very strange

Updated

19 years ago
Assignee: leger → rickg
Component: Browser-General → Parser

Comment 4

19 years ago
Parser or content sink issue?

Updated

19 years ago
Assignee: rickg → petersen

Comment 5

19 years ago
Petersen -- can you verify this please? I don't see it.

Updated

19 years ago
Assignee: petersen → rickg

Comment 6

19 years ago
Based on the description, I 'm not able to reproduce the problem described.

Tested witb the Dec 20th build under Win 98 and Mac OS 9.

Comment 7

19 years ago
Just downloaded the Mac build (Dec 20th; 199912201) and the problem persists.
1. Entered http://www.mozilla.org
2. Added zine to get http://www.mozillazine.org
3. Right hand side of page does not come up.

Running on OS9.0

Possibly related to bug #19356 where the right hand side of dailynews.yahoo.com
does not display completely. (tested today on 199912201, MacOS 9.0)

Updated

19 years ago
Target Milestone: M13

Comment 8

19 years ago
setting target milestone.

Comment 9

19 years ago
Hey ChrisN -- ChrisP and I can't seem to repro this problem. I'll owe you a
favor if you will double check the problem for me. Thanks -- RickG.

Comment 10

19 years ago
The navbar doesn't show up always with Win32 build 2000010308 also.
(Reporter)

Comment 11

19 years ago
Following the steps outlined in meiering@u.washington.edu's 12-13 comments, I am
able to duplicate this bug in the Jan 9 2000 Windows build.

This is duplicatable only the first time mozillazine is loaded. Thus, if I
start the app, and visit mozilla.org, and then enter "zine" after the "mozilla"
in the URL-bar and hit ENTER, the navbar at mozillazine.org will not appear that
first time. However, if I go back to the mozilla.org home page, and enter "zine"
again and hit ENTER, the navbar loads properly.

This bug is repeatable, but not every time. I tried it 3 times, and was able to
get this behaviour 2 out of the 3 times.

Comment 12

19 years ago
Created attachment 4091 [details]
testcase; semi-simplified talkback page; duplicates everytime

Comment 13

19 years ago
The attachment is a simplified form of one of the talkback articles,
not the front page, but this version happens _everytime_ using win95
2000010608. It uses the same 'html pattern' as the main page. (It's
more likely a tables thing, than a a parser problem).

Updated

19 years ago
Target Milestone: M13 → M14

Comment 14

19 years ago
This isn't looking good for m13. I'm not even sure yet where this problem is.
(Assignee)

Updated

19 years ago
Assignee: rickg → harishd
(Assignee)

Comment 15

19 years ago
Moving to my list :(
(Assignee)

Comment 16

19 years ago
Ok, I see the problem...but this is definitely not a parser problem ( save it on
you hard drive and try loading - N number of times - you will not see the
problem ).  The culprit could be the server after all.
(Assignee)

Comment 17

19 years ago
Moving this to M15.  
Target Milestone: M14 → M15

Comment 18

19 years ago
*** Bug 23526 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

19 years ago
The problem seems to have gone away. Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 20

19 years ago
Works great with todays build on all platforms.  Marking Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.