Impossible to paste entries into folder using keyboard shortcuts

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Gili, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4) Gecko/20030616
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4) Gecko/20030616

If you try pasting bookmarks into the contents of an empty folder, they will
paste before or after the folder but never inside. When using the mouse, you can
successfully drag links into an empty folder. Keyboard navigation should
function the same way.

Reproducible: Always

Steps to Reproduce:
1. Create an empty bookmark folder
2. Copy a bookmark
3. Move keyboard cursor over folder and hit CTRL-V
4. Bookmark will paste after folder, not inside it

Comment 1

14 years ago
Not OS/2 specific
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: other → All
Hardware: PC → All

Comment 2

14 years ago
*** Bug 228741 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*** Bug 224223 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
*** Bug 227272 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
Also on OS X 10.3.6/FF 1.0 (Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0); as you might expect, behavior is
identical if you're pasting many bookmarks at a time as well.
Product: Browser → Seamonkey

Comment 6

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody

Comment 7

11 years ago
This still occurs in Firefox 2.0 on Windows (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0). In Firefox, choosing 'New Bookmark' from the context menu after navigating to a newly created (empty) folder in the folder tree still places the bookmarks in the parent folder. Using Edit->Move Bookmark(s) to move bookmarks into a newly created folder also fails; the bookmarks appear to be deleted altogether. The only way to create a bookmark inside a new folder is to use the "Bookmark This Page" command in the browser and choose the folder from the list, which does not allow for the same level of customisation (one has to edit the bookmark later to change the URL, keywords, etc.).

Comment 8

5 years ago
Can't reproduce this in current nightly, closing
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.