[DOGFOOD] Can't click on links in CNET story

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Akkana Peck, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] [12/19-12/22], URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I'm not sure who's the right owner for this sort of bug --

On the given CNET page, near the bottom of the page, there is a list of Linux
distributions, each of which is a link to another story.  In 4.61, I can click
on those links and go to the story; in Mozilla, they aren't clickable and don't
have mouseover feedback.

Here is a sample of one of these links:

<td valign=middle align=center><a
href="/software/0-3721-7-1473264.html?st.cn.3721-7-1473249.subdir.3721-7-1473264"><font
size="-1" face="Arial, Helvetica" color="#0000ff"><span
style="color:#0000ff"><b>Caldera OpenLinux 2.3</b><br></span></font></a></td>
(Reporter)

Comment 1

18 years ago
Adding joki -- maybe he knows who should own this.

Updated

18 years ago
Assignee: troy → joki

Comment 2

18 years ago
I'll take this.  Its probably a dupe of one I already have anyway but since I
don't know how many frame targetting issues are hiding down there I'll keep it
out for now.

Updated

18 years ago
Whiteboard: [PDT+]

Comment 3

18 years ago
Putting on the PDT+ radar.

Updated

18 years ago
Assignee: joki → rickg

Comment 4

18 years ago
Well I thought this was an issue with event handling in tables which I'd seen
but apparently its not.  The problem is that the span inside the link is forcing
the anchor closed.  This seems like its probably a parser problem.  I'm adding a
boiled down test case.

Comment 5

18 years ago
Created attachment 3329 [details]
Simplified test case for span inside anchor bug
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+]
(Assignee)

Comment 6

18 years ago
Given that this is just a residual style bug (which is fixed in my tree awaiting
the tree to reopen post-dogfood), I suggest demoting this problem.
(Assignee)

Comment 7

18 years ago
*** Bug 21108 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

18 years ago
Why?  It prevents anyone from using mozilla to read the interesting parts of
this CNET story (and presumably other CNET articles as well) since the story is
spread out among many pages and the links to successive parts of the story don't
work at all.

I was hoping to be able to use mozilla to read cnet, since its font sizes are
much better than 4.61. :-)

Updated

18 years ago
Whiteboard: [PDT+]

Comment 9

18 years ago
Putting on PDT+ radar.
(Assignee)

Comment 10

18 years ago
*** Bug 21240 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
may be related to 20557 and/or 20491

Comment 12

18 years ago
Created attachment 3515 [details]
very simple test case

Comment 13

18 years ago
I don't think this is related to 20557 and/or 20491. Those are both some sort of
table bug. This is just a span inside an "a" tag.
(Assignee)

Comment 14

18 years ago
Fixed in my tree. I'm trying really hard to land this by this weekend.
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] [12/19-12/22]

Updated

18 years ago
Blocks: 22176
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

18 years ago
Fixed by landing of residual style handling.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 16

18 years ago
Fixed in the Dec 22nd build (1999122208).

Comment 17

18 years ago
*** Bug 22452 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
*** Bug 22602 has been marked as a duplicate of this bug. ***

Updated

18 years ago
No longer blocks: 22176
You need to log in before you can comment on or make changes to this bug.