Folders and files with non-latin characters don't show up

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Andre-John Mas, Assigned: smontagu)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I have a folder which contains files and folders whoes name contain non-latin
characters, such as cyrillic and chinse idiograms. Browsing this folder with the
file:// protocol I only see the files with latin characters. I should also note
that the file:// protocol appears to be insisting on displaying in cp1225. This
is an issue since Windows stores long file names in UTF8. This is observed with
the release version of 1.4, and I am certain it effects previous version. I can
not confirm whether this issue affects other platforms.

Reproducible: Always

Steps to Reproduce:
1. Ensure that all possible languages are checked in the regional-options
control panel. 
2. Create folder containing files with name using non-latin characters, such as
cyrillic - you can use 'character map' to help you.
3. Browse the folder and see the results.


Actual Results:  
As described in the details above.

Expected Results:  
A) displayed the page in UTF8
B) displayed ALL the files and folders in the directory

Comment 1

14 years ago
-> i18n
Assignee: darin → smontagu
Component: Networking: File → Internationalization
QA Contact: benc → ylong

Comment 2

14 years ago
Seems it has dup bug(s), couldn't find an exactly one (bug 188383 may related).
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

12 years ago
This issues is dependent on bug 239279 (Need Mozilla binary that supports
Windows unicode API) being fixed. This issues will probably resolve itself once
the bug is corrected.

I can also confirm through tests that this is an MS-Windows specific issue,
since the behaviour is correct in MacOS X.
Depends on: 239279
Status: UNCONFIRMED → NEW
Ever confirmed: true
Testing with Firefox 2.0 in Win XP Pro, I can confirm that this bug is fixed, at least in this platform.  So I'm going to close this bug.  If it isn't fixed in Win2000 or if you find it's not fixed, please reopen it or write a comment here.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

11 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

11 years ago
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
I suppose the fix of this bug is a direct or indirect consequence of fix of bug 162361 or bug 332123 or similar bugs.  But fix is fix, who cares? ;)

Comment 8

11 years ago
Let's get the dependency right. 
Status: RESOLVED → REOPENED
Depends on: 162361, 278161
No longer depends on: 239279
Resolution: WORKSFORME → ---

Comment 9

11 years ago
now mark it as fixed. fixes of bug 162361 and bug 278161 fixed this bug.

Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.