Frames: Printing should be enabled only if a frame has focus

VERIFIED INVALID

Status

()

Core
Printing: Output
P1
major
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: shrirang khanzode, Assigned: Chris McAfee)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using mozilla 5.0, Go to the link mentioned above.
Observe that a page with two frames pops up.
Click on the 'File' menu(without clicking the mouse on any frames).
Observe that the 'PRINT' button is enabled.

Using 4.7, I see that if a page with frames loads up, then opening the file menu
grays out all the print related buttons unless a frame is selected explicitely
with the mouse, and instead of a PRINT button( as seen in mozilla 5.0) there is
a "Print Frame" button. Do not know if this is a desired feature for 5.0....

Updated

19 years ago
Assignee: saari → don
QA Contact: sairuh → shrir

Comment 1

19 years ago
assigning to don,not sure who will implement print frame menus, saari is backend
menus engineer so I don't think he should get this bug.
(Assignee)

Updated

19 years ago
Summary: Different behaviour on 5.0 and 4.7 PRINT buttons → Frames: Printing should be enabled only if a frame has focus
(Assignee)

Comment 2

19 years ago
new summary
(Assignee)

Updated

18 years ago
Assignee: don → mcafee
Target Milestone: M14
(Assignee)

Comment 3

18 years ago
mcafee

Updated

18 years ago
Priority: P3 → P1

Comment 4

18 years ago
This will cause a usability problem. It would be pretty difficult for your
mother to work out that printing is disabled because no frame is currently
selected.

Surely a better solution is to make sure there always *is* a frame with focus?
And that way, you wouldn't have to completely un-fix this bug when bug 23659
(or bug 7201) is fixed.

Comment 5

18 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus
(Assignee)

Comment 6

18 years ago
m15
Target Milestone: M14 → M15

Comment 7

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Updated

18 years ago
Target Milestone: M16 → M18

Comment 8

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21
(Reporter)

Comment 9

18 years ago
*** Bug 32865 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
[Not a menu problem]
Component: XP Toolkit/Widgets: Menus → XP Apps: GUI Features
OS: Windows NT → All
Hardware: PC → All
Netscape nav triage team: per Alec Flett's pre-triage recommendation, this 
bug is nsbeta1-.  Changed component to printing.
Component: XP Apps: GUI Features → Printing
Keywords: nsbeta1-
(Reporter)

Comment 12

17 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay

Comment 13

17 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Updated

17 years ago
Depends on: 64841

Updated

17 years ago
No longer depends on: 64841

Updated

17 years ago
Blocks: 64841
I think this bug is invalid. in 6.x when you print and a frame is not selected
you are given the option to print all of the frames in the document. In 4.x you
can only print the selected frame, it does not have the capability to print all
of the frames in the document.

Marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 15

17 years ago
verified in 4/3 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.