Talkback submission is not working - giving proxy error with no proxy involved

RESOLVED DUPLICATE of bug 210251

Status

RESOLVED DUPLICATE of bug 210251
16 years ago
10 years ago

People

(Reporter: mdeibler, Assigned: namachi)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4) Gecko/20030624

I had a browser crash that generated a talkback event.  It was queued and I
pressed the send key to send it in.  It looked like it was sent, but eventually
gave me a 'check proxy settings or try later' error.  I don't have a proxy
server in the mix on my network, so I checked the proxy settings in the talkback
agent.  I tried the auto-proxy settings on and off with no positive results. 
The talkback even is still queued, and I am still trying to send it in.

Reproducible: Always

Steps to Reproduce:
1. try to send queued talkback events
2.
3.

Actual Results:  
proxy error message

Expected Results:  
sent the talkback event and cleared the talkback agent queue

I tried searching for other talkback bugzilla bugs, but none seemed to describe
the situation that I had.  If I missed one, and this is a dup, I'm sorry.

This is really bad for two reasons.  First, I *THINK* the events are being
submitted and thus multiple bugs are being generated somewhere (one per
submission).  This obviously creates work for someone.  Second, users of the
browser now have a queue-full of talkback events that greets them every time
they start the browser - this is bad.  Their only option is to turn off
talkback.  This does NOT help the development community at all.

Also, I'm using WinME, but the OS list only has Win98 - it's close enough I guess.
OS: Windows 98 → Windows ME

Comment 1

15 years ago
I don't mean to just sound like a "me too", but I'm having this exact problem in
Mozilla 1.7 beta with Win XP Pro.  I can ping talkback.mozilla.org, and have
tried this without my firewall operating, but the crash report I'm trying to
send is still in queue.  Based on the messages in the window that pops up, I
believe that Talkback is connecting to mozilla.org, but something is
interfering.  Is it possible the wrong server has been specified or Talkback
isn't getting the right IP?  Is there a way to use talkback in some kind of
debug mode?
My trunk 1.8 build (2004-05-14-09) sends incidents almost immediately.

I know the server/db were having problems, is this fixed for you both now?
(Reporter)

Comment 3

15 years ago
I haven't had a 'crash' event to trigger a talkback in quite a while.  good for
mozilla, bad for the trouble-shooting of the bug.
Mike, could you try to reproduce bug 243669 or bug 243674?

That'll tell us if Talkback is working fine for you again.

Thanks!

Comment 5

15 years ago
I can confirm that this still occurs in 1.7.0 and 1.8a1+ (a2-2004052009) on
Win2000 and WinXP. A packet trace shows that Talkback is connecting and
transferring the data but the server stops ACK'ing the packets after 35 seconds
of transfer. It works fine on a fast link but a congested or slow link (e.g.,
dialup) doesn't work.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

14 years ago
*** Bug 287258 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 291707 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
Still happening with FF 1.5.0.1 win32

Comment 9

13 years ago
Hm, maybe some of these are yours: http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=url&match=contains&searchfor=www.idsoftware.com&vendor=MozillaOrg&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid

At least these are different from the Yahoo Mail crashes. Here it is obvious that Flash is to blame, all crashes occur there. I wonder however how Adblock Plus could trigger a crash here... Could you try to disable "show tabs on Flash and Java" in the options?

Comment 10

13 years ago
Oops... Sorry about bugspam, wrong bug :-(

Comment 11

13 years ago
This is a dup of bug 210251.  Please read through the relevant comments there and check out the first entry in the Talkback FAQ: http://wiki.mozilla.org/Mozilla_QA_Community:Talkback:FAQ

*** This bug has been marked as a duplicate of 210251 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 12

13 years ago
Removing Larry from the CC list.  Not sure who added him to this bug, but he did not wish to recieve any more bug mail, so taking him off.  If I removed the wrong Larry, please CC yourself back. ;-)

Comment 13

13 years ago
jay/et al, there's this handy link called "view bug activity" which is visible below the commit button. it's designed specifically to answer questions like "who added me to the cc list".

in this case, if you look at the timestamps, you'll see it matches comment 6 which is the automatic annotation for marking a bug as a duplicate. reporters of bugs that get resolved as dupes are automatically cc'd to the dupe. it's a one time cc because usually reporters want at least a bit of a chance of knowing what's going on.

now since this bug is resolved as a dupe, your larry is unlikely to get much spam anymore so removing him now is pretty pointless.

Updated

10 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.