Closed Bug 213402 Opened 17 years ago Closed 7 years ago

bookmarks folders should also have keywords

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: d97se, Unassigned)

References

Details

(Whiteboard: wontfix?)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030720 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030720 Mozilla Firebird/0.6

I would like to see keywords for the bookmark-folders, just like the ones for
bookmarks. Typing the keyword opens the bookmarks in that folder in tabs.

Reproducible: Always

Steps to Reproduce:
Valid enhancement request. Confirming to raise in on Pierre's radar and let him
decide, whether he wants to implement this or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of 137041?
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
FWIW, Epiphany on linux has this functionality
Gotta be a dupe of 137041.
no, that's a seamonkey bug.  The bookmarks code forked a long time ago.
*** Bug 261280 has been marked as a duplicate of this bug. ***
*** Bug 261690 has been marked as a duplicate of this bug. ***
I hope this isn't taken the wrong way, but IMO, this bug ought to be deassigned.
I'm not sure when Pierre took this, but it appears in summer 2003. I would take
if I knew how to fix it; I don't, but I doubt this can be that hard. Deassigning
might raise this to someone's awareness that does/would know what to do about it.
Unassigning it is highly unlikely to make any difference - anyone likely to pick
it up based on that will know that Pierre isn't around. Now that you've
commented and I'm adding to the bugmail anyway, may as well do it...
Assignee: p_ch → nobody
QA Contact: mconnor → bookmarks
My Mozilla crashed and when I brought it in my Bookmarks were no longer...is there a way to find old ones?

Thank you
Try the "Lost bookmarks" article on the MozillaZine KB or ask on the MozillaZine Forums or Mozilla's IRC, but Bugzilla is bad.
My two cents.  Keywords on folders would be really appreciated, but ...

Opening all bookmarks and folders within such folders would be a bad idea.
What would you do when 500 tabs open up and you didn't want any of them.

I would suggest that a keyword shortcut to a folder whould bring up the bookmarks
sidebar, or the Bookmarks Manager with the only folder name that has the keyword being highlighted (selected only but not invoked), so you can examine your choice(s).
I'd suggest entering a keyword opens only the bookmarks in that folder and not any subfolders. Also if the number of bookmarks to be opened is excessive, a dialog box should get confirmation from the user.
Duplicate of this bug: 385892
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Another reason to not open any bookmarks when opening a folder with a keyword is that bookmarks need not be simple references to a web page, but could be a bookmarklet, could be a keyword bookmark, could even be a chrome shortcut.  But basically if I open a folder I want to see what is in the folder and make my own choices, even if there is only one item it it.
Camino on OS X has had keywords for bookmarks for some time. To give an example of a way in which they have personally come in handy: 

I'm not one of those people who navigates entirely through the keyboard, but I am a keyword nut and have at least several dozen bookmarks that are keyworded by site name (favorite sites, saved searches, etc.). However, I also have several folders of bookmarks that I regularly check in groups, but at different intervals (daily news sites, weekly entertainment reviews, etc.). 

In Firefox, I need to keep these folders loaded in either my bookmark bar or bookmark menu to have fast access to them, and I need to mouse over to the folder to load them. I don't use the bookmarks sidebar for this because I'd have to find them amongst the glut of less frequently-browsed folders that I keep out my bookmark bar/menu folders for that reason.

In Camino, however, I just assign keywords to several existing folders and, consequently, I can load them in seconds and don't even need to keep my bookmark bar open (saving space on my laptop screen). 
Duplicate of this bug: 417291
This really would be a good feature to add. 

People generally tend to have a set of bookmarks in a folder that they interact with often. So having this option would definitely help.
Whiteboard: wontfix?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Late to the party, but this bug describes the functionality I'm looking for - I would love to be able to type in a keyword for a bookmark folder *just* like I can for bookmarks right now.

That means no bookmark sidebar, nothing out of the ordinary.  The functionality should be just like middle-clicking on the folder in the bookmarks sidebar: all tabs immediately open, and if there are too many the "You are about to open X tabs. Do you want to continue?" popup happens.

I wonder if an extension might be a better way to prototype this?
(In reply to comment #21)
> I wonder if an extension might be a better way to prototype this?
Yes.
Excellent idea. Found in Kmeleon. Would love to see it in Firefox (Pale Moon, in my case).
Extension material, not something we'll add to Firefox proper.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
An extension would be acceptable. This functionality may not be desired by all FF (and FF clone) users, but would be highly appreciated by users like me.
You need to log in before you can comment on or make changes to this bug.