Closed Bug 213672 Opened 17 years ago Closed 17 years ago

Implementing status bar as a normal toolbar

Categories

(Firefox :: Toolbars and Customization, enhancement)

enhancement
Not set

Tracking

()

VERIFIED WONTFIX

People

(Reporter: bugzilla, Assigned: hyatt)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I noticed that although Firebird's toolbars are very very customizable, it does
not treat the status bar as a toolbar. Which is a pity, coz if the status bar
too were treated as a normal toolbar, one could add the usual icons to the
status bar, or move the status bar displays to other toolbars, etc. The thought
of such an option came across me while using the Site Navigation Bar
(extension). This extension displays its buttons on the status bar, and I
realized how convenient it was to have the navigation icons at the bottom
(rather than the usual top). That was when I tried to (unsuccessfully) move the
Back and Forward to the status bar. (By the by, a browser that does allow this
is Opera.)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Well you could always move your OS taskbar to the top of the screen. I've done
that and it does cut down on the amount of mouse travel.

As to your request, it is not going to happen. See bug 150379 comment 16. See
also bug 192473.

That said, there should be a way to work around this if you're adept at
programming. Conceivably, an extension could be made to assign toolbar IDs to
the elements in the status bar, so that they could be put on one of the regular
status bars (or of course you could create a new toolbar and put them on that).
After that, it's a simple matter of some userChrome.css tweaks to hide the
status bar.

#status-bar {
display: none !important;
}

should do it

-->WONTFIX
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → WONTFIX
Taking QA Contact
QA Contact: asa → bugzilla
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED
*** Bug 233517 has been marked as a duplicate of this bug. ***
QA Contact: bugzilla → toolbars
Duplicate of this bug: 444750
Duplicate of this bug: 439413
Duplicate of this bug: 427282
Duplicate of this bug: 563313
You need to log in before you can comment on or make changes to this bug.