Closed Bug 439413 Opened 12 years ago Closed 11 years ago

Make everything (almost) a tool bar item

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 213672

People

(Reporter: brianvanderburg, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Currently the status bar is treated a little bit differently than tool bars.  However some extensions can support being installed in the status bar or as a tool bar item, and the tool bar item is just as useful, giving the status/etc.  An idea to make this even more customizable is to make almost everything a tool bar item.  The main window can consist of: tool bars, side bar, page view/tab area.  Each tool bar can be customized in position (top/bottom/left/right), each with different properties (buttons only,text only/small/large icons/shown during full screen).  All In One Sidebar provides much of that functionality.

One step further is to make the status bar a tool bar with the same options as above.  The status/url area would then be just another tool bar item, so would the loading progress meter, etc.  Extension developers could be encouraged to make their extensions have tool bar items and not status bar items.  This also allows the items to be configured in any order desired, where often the order of what is in the status bar is not customizable by the user.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Depends on: 264205
The severity of this bug should be marked as an enhancement.
But yes, great ideas.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213672
You need to log in before you can comment on or make changes to this bug.