Closed Bug 214121 Opened 21 years ago Closed 20 years ago

Form autocomplete appears in wrong place (position: absolute)

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugs, Assigned: hewitt)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1

If a form is nested in two absolutely positioned DIV tags (it may be other
absolutely positioned elements), then the autocomplete list will appear in the
wrong place (it will appear presumably where the field would be were it not for
the second DIV tag).

Reproducible: Always

Steps to Reproduce:
1. Load the example page
2. Start filling in the page's single form with keywords likly to trigger an
autocmplete box
3. Notice how the autocomplete box appears in the wrong location

Actual Results:  
Autocomplete was in the wrong place.

Expected Results:  
Put the autocomplete box in the right place (i.e. underneath the box)
Taking QA. Sorry for the bugspam
QA Contact: asa → davidpjames
Confirming on 20030729 with W2K
Status: UNCONFIRMED → NEW
Ever confirmed: true
Seeing in Linux as well.

OS --> All
OS: Windows XP → All
Summary: Form autocomplete appears in wrong position on the page → Form autocomplete appears in wrong place (position: absolute)
*** Bug 220068 has been marked as a duplicate of this bug. ***
*** Bug 224582 has been marked as a duplicate of this bug. ***
Hardware: PC → All
*** Bug 225907 has been marked as a duplicate of this bug. ***
Still occurs with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031228
Firebird/0.7+
while posting to The Burning Edge (!) - WinXP SP1
I can't see the dropdown at all on
http://www.squarefree.com/burningedge/archives/000236.html.  Keypresses act as
if the dropdown were there, so I guess it's just way offscreen.  My resolution
is 800x600.
Same problem on http://www.lycos.de/, which uses position:relative.
Has this bug been abandoned? Joe Hewitt has "(gone)" in his name.
"This" bug hasn't been abandoned; rather, the entire Autocomplete component has
essentially been "abandoned" until such time as someone takes over from Joe
Hewitt. See bug 222184.

www.lycos.de and testcase is WFM.
build: 20040302, Windows 2000
WFM at http://www.squarefree.com/burningedge/archives/000236.html too.  I wonder
when/how this was fixed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219
Firefox/0.8.0+
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
*** Bug 236985 has been marked as a duplicate of this bug. ***
*** Bug 239650 has been marked as a duplicate of this bug. ***
This bug still exists in FireFox 0.9 on Windows with dual monitors.  Position
the secondary monitor to the left of the primary monitor and all toolbar,
autocomplete and bookmark popups open up in the right hand monitor ('primary'
monitor)
(In reply to comment #17)
> This bug still exists in FireFox 0.9 on Windows with dual monitors.  Position
> the secondary monitor to the left of the primary monitor and all toolbar,
> autocomplete and bookmark popups open up in the right hand monitor ('primary'
> monitor)

That is antoher bug, occuring when having dual monitors. Dont know exaclty what
the bug number is, but you should find it in the meta bug 236647
You need to log in before you can comment on or make changes to this bug.