Spell Checker should have an option to ignore Capitalized words in the middle of a sentence

RESOLVED DUPLICATE of bug 391672

Status

()

Core
Spelling checker
--
enhancement
RESOLVED DUPLICATE of bug 391672
15 years ago
9 years ago

People

(Reporter: Dave Evans, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Spell Checker should have an option to ignore Capitalized word in the middle of
the sentence.  This would help solve bug 214505

Reproducible: Always

Steps to Reproduce:
1.Compose an email "Hi Bobert Jackny, how are you doing?"
2.Hit Send
3.

Actual Results:  
Spell Check catches "Bobert" and "Jackny"

Expected Results:  
Have a preference setting to allow spell-check to ignore capitalized words

Comment 1

15 years ago
triaging
Target Milestone: --- → After Thunderbird 1.

Updated

15 years ago
QA Contact: asa

Comment 2

14 years ago
*** Bug 267326 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
My bug was not really a duplicate since it went to far as to extend ignore
options to domains and e-mail addresses.

The Spell checker also ignore text in the following instances.

Domain names, If a period is not followed by a whitespace then everything in
front of and after the period should be ignored to the next whitepace

goober. 
would not be ignored for instance
but
goober.com would be
or smtp.goober.com would be ignored.

Likewise in an e-mail address blob@domain.com would be ignored.  although, if
you ignored text in front of and after a period, it would be ignored anyway by
the first example.

Comment 4

14 years ago
(In reply to comment #3)
> My bug was not really a duplicate since it went to far as to extend ignore
> options to domains and e-mail addresses.

See bug 172186, bug 234936 (I don't know why those aren't dupes).  I'm actually 
not seeing spellcheck flags on email addresses or URLs, but I do on domain 
names.


The task of determining "in the middle of a sentence" requires a lot more 
intelligence than the current spellchecker has.  For instance, the dupe wanted 
to avoid flagging the name in the case of "Dr. Blempers" -- if that period is 
used to determine the end of a sentence, then "Blempers" will be flagged.

On the other hand, simply ignoring all words that begin with a capital will miss 
the misspellings such as "Acutally, I think this bug is not worth fixing."  In 
some cases, I might deliberately add a Very Impotrant Misspelling which I would 
want flagged.

I'd rather put up with the false-positives than miss the things I care about.

Comment 5

14 years ago
That is a most valid point, I neglected to considering mispellings on words at
the beginning of a sentence, but you could also include common prefixes.

Dr. Mrs. Ms. Prof. Mr.

so that it would not check the words after the prefixes.  And then following
standard punctuation rules establish when a normal word should be checked even
if capitalized.

Updated

13 years ago
Component: Message Compose Window → Spelling checker
OS: Windows 2000 → All
Product: Thunderbird → Core
Hardware: PC → All
Version: unspecified → Trunk

Comment 6

12 years ago
*** Bug 344687 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Just copying some text from my dup. My text editor of choice has these options:

Case sensitive
Ignore capitalized words (e.g. England)
Ignore single letters (e.g. b)
Ignore words in capitals only (e.g. ASAP)
Ignore words with mixed case (e.g. TextPad)
Ignore words with numbers (e.g. Win98)

It also has a setting that defines what a "word" is, but I can't seem to find it right now. IIRC it was a regex pattern.

BTW, is the spell checker in Minefield based on some other package like ispell or Aspell? I found both of those words in the dictionary, which leads me to believe it might be the later. 

Comment 8

11 years ago
On a related note the Spell Checker (including version 2.0.0.9) does weird things with mis-capitalized words.

For Example: 
1) "WHen" returns "Wren, whens, hen, wen, then". Why isn't the obvious choice of "When" presented?
Further were does this dictionary come from? "whens" is not an English word. (When's could be considered a contraction of "when is" but that's about as close as you get).

2) "SPell" returns "Snell, Shell, Skell, spell, ispell". This is closer, at least we got "spell" in the list though not as the first choice and not with proper capitalization.

Updated

11 years ago
Duplicate of this bug: 374474

Updated

11 years ago
QA Contact: spelling-checker

Comment 10

11 years ago
> "SPell" returns [snip] "ispell"

Well that answers that question... :-)

Updated

10 years ago
Assignee: mscott → nobody

Comment 11

9 years ago
Comment #8: Fixed by Hunspell. 

Recognizing the middle of a sentence (and doing it right) requires a grammar checker. Bug 395327.

The rest of this falls under Bug 391672 --> DUPLICATE.

Thanks for the comments everyone, but please try to keep bugs about a single issue.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391672

Comment 12

9 years ago
Last time I checked 214518 < 395327 or 391672 so it would be pretty much impossible for us to have seen those bugs at the time this one was opened.

Therefore 391672 must be a duplicate of this bug.

Comment 13

9 years ago
Hi Thorin, as far as I know any bug can be marked a duplicate of any other bug. 

The clearest bug should win, and this one has multiple issues all of which are better covered by other bugs.
You need to log in before you can comment on or make changes to this bug.