bookmark keyword cannot be used to open bookmark in sidebar

RESOLVED WONTFIX

Status

()

P3
minor
RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: mconnor, Unassigned)

Tracking

({polish})

Trunk
polish
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
using a bookmark keyword loads the link in the main content area, not the web
panel, even when it is a valid Web Panels bookmark.  

Not sure whether we want to support this, but I don't see a reason why not to.
(Reporter)

Comment 1

15 years ago
*** Bug 215658 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
*** Bug 223882 has been marked as a duplicate of this bug. ***
We should support it because there is no difference to other bookmarks with
keywords. Otherwise the keyword box has to be disabled or removed for bookmarks
which are selected as sidebar.

I like the way to open bookmarks with keywords. Its really fast and you don't
have to navigate throught the Bookmarkfolders. So we should support this way of
opening within the "web panel" vs. "sidebar". 

Comment 4

15 years ago
taking
Assignee: hyatt → p_ch
(Reporter)

Comment 5

15 years ago
*** Bug 230000 has been marked as a duplicate of this bug. ***
I updated the summary to get a search result for 'sidebar'. 'Web panel' is
rarely used.

Always confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040110 Firebird/0.8.0+ (mozJF).
Hardware: PC → Macintosh
Summary: bookmark keyword cannot be used to open web panel bookmark → bookmark keyword cannot be used to open bookmark in sidebar

Updated

15 years ago
OS: Windows 2000 → All
Hardware: Macintosh → All
HW/OS -> All

Updated

15 years ago
Flags: blocking1.0?

Updated

15 years ago
Flags: blocking1.0? → blocking1.0+
Priority: -- → P4
i'd like to fix this bug. however, firstly, is there anybody that can tell me
how to set a keyword for a book mark in keyworkd field( i tried "a", "alt+a" and
"ctrl+a". and it didn't work)
(In reply to comment #8)
> i'd like to fix this bug. however, firstly, is there anybody that can tell me
> how to set a keyword for a book mark in keyworkd field( i tried "a", "alt+a" and
> "ctrl+a". and it didn't work)

You have only to add characters like "bug" to this field. If you want to open
the associated bookmark you have to set the focus to the address bar by hitting
"Ctrl+L" or using the mouse. Now you enter "bug" and press return. The correct
URL will be opened. For sidebar URLs it should be happen inside the sidebar and
not the main window. 

Good luck and if you have questions just ask them here or in IRC.
is there a way to get RDF source from url string?
Attachment #155760 - Flags: review?(bugs)
(Reporter)

Comment 12

14 years ago
*** Bug 260512 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
p4 priority - not a blocker. if a fully reviewed patch materializes, please
nominate for aviary approval. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-

Comment 14

13 years ago
*** Bug 327807 has been marked as a duplicate of this bug. ***
Attachment #155760 - Attachment is obsolete: true
Attachment #155760 - Flags: review?(bugs)
this bug depends on what happens with bug 329964, I guess. Probably invalid, since this functionality will have to be reimplemented anyways.
Assignee: p_ch → nobody
QA Contact: mconnor → bookmarks

Comment 16

12 years ago
*** Bug 351594 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 405246

Comment 18

11 years ago
(In response to comment #15)
>this bug depends on what happens with bug 329964, I guess. Probably invalid,
>since this functionality will have to be reimplemented anyways.

bug 329964 has been fixed, but the fix to this problem hasn't been reimplemented in the process.  I'm requesting it be fixed for Fx3.  Ria Klaassen suggested to me at https://bugzilla.mozilla.org/show_bug.cgi?id=405246#c1 , that instead of filing the separate bug report 405246, I should flag a request here for blocking‑firefox3.  I have just done that.

Sorry I don't have a patch to go along with this request, but I'm not a developer.  I just didn't want this bug -- reported by Mike Connor over four years ago -- to be overlooked.
Flags: blocking-firefox3?
Moving to Places while this definitely won't be fixed for Firefox2 and it's still an issue for Places. Removed old priority flag.
Component: Bookmarks → Places
Priority: P4 → --
QA Contact: bookmarks → places
Version: unspecified → Trunk
Flags: blocking-firefox3? → blocking-firefox3-

Comment 20

11 years ago
I hope that at some point this gets fixed in FF3.  The sidebar can be a powerful tool, but only if it's easily accessible.
Selecting a bookmark we run following code (as far as I was able to follow):
http://mxr.mozilla.org/seamonkey/source/browser/components/places/content/controller.js#635

But which function is executed when hitting Enter within the urlbar, clicking the go button or using the open dialog? Are this different implementations or do they call a core function?

I tried to get this and ended here:
http://mxr.mozilla.org/seamonkey/source/docshell/base/nsIWebNavigation.idl#231

No idea if this is correct. Anyone who knows that?

Comment 22

11 years ago
I was going to file this as a bug myself, but found this one first.  I hate to whine, but this has been open for nearly 5 years.  Is there some reason why users can't create bookmark keywords to load in the sidebar?  If it's a design decision, could we get another way to make a sidebar bookmark?  Maybe something to the effect of bookmarking chrome://path.to.sidebar?url=domain.com?

Marko or Alex, any idea if we could solve this issue in the near future? No idea how complex the patch will be. But doesn't sound complicated.
Keywords: polish
Priority: -- → P3
Whiteboard: [good first bug]

Comment 24

10 years ago
I would like to comment as well if we could hear the status of fixing this, and what can be done.  It shouldn't be too complicated at all one would think, but then again I am not familiar with the code.

This would be a -wonderful- feature to have, especially with the development of more and more sites that work great in sidebars such as Weather Underground, Google Gmail/Notebook/Talk/Calendar/Tasks/Etc, and many many more.  Simply being able to use a keyword to open the sidebar with valuable sites such as those and more would improve draw to Firefox.

Comment 25

9 years ago
oh please solve this issue, somebody! and make it work for quicksearch bookmarks, too! (I don't think this has been mentioned above yet)

By quicksearch bookmarks, I mean bookmarks that have a keyword set, and that submit everything entered behind this keyword as part of the bookmark's url. E.g. a bookmark of the following kind:

Name: Google
Location: http://www.google.at/search?q=%s
Keyword: gg
Load this bookmark in sidebar: Yes

This bookmark should enable the following behavior: When I enter "gg firefox" into the firefox address bar, the url "http://www.google.at/search?q=firefox" should be opened in the sidebar.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

8 years ago
Depends on: 560305
Seems that all the functionality has ben switched to the Places API, so the old files has changed. Anyone could check this?

Updated

6 years ago
Whiteboard: [good first bug]
We're planning to remove "open in sidebar" (bug 560305), so we're not going to fix this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.