Can't import messages/address books/settings from Mozilla to Thunderbird

RESOLVED DUPLICATE of bug 63389

Status

Thunderbird
Preferences
RESOLVED DUPLICATE of bug 63389
15 years ago
4 years ago

People

(Reporter: JonStipe, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Thunderbird currently gives the option of importing stuff from Eudora, Outlook,
Outlook Express, Communicator 4.x, and text files... but not from Mozilla. There
is currently no easy way to import messages, address books, or settings from
Mozilla to Thunderbird, or vice versa, which makes it kinda hard to switch.

Reproducible: Always

Steps to Reproduce:
1. Open Tools > Import.
2. Select "Mail", then click "Next".
3. Read the list of programs.
Actual Results:  
Mozilla is not listed.

Expected Results:  
Mozilla should be listed.

4. Now click "Back", select "Address Books", and click "Next".

Actual Results:
Mozilla is not listed.

Expected Results:
Mozilla should be listed. Yes, I know you can export address books to a text
file and import that, but it should be possible to do it directly. And you can't
do that with mail or settings, anyway.

5. Now click "Back", select "Settings", and click "Next".

Actual Results:
Mozilla is still not listed.

Expected Results:
Again, Mozilla should be listed.

Thunderbird is supposed to be based on Mozilla, so importing stuff from it
should be easy.

Updated

15 years ago
QA Contact: asa

Comment 1

15 years ago
this seems to be related to bug 121725 - no way to import mozilla mail settings
from one profile to another. this is a bug that's been open since before version
0.9.9, it is indeed making it fairly hard to switch.

Comment 2

14 years ago
this bug is present in Mac OS X too, so bug OS should be all. and I agree,
import from mozilla should be a top priority for anyone working on the new
"suite". Otherwise what is the point of having a next generation. Tbird should
at least be able to import from a format Moz can export to, if not the normal
Moz files themselves.
Changed:

OS to ALL
OS: Windows XP → All

Comment 4

14 years ago
I really hope someone gets around to this soon, it's a bit unusual to be able to
import mail from Eudora, but to have to copy folders and edit preferences.js for
the two mozilla mail programs.

Just to include some docs for others who have had the problem: here's the
migration procedure as it was described to me (thanks to Mabus and Hendikens on
#mozillazine):

1) Go to %APPDATA%\Mozilla\profiles\default\<random>.slt\ and get the \mail
\imapmail etc.. folders you want, and copy them to
%appdata%\thunderbird\profiles\default\<random>.slt\
2) then delete all the .msf files in there to force a rebuild of the summary data.
3) Copy prefs.js if you don't want to setup your accounts again.
4) you'll need to edit prefs.js by hand after copying it - just copy from
%Appdata%\mozilla\profiles\default\<random>.slt\prefs.js to your thunderbird
profile directory, edit all parts of it that contain a path.

Thunderbird Help has a tutorial: http://texturizer.net/thunderbird/faq.html#q2.2

Cheers,
Dave.

Comment 5

14 years ago
*** Bug 245674 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
While I agree that having Mozilla listed should be a must, I also only see
"Communicator 4.x" in my case (running under Linux, TB 0.7.1, new install with
no account set up). I would like to be able to import from Mozilla and Eudora
(...) even if the last one doesn't exit on the OS I am using.

Comment 7

14 years ago
*** Bug 249857 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
I'd strongly suggest a higher priority on this bug, also on the Mozilla mail
component with same problem. 

To the wanted scenarios, also add reinstalling windows and having your profile
data saved somewhere. now have to do it manually. 
Mozilla/Thunderbird option in all 3 cases (mail/address book/settings).

Also, nobody noticed, but it's kinda odd, duh! 
Can't import my own application's mail/addressbook/settings? Really.

Comment 9

14 years ago
I finally exported my Mozilla address books and imported them manually into
thunderbird, which works fine. A minor inconvenience, but not a big deal.

Perhaps a small note to that effect could be added to the docs somewhere? As a
FAQ, perhaps?

Cheers,
Dave.
(Assignee)

Comment 10

14 years ago

*** This bug has been marked as a duplicate of 248047 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 11

14 years ago
(In reply to comment #10)
> 
> *** This bug has been marked as a duplicate of 248047 ***

Strange, if this bug is fixed, why can I still not import mails and addresses
from Mozilla with Thunderbird 0.7.3 on Windows? I only see Communicator 4,
Eudora and Outlook in Tools/Import.

Comment 12

14 years ago
I am with Asa's bug 215306 comment 18 thinking that this bug should not have
been marked duplicate of bug 215306 for this one to track the tools/import part
of this issue.

(In reply to comment #11)
> Strange, if this bug is fixed, why can I still not import mails and addresses
> from Mozilla with Thunderbird 0.7.3 on Windows?

Maybe because it is going to be in version 0.8 only... If you are impatient to
have this feature, you can get the latest 0.8 nightly.

Comment 13

14 years ago
Sorry, typo:

I am with Asa's bug 248047 comment 18 thinking that this bug should not have
been marked duplicate of bug 248047 for this one to track the tools/import part
of this issue.

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 14

14 years ago
Import Mozilla mail is bug 63389. For the other things (addressbook etc.) see
bug 187564, bug 22689, and Bug 121725. Marking as dupe of the first.


*** This bug has been marked as a duplicate of 63389 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.