Closed Bug 121725 Opened 20 years ago Closed 11 months ago

Import mozilla addressbook (mab)

Categories

(MailNews Core :: Import, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1664359
Future

People

(Reporter: p_ch, Unassigned)

References

Details

Linux build, 2002 01 21 21
Bug 72400 was originally about importing addressbook from another mozilla profile.
It has morphed into a much broader extent.
Sorry if I missed sth, but after the fix, it's still not possible to import
Mozilla addressbooks.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
KW: mozilla0.9.9 and nsbeta1, please (for parity with bug 72400).
Keywords: mozilla1.0, nsbeta1
Discussed in 2/28/02 Mail & News bug meeting.  Decisions was to minus this bug.
 Workaround is to export/import to .ldif file.
Keywords: nsbeta1nsbeta1-
Target Milestone: --- → Future
*** Bug 138277 has been marked as a duplicate of this bug. ***
*** Bug 149821 has been marked as a duplicate of this bug. ***
*** Bug 165489 has been marked as a duplicate of this bug. ***
Though there was decision to forget about that feature, i still do a new run ;-)

Beeing tester of mozilla I now had the situation, that parts of my profile were
broken, especially prefs.js. The status:
- Luckily all the *.mab files are ok
- None of the files are found anymore within addressbook tool
- I tried to rebuild the entries in localstore.rdf and others, but its really
complicated (my problem is solved)

So, what's my result:
- a normal user must throw away all adresses and restart from zarro
- one could write an extra 'repair'-tool to convert the *.mab to *.ldif, 
  freeing from further demands
- but I think its the better way to integrate it in mozilla from beginning
*** Bug 200210 has been marked as a duplicate of this bug. ***
mass re-assign.
Assignee: racham → sspitzer
this is an old bug, but it's causing new problems. users trying to switch from
mozilla to thunderbird can't import mail or settings (bug 215306), still no easy
way to import / export entire profiles (ie, when changing computers, or copying
settings from a home computer to a work system, etc.)

having to export all addresses as text then re-import is silly. we know moz mail
can read a moz address book, what does it take to get it to go from reading it
to copying into the current one?

sure, people who have used moz/moz mail for a while can manually copy files &
settings, edit the names of profile directories, and so on, but until this &
related bugs are fixed the average user isn't going to have a clue how to move
their settings onto a new computer.
No longer blocks: profile-corrupt
I agree, this is a no-brainer. Thunderbird should import from Mozilla or a
format Mozilla can export to.
OS: Linux → All
Hardware: PC → All
Product: Browser → Seamonkey
Assignee: sspitzer → nobody
Component: Address Book → MailNews: Import
Product: Mozilla Application Suite → Core
QA Contact: nbaca
*** Bug 289576 has been marked as a duplicate of this bug. ***
*** Bug 289574 has been marked as a duplicate of this bug. ***
*** Bug 295325 has been marked as a duplicate of this bug. ***
*** Bug 136957 has been marked as a duplicate of this bug. ***
This extension has a workaround.
MoreFunctionsForAddressBook
http://nic-nac-project.de/~kaosmos/morecols-en.html
- possibility to import/export the addressbooks in the native format (file mab);

This function would have saved lots of time setting up Tb 2 on a new Vista box.  I worked around by generating dummy abook-1.mab and then over writing with file from  a salvaged HDD through a USB connection. The LDIF import is only usable if the source is a functional system w/Tb Abook able to run and generate the LDIF. When the OS is dead and the HDD's file strucure is intact, a *.mab import is the only way to save the contacts data.

Nominating as Wanted for Tb 3.0
Flags: wanted-thunderbird3?
QA Contact: import
Product: Core → MailNews Core
I'm going to mark it wanted+ because it should be simple to do - but I could see marking it wanted- based on our new driver criteria
https://wiki.mozilla.org/Thunderbird:Release_Driving
Flags: wanted-thunderbird3? → wanted-thunderbird3+
Duplicate of this bug: 473083
Duplicate of this bug: 763754
Summary: Import mozilla addressbook → Import mozilla addressbook (mab)
Extensions are often written only for Thunderbird or Firefox. Despite the fact that these addons would function on SeaMonkey, they cannot be installed without unpacking the extension and tinkering with the installation code. I would nominate the functionality of the extension to be imported into the trunk if it is a viable and simple solution.

(In reply to Ronald Killmer from comment #15)
> This extension has a workaround.
> MoreFunctionsForAddressBook
> http://nic-nac-project.de/~kaosmos/morecols-en.html
> - possibility to import/export the addressbooks in the native format (file
> mab);
> 
> This function would have saved lots of time setting up Tb 2 on a new Vista
> box.  I worked around by generating dummy abook-1.mab and then over writing
> with file from  a salvaged HDD through a USB connection. The LDIF import is
> only usable if the source is a functional system w/Tb Abook able to run and
> generate the LDIF. When the OS is dead and the HDD's file strucure is
> intact, a *.mab import is the only way to save the contacts data.
> 
> Nominating as Wanted for Tb 3.0
(In reply to Michael Buckland from comment #2)

This is not a viable work-around.

Just curious as to where Mozilla is on address book format. Are they putting off a revamp or avoiding another standard such as vCard. You have working profile. Suddenly Thunderbird decides to create a new one out of the blue. Now you got your contacts in mab files in the abandoned profile. I'll just have to download some hackware out there that will import the files and hope I don't lose important information and additional information that is not transferrable due to the oddities of mab format.
See Also: → 1681685
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1664359
You need to log in before you can comment on or make changes to this bug.