If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mechanism to load supressed images per message

RESOLVED DUPLICATE of bug 216133

Status

Thunderbird
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 216133
14 years ago
14 years ago

People

(Reporter: Jake Zukowski, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

This is related to bug 179568, but is a bit broader.  Some e-mails are not spam,
but have spam portions to them.  A notorious example is Yahoo Groups.  Every
time you receive a mail from them, the top of the message is an advertisement,
an HTML image.  You used to be able to opt for Plain Text only, but that option
has since been removed.

Reproducible: Always

Steps to Reproduce:
1. Sign up for a group at groups.yahoo.com
2. Have the group mail be sent to an account set up in Thunderbird
3. Receive a message

Actual Results:  
The top spam portion of the mail loads

Expected Results:  
The graphics should not load, with an option to load the graphics if you choose

This is related to 179568.

If I had my way, I would design the feature as follows:
Put an option in Display downloading remote images.  Text would read "When an
HTML message has remote images," [dropdown box: "always display the images, "let
me choose to display the images", "never display the images"]   

Behaviors for options 1 and 3 are patently obvious.

Behavior for option 2 should give the user an unobtrustive way to download
images.  Best implementation I've seen is in Office Outlook 2003.  At the top of
the message, it states "Click here to download pictures. To help protect your
privacy, Outlook prevented automatic download of some pictures in this message."

Throwing a dialog asking to download the images would be a bad user experience.

Comment 1

14 years ago
Try Tools -> Options -> Advanced -> Privacy -> Block Loading of Remote Images in
Mail Messages.
Summary: preference to supress load of remote images → preference to supress load of remote images
(Reporter)

Comment 2

14 years ago
Sure, that works.  But what's the mechanism to show the images?  Do I always
have to go to Options?  The Outlook method still seems most reasonable to me.

Comment 3

14 years ago
So you're thinking of maybe a toggle that will switch between viewing/blocking
remote images?  This has been brought up in #216133.

I suggest that we combine the two under one bug #.
(Reporter)

Comment 4

14 years ago
Yep, sounds like the exact same feature request.  I would have no problems with
combining them.
(Reporter)

Comment 5

14 years ago
Changing for a more descriptive title.
Summary: preference to supress load of remote images → mechanism to load supressed images per message

Updated

14 years ago
QA Contact: asa

Comment 6

14 years ago
the other bug is already assigned to scott, so I'm marking this one as dupe

*** This bug has been marked as a duplicate of 216133 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.