with imap account, if i set my sent-mail folder to Inbox (by selecting Inbox->Choose this folder in account preferences), sent mail is stored in INBOX.INBOX

RESOLVED DUPLICATE of bug 248080

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 248080
15 years ago
9 years ago

People

(Reporter: Mike Eheler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-12-28)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: ftp://ftp.mozilla.org/pub/thunderbird/nightly/2003-08-07-trunk

In Account settings under Copies & Folders for any given account, in the
grouping When sending messages, automatically:
[x] Place a copy in:
(o) Other: Inbox on account name

The mail server I'm using is a cyrus imap server, and all folders are "under"
INBOX (i.e. INBOX.Drafts, INBOX.Templates, etc.).

As far as I know, this behaviour has always been.

Reproducible: Always

Steps to Reproduce:
1.Open account settings 
2.Goto Copies & Folders section of any Cyrus IMAP (was unable to test on any
other imap servers) account
3.For sending messages, enable Place a copy in: and set it to Other then select
Inbox on account name -> Choose this folder

Actual Results:  
Sent mail is not stored in INBOX, but rather INBOX.INBOX is created and messages
are stored there instead.

Expected Results:  
Saved the message to INBOX.

Comment 1

15 years ago
Surely you'd put your sent mail in the 'Sent' mail folder on IMAP. Can't see the
point of putting sent email in your IMAP INBOX..?
(Reporter)

Comment 2

15 years ago
Where I put it doesn't matter.. fact is this should work as expected, and yet it doesn't. 
 
With this particular IMAP server setup all folders must reside under INBOX, for example: 
 
INBOX.Drafts 
INBOX.Templates 
INBOX.sent-mail 
 
etc, etc. 
 
So when I set up a new IMAP account in mozilla, I have to change all of my folder defaults. 
 
The reason I want to put sent-mail into my inbox is to have a mailbox that has a news-style 
threaded layout.. easy access to all emails in a particular thread of email. 

Comment 3

15 years ago
I'm told by my collegue (who just set up cyrus with tbird) that cyrus stores the
inbox as a different format to other folders (why I don't know). This prevents
Tbird from storing it in the Inbox. I'll check more specifics tomorrow.
(Reporter)

Comment 4

15 years ago
Hrm that doesn't make much sense. All my incoming emails are saved to INBOX, and I have 
no problem moving emails to INBOX.. the problem is that if I choose INBOX 
(Account->Inbox->Choose this Folder) as my Sent folder, then the sent emails are stored in 
INBOX.INBOX, which is created if it does not exist.. why can't the messages simply be saved 
to INBOX? 
 
Yes, Cyrus is different, but this is possible, and needs to be addressed. :) 
 
Mike 

Updated

15 years ago
QA Contact: asa

Comment 5

15 years ago
Thunderbird 0.4 relase on FreeBSD
UW-IMAP mail server

I was able to set thunderbird to put sent mail in Inbox and it worked correctly.
Sent items were placed in Inbox as specified.

Comment 6

14 years ago
I've seen this bug as well, on various platforms and releases. Currently, on MacOS X 10.3.5, the bug 
does NOT appear in Mozilla 1.6 Mail & Newsgroups, but DOES appear in 1.7.2, and does NOT appear on 
1.8a2. The extra INBOX.INBOX can't be deleted from the Mail & Newsgroups GUI; I ended up writing a 
Python script to delete it programmatically. One useful clue might be that when you go to "Edit -> Mail 
& Newsgroup Account Settings... -> <account> -> Copies & Folders" (where <account> is your 
account name), the "Other" menu for "Place a copy in:" says "Inbox on <account>" when the bug 
doesn't appear, and "<account>" when it does. If you try to change it in the faulty versions by selecting 
"<account> -> Inbox -> choose this folder", and you select "OK", when you reopen the account 
settings panel, it will now say "INBOX on <account>". 

To answer James Green's comment, the reason to put your sent mail in Inbox is that it's far easier to 
read your email threads. I've never understood the point of a separate Sent folder.

Comment 7

14 years ago
This is what happens with Courier IMAP in Thunderbird 0.9.2 release. It is
failing to create an INBOX folder as a subfolder of INBOX.

* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT
THREAD=REFERENCES SORT QUOTA IDLE STARTTLS] Courier-IMAP ready. Copyright
1998-2003 Double Precision, Inc.  See COPYING for distribution information.
1 login "removed" "removed"
1 OK LOGIN Ok.
2 list "" "INBOX.INBOX"
2 OK LIST completed.
3 create "INBOX.INBOX"
3 NO Cannot create this folder.
QA Contact: front-end

Comment 8

10 years ago
do you see this with bug with courier imap?

Updated

10 years ago
Assignee: mscott → nobody

Comment 9

10 years ago
Is this problem gone for you?   (reporter's email address is invalid)

by title at least, this reads as a dupe of bug 248080, which is fixed.
Whiteboard: closeme 2008-12-28

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 248080
You need to log in before you can comment on or make changes to this bug.