unable to tell when empty trash or expunge inbox on exit are complete

RESOLVED DUPLICATE of bug 76691

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 76691
15 years ago
5 years ago

People

(Reporter: WG9s, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030822 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla Thunderbird 0.2a (20030813)

If you have empty trash on exit or expuge inbox on exit selected, there is
currently no way to tell if these operations are complete.  This is of
particular importance for dail-up IMAP users.  I often accidentallly disconnect
while the empty trash operation is in progress preventing the folder on the IMAP
server from actually being emptied.

Reproducible: Always

Steps to Reproduce:
1. have some e-mail in your trash folder on an IMAP account that you access via
dailup
2. configure the account for empty trash on exit
3. exit thunderbird
4. disconnect from the dailup session immediately when the thunderbird window closes
Actual Results:  
Received a message that the connection to my IAMP server was terminated.

Expected Results:  
Presented a pop-up window saying that folder cleanup was in progress so I would
be warned not to disconnect until the po-up disappears.

Updated

15 years ago
QA Contact: asa

Updated

13 years ago
Summary: unable to tell when empty trash or expuge inbox on exit are complete → unable to tell when empty trash or expunge inbox on exit are complete

Comment 1

13 years ago
I agree with this comment, but I would like to add another reason for implementing this fix: even if you are just using the browser, when you exit, the browser updates the profile files, and if you log out before the browser is finished, you wind up with a corrupted profile.
QA Contact: front-end

Updated

11 years ago
Duplicate of this bug: 373453

Updated

10 years ago
Assignee: mscott → nobody

Comment 3

9 years ago
what are the practical issues in Thunderbird, other than the already stated "not all messages are gone before startup"?  And, is this as much of an issue in version 3, or pop vs imap?

Updated

9 years ago
Severity: normal → minor
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> what are the practical issues in Thunderbird, other than the already stated
> "not all messages are gone before startup"?  And, is this as much of an issue
> in version 3, or pop vs imap?

This is mostly an issue for people who do not have an "always-on" Internet connection.  Believe it or not there are people who still use dial-up and the issue is there is no way to tell when it is safe to disconnect the Internet connection because there is nor way to tell if Thunderbird still has connections open to the POP or IMAP server.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 76691
You need to log in before you can comment on or make changes to this bug.