Redesign of about:buildconfig

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: raccettura, Assigned: jag+mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

I propose redisigning the about:buildconfig page.

New design forthcoming.  Enhancements:

Design from about:plugins (consistant design).  
XHTML Compliant (w3c validator says so).

New design is also a bit easier on the eyes IMHO.  Would be nice if we could get
it filled in a bit more (I like information, hence I love the internet).

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
Posted file buildconfig.html.in
A new mozilla/toolkit/content/buildconfig.html.in
(Reporter)

Comment 2

16 years ago
Posted file css for new design
CSS for new design.  It's based on about:plugins.
Is a bigger file justified? Why XHTML? Buildconfig isn't the kind of thing that
needs to be prettied-up IMO. *Maybe* if it used the same CSS file as
about:plugins, but there's no need to take up more space for this, don't you think?
(Reporter)

Comment 4

16 years ago
about:plugins is being redsigned: Bug 186490.

That page too should be XHTML.  And share the same stylesheet.  Consider this
stage 1.

The stylesheet is more generic.  The only reason I didn't bother with the
plugins page is because it's being redone (see bug).  When it's done, it should
be done the same.  And share the stylesheet.

IMHO both should be linked from "about:"

Comment 5

16 years ago
Three things: 
First, /toolkit/ is the Firebird product, not the Browser product.
Second, we need to reconsider where about:buildconfig should live.  We should
not have a separate one per product, it should just live in necko with the rest
of the about: handlers.
Third, if we're going to "redesign" it, we should look into ways to make it more
useful, not just prettier.  

Since we only need one about:buildconfig, we should consider making a way for
products to tack their own build/config information onto about:buildconfig. 
This way we can get the true build configuration when we start shipping GRE
independently of the products.  

Also, as I mentioned in bug 217407, we might want give people the ability to add
the vendor string to about:buildconfig.

Assignee: mozbugs-build → darin
Component: Build Config → Networking
QA Contact: benc
(Reporter)

Comment 6

16 years ago
Ok, here was my thinking.  I thought about:buildconfig could be much more useful
than it is.  

Mozilla is an End User product now.  We don't want to bother the end user with
"geek speak"... BUT.  Geeks want/need "geek speak".  So do developers, and beta
testsers (such as myself).   Hence buildconfig is the right place for it. 
about: is good for enduser info.  about:buildconfig for geeks.

1.  Should be universal across products (thought it was, my mistake).  Should be
shared, so that it's consistant across.

2.  Should give as much info as possible.  IMHO, anything possible, within
reason.  Good for diagnostic, and debugging:

Date/Time of Build Start
Machine name that built it
Any possible information about the build machine's config that could be useful
(library versions, etc.)
Expand on things like "--with-extensions=all" (what extensions?  Which are they?
 Was XYZ available when this was built?
Vendor Information

Would help beta testers provide more accurate feedback via bugzilla.

With my little redesign, it would be more than fesible to have all that info,
and more displayed nicely.  Just like about:plugins is nice and easy on the
eyes.  can find anything in seconds.  Regardless of page length.

Comment 7

16 years ago
the actual content of about:* has been the stuff of XP-apps.

networking bugs for about: only relate to aspects of the protocol handler or
file mappings not working.
Assignee: darin → jag
Status: UNCONFIRMED → NEW
Component: Networking → XP Apps
Ever confirmed: true
QA Contact: benc → pawyskoczka

Updated

16 years ago
OS: Windows XP → All
Hardware: PC → All
Product: Core → Mozilla Application Suite

Comment 8

14 years ago
Would be ideal if about:buildconfig included gcc -Q -v output
as well as values of such variables as CFLAGS, CXXFLAGS, CHOST, MAKEOPTS.

Also take into consideration bug 261911.

Comment 9

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

9 years ago
about:buildconfig has been adjusted to the (my) new layout/design of about: by bug 372826, and I just prettied it up a bit in bug 538890, so this is WFM.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.