Page with Java applet and javascript scroller does not display properly in Camino

RESOLVED FIXED in Future

Status

defect
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: mak, Assigned: mikepinkerton)

Tracking

unspecified
Future
PowerPC
macOS
Dependency tree / graph

Details

()

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030901 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030901 Camino/0.7+

In Camino the java applet at left is not visible, the scroller in second column
does not seem to display/update fully, and Camino is using up 45% of the CPU.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.carcassonne.org
2. Click the english flag in the middle
3. Observe results

Actual Results:  
See above. This page, and Camino after going to this page, is not usable.

Note: I am Running MacOSX Panther 7B53.


Works fine in Safari, without using much CPU. In Mozilla (fizilla) the scroller
looks fine but the java applet does not display at all. Mozilla is using 25% of
CPU according to top -u.

Comment 1

16 years ago
I'm confriming using 20030902 NB on MacOSX 10.2.6.

The page uses all my cpu power (G4 533) whcih seems a bit much for such a simple
page. And the java applet on the left showed the first time I loaded the page,
after that (when it was cahced) it didn't show up anymore unless I clicked and
dragged on it.

Comment 2

16 years ago
Confirming comment #1 with Camino 2003090302

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino0.9
Note that installing Java Embedding Plugin (bug 197813) seems to make Camino
behave the same way as Safari (besides the CPU usage) WRT the Java applet.

Mousing over the JavaScript scroller will stop it sometimes in Camino, which I
can't seem to make happen in Safari.

Mac OS X 10.3.6, Camino 2004112008 (v0.8+)

Comment 4

15 years ago
Confirming that using the Java embedding plugin makes the page works as it should.

WFM using 20041130 NB on 10.3.6 with java embed plugin.

Updated

15 years ago
Blocks: 224615
Since this is fixed with the JEP, available now, and since Camino will at some
point bundle JEP, I don't see the need for this to block 0.9 anymore, esp. since
there are bigger fish to fry for 0.9. 

-> Future
Target Milestone: Camino0.9 → Future
Fixed by bundling the Java Embedding Plugin with Camino (nightly builds 20050729
and later), bug 301076.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.