Closed Bug 220049 Opened 16 years ago Closed 15 years ago

Duplicate bookmarks allowed

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gyows, Assigned: p_ch)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

User is allowed to use the same title for multiple bookmarks. A user can name
all of their pages "Hominy Grits" if he/she wants to. This may be by design.
However, it has caused me confusion a number of times since I often re-name
links to friendly names and have used duplicate names. 



Reproducible: Always

Steps to Reproduce:
1. Save a page as a bookmark (use unique name)
2. Browse to a different page
3. Save page as bookmark with same unique name

Actual Results:  
Both (identical) bookmarks are allowed

Expected Results:  
A message like "A bookmark with that title already exists...ok?" or something
>Firebird/0.6.1

-> FB
Product: Browser → Firebird
QA Contact: petersen → mpconnor
Summary: Duplicate bookmarks allowed → Duplicate bookmarks allowed
Version: Trunk → unspecified

*** This bug has been marked as a duplicate of 10198 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
I am cleaning up bug 10198 it is for the suite. String for spaming detection
20050502:08:58:19
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
New as this seems to be the first bug request for this feature.
20050502:08:58:19
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → Trunk
*** Bug 222928 has been marked as a duplicate of this bug. ***
*** Bug 272103 has been marked as a duplicate of this bug. ***
*** Bug 281794 has been marked as a duplicate of this bug. ***
*** Bug 284997 has been marked as a duplicate of this bug. ***
*** Bug 291697 has been marked as a duplicate of this bug. ***
Its by design.  We implemented unique IDs for bookmarks in order to enable users
to have multiple copies of a bookmark for this reason, and this is probably a
dupe of something I marked as WONTFIX a long time ago, but since I can't find it
and there's a long dupe chain attached to this, I'll just WONTFIX it.
Status: NEW → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → WONTFIX
this rfe is not about removing the ability to have multiple bookmarks, it is 
about adding a simple dialog asking the user to overwrite an existing bookmark 
is the selected folder. marking as wontfix is ridicolous since many users have 
requested this and find this functionality useful.
*** Bug 311825 has been marked as a duplicate of this bug. ***
*** Bug 324596 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Duplicate of this bug: 371677
Duplicate of this bug: 395367
Bug - 395367 raised by me is duplicate of this bug
Duplicate of this bug: 399834
Duplicate of this bug: 482937
You need to log in before you can comment on or make changes to this bug.