after a period of time, Firebird stops responding to URLs entered in address bar or selecting bookmarks.

VERIFIED DUPLICATE of bug 223331

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 223331
14 years ago
14 years ago

People

(Reporter: Brian Tully, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+/jtalkington-nightly
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+/jtalkington-nightly

Firebird suddenly stops responding to user interactions such as clicking on a
bookmark or if i type a URL in the address bar and press enter (or click the
"Go" button) nothing happens. it doesn't even try to connect to the page
requested, it's as if suddenly the ability to visit new pages breaks. note that
Firebird isn't "frozen" - one can still resize and open/close windows - you just
can't go to any web page. the only way to fix the problem is quitting and
restarting Firebird.

Reproducible: Always

Steps to Reproduce:
1. use the browser for 20 minutes or so
2.
3.

Actual Results:  
Firebird suddenly stops responding to new URL requests

Expected Results:  
when i click on a bookmark or enter a URL into the address bar, Firebird is
supposed to go to that URL. instead, nothing happens.

using default theme, with StumbleUpon and Web Developer extensions enabled.

Comment 1

14 years ago
Brian, did you already tried by creating a new, vanilla profile without
installing any extensions at all?

Comment 2

14 years ago
I encounter this bug on a daily basis as well.  Although, I think I've pinned it
down to a more specific series of events:  it always happens, without fail, only
after all active Firebird windows are closed (Firebird app itself remains open);
 The moment a new window is then opened, the bug occurs.  The bug remains on all
new windows and tabs until I quit out of Firebird and open it up again.  So,
I've just been making a point to make sure that I always keep at least one
Firebird window open (even if it's simply a blank page.) 

I'm running the latest nightly of Firebird 0.7 release candidate on OS X 10.2.6.

Hope this helps!  

Keep up the awesome work on the project. Firebird is still the best browser for
OS X.  I've been running it daily since Phoenix 0.5, and I look forward to
continue testing nightly builds.

Best regards,
Glenn Watts

Comment 3

14 years ago
*** Bug 222230 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
works for me, although i do see the other problems with the first window after
all closed.  i'm not sure why this happens for some and not others.

by the way, the bookmarks not working problem is being tracked in bug 206752.

Comment 5

14 years ago
i have a suspicion this is fixed in 0.7.1.  let me know, as i never saw this
problem to start with :)

Comment 6

14 years ago
It looks like the original reporter hasn't responded since September. Nobody
else has been able to reproduce this bug, and I suspect it was a result of
occasionally closing all windows and opening a new one, which was fixed in bug
223331. Comment 2 definitely was that bug.

Comment 7

14 years ago
Yes, 0.7.1 for OS X seems to have fixed this bug.  I'm running 0.7.1 and I no
longer have this issue.  I used to experience it every day with 0.7 and earlier,
and now I do not experience it at all.  0.7.1 is FANTASTIC!!!

Keep up the great work.  This browser is incredible.

Best Regards,
Glenn

Comment 8

14 years ago
My apologies.  Just saw the cross-reference against Bug 223331.  I guess I
posted my original comment (#2) prior to that bug being tracked?  Anyhoo, I
agree with you Wayne, I think original poster was experiencing Bug 223331 but
just didn't realize how to pinpoint it more accurately.

Glenn

Comment 9

14 years ago
I agree with Glen, duping it against Bug 223331

*** This bug has been marked as a duplicate of 223331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.