Closed Bug 221413 Opened 18 years ago Closed 18 years ago

Palm Sync UI

Categories

(MailNews Core Graveyard :: Palm Sync, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: raccettura, Assigned: Bienvenu)

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

Palm Sync should have a UI like all other Conduits do.  This is necessary if the
user wants Palm Data to override Mozilla Data, or vice versa... or just not sync
during the next hotsync.

Would be nice to takc onto bug 214407 when it ships as a Thunderbird Extension.

Reproducible: Always

Steps to Reproduce:
Attached image Example
Example of what should come up when you customize the hotsync.
Depends on 214407, as we can't do much until we have it working.
Depends on: tbpalmsync
I'm not sure if the moz palm sync backend has all the capabilities, but at least
some way to get off the do-nothing snide would be useful.
Assignee: cavin → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch Patch to add uiSplinter Review
Patch to add a ui to the conduit for configuration
Additional files needed for patch
Attached image Example of ui
Example of dialog of for Conduit UI
Removing dependency since this bug is independent of getting a working
thunderbird extension.  This is needed for the SeaMonkey build (TB will tag
along and get it when the extension is available)
No longer depends on: tbpalmsync
that's awesome. I won't have a chance to deal with this until Tuesday, but thx a
lot for doing this!
Not sure what progress David has made, but thanks to his help, I'm able to sync
with Thunderbird.

I would suggest when Palm Sync comes to Thunderbird, it should include this,
hence this bug should block bug 214407.

What would be involved in adding the options for one sided sync's... "Desktop
Overwrites Handheld" and vice versa... as those are rather conventional on Palm
Sync, and quite useful?
Robert:  Right now the "... overwrites ..." options are not implemented in the
conduit. (See
http://lxr.mozilla.org/mozilla/source/mailnews/extensions/palmsync/conduit/MozABConduitSync.cpp#591)

That is why I only put the two options I did into the UI.

As for the possibility of this making it into the conduit, I think that would
slow down the initial release of a TB extension if it has to wait for this
functionality.  But I agree that eventually the " ... overwrites ..." options do
need to be included.  David may have a better idea of how hard it will be to
include this capability; I haven't dug into the syncronization code enough yet
to make an educated assessment.

Kevin
If it will take to long, I 100% agree it should wait.  

But another bug should be filed, so that it doesn't fall of the radar, as it's a
feature worthy of implementation (for functionality, and consistancy and
completion).

I've been keeping a real close eye on this, as Palm Sync is something I'm 100%
in favor of (just hoping someone can get it on the Mac as well).

I'm definitely not waiting for that feature to make palm sync an extension -
I've already created the xpi file for the extension and I'm trying to figure out
why it doesn't install correctly :-(
Robert:  I would file two bugs for the following two items (I would do it but
don't have the time at the moment to write a good bug report) :

Item 1:  Provide capability for handheld to overwrite the desktop or desktop to
overwrite the handheld in the addressbook sync

Item 2:  Move Hotsync from a c++ implementation to a java based conduit.

I noticed in the conduit SDK that there is a way to implement the conduit as a
java based solution.  This may be better as a cross-platform solution for both
Mac and Linux in the future.  There will probably have to be a fair amount of
code rewrite to achieve this, but may be the fastest overall method to move this
code to other platforms.

Kevin
Bug 222016 is for adding the additional options to hotsync.


From the Java CDK on Palm's site:
http://kb.palmsource.com/cgi-bin/palmsource.cfg/php/enduser/std_adp.php?p_sid=JjzZkIVg&p_lva=&p_faqid=148&p_created=1032298829&p_sp=cF9zcmNoPSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9NiZwX3Byb2RfbHZsMT1_YW55fiZwX2NhdF9sdmwxPTQmcF9wYWdlPTE*&p_li=

This is not a version of HotSync Manager created with Java, i.e. it is not
intended to be a cross-platform version of the highly-successful HotSync
Technology. With the CDK, Java you write conduits that connect into existing
versions of HotSync Technology. At this time, this kit will only work with the
Windows 95 / NT version of HotSync Manager.

Doesn't look like it will achieve anything towards cross platform compatibility.
   It apparantly isn't supported on the Mac.  And Palm only has a HotSync
manager for Windows and Mac OS to begin with (IIRC).  So we get nothing out of
the work, than some fun with Java.

Perhaps someone knows better, but that's what I see on the site.
Robert, Kevin,

I looked into hotsyncing recently, and to my knowledge, platform independence of
Palm syncing is almost impossible to achieve without starting an entire new
project. 
The problem is that any hotsyncing solution with Windows relies on Palms hotsync
API, both the Java and C++ version, while solutions with Linux use pilot-link. 
There is, however, the OS project jsyncmanager (http://www.jsyncmanager.org). I
never tested it, but it's a purely Java-based and platform independent hotsync
solution with direct hardware access, replacing Palms hotsync on windows.
Unfortunately, it doesn't seem to work together with Palms exisiting hotsync
application, as the lead developer told me:

"Typically, we don't suggest running both the Palm HotSync
Manager and the jSyncManager at the same time.  The only case where
it's safe is if you're using two different serial ports for each."

This would be the only option for an existing platform independent hotsync, and
to create a new one would IMHO require to start an entire new project, not just
a thunderbird extension.
I think the most practical solution would be to let the extension run on Windows
and hopefully Apple (I have no idea about those, but at least there is a Palm
hotsync application as well, so it should be possible), and find a different
solution for Linux. 
Comment on attachment 132960 [details] [diff] [review]
Patch to add ui

this looks good - I've made some minor tweaks to formatting and I'll check this
in to the trunk (not .3 branch) so that it will be in .4 tbird.
Attachment #132960 - Flags: review+
fix checked in - it's just a yes/no toggle right now, but when we have the
ability to do more in the backend, we can add that to the front end as well. Thx
a lot, Kevin!
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Has any further development happened on this project? I would like to see the OS
for this bug changed from Windows XP to All. There are many Thunderbird users on
Macs who would love to be able to sync with their Palms.
Jim, please see bug 16767.
Product: MailNews → Core
Product: Core → MailNews Core
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.