Closed Bug 221602 Opened 16 years ago Closed 10 years ago

Don't ship comm.jar

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla3.7a1

People

(Reporter: p_ch, Assigned: steffen.wilberg)

References

Details

Attachments

(1 file)

Lot of work needed here. There are three steps: clean up the GRE, the toolkit
and Phoenix.
Blocks: 171082
*** Bug 200142 has been marked as a duplicate of this bug. ***
Pierre, you might want to take a look at attachment 127363 [details] a chrome
trace-report, which should yield some interesting information. Also take a look
at attachment 127430 [details] and attachment 127431 [details] (the script and the header file,
which generated the report).
Depends on: 243116
Depends on: 243118
Depends on: 243119
Thanks to the passage of time, this is now just xbl-marquee, and the cookie accept dialog.
Assignee: p_ch → nobody
QA Contact: asa → build.config
And, while the cookie accept dialog can be utterly painlessly moved to toolkit.jar, xbl-marquee is a little more tangled up in the tree, and, at this point this bug is pointless: we need both of the remaining things in there, and moving them both to toolkit.jar looks like it would pick us up a mighty 400 *bytes* of .jar overhead. Uncompressed.
Whiteboard: [wontfix?]
Whiteboard: [wontfix?]
Attached patch patchSplinter Review
Bug 468011 is trying to consolidate the jars.
This is finally removing comm.jar.
Tested that the cookie accept dialog and <marquee> still work.
Assignee: nobody → steffen.wilberg
Status: NEW → ASSIGNED
Attachment #394744 - Flags: review?(benjamin)
(In reply to comment #4)
> And, while the cookie accept dialog can be utterly painlessly moved to
> toolkit.jar, xbl-marquee is a little more tangled up in the tree, and, at this
> point this bug is pointless: we need both of the remaining things in there, and
> moving them both to toolkit.jar looks like it would pick us up a mighty 400
> *bytes* of .jar overhead. Uncompressed.

what do you mean by tangled up?
Wrong tense: the right tense for "mean (in February 2007) by tangled up?" is "did." Without an mxr indexing 1.9a2, dunno, probably something a bit like http://mxr.mozilla.org/mozilla1.8/search?string=xbl-marquee since SeaMonkey would have still been using the old installer, and embedding wouldn't have looked quite so abandoned back then.
Attachment #394744 - Flags: review?(benjamin) → review+
http://hg.mozilla.org/mozilla-central/rev/3000a028e2e5
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 3.7a1 → mozilla3.7a1
You need to log in before you can comment on or make changes to this bug.