crash following attempt to close any opened PDF/Acrobat files

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Bryan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+

Link above is one example, have duplicated/experienced problem with multiple PDF
downloads.  Running:   Versión 6.0.0.2003051500 of Acrobat Reader (Spanish
Interface).  

Reproducible: Always

Steps to Reproduce:
1.Browse to any site with a pdf/acrobat file (ie. faq in suggested link)
2.Open file
3.Attempt to close file

Actual Results:  
Browser hangs, requires shut down via task manager.

Expected Results:  
Closed smoothly, allowed to continue browsing in other windows/tabs.  

n/a (no additional error report or message is generated)

Comment 1

15 years ago
I get the same results on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.6a) Gecko/20031103 Firebird/0.7+ with Adobe Reader 6.0.0 5/19/2003

After manually terminating Firebird, frozen Adobe Reader process hangs around,
and needs to be terminated as well, before another PDF file could be opened.

Bug 224550 is a duplicate of this bug.

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216
Firebird/0.7+

WORKSFORME.  Although, this has happened to me in the past.  What might be the
problem is there is an option in Acrobat that will bring up a dialog box to
confirm that you want to close the PDF, and sometimes it becomes hidden by the
browser, I have no idea why, and its still looking for you to confirm to close
it.  That is why I think Acrobat hangs, cause its still waiting for
confirmation.  So it may be a different sort of bug.

Comment 3

14 years ago
As of verion Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031216 Firebird/0.7+ , using Adobe Acrobat Reader 6.0.0.5 , and Windows
Xp pro ,when I try to close the file I am prompted with the following message :

 " One or more pdf files are open insed a web browser ... if you close adobe
reader those documents will be closed."

The windows , steal windows focus and if you alt+tab to switch to another
program , firebirds hangs and it start to take 100% cpu ... If you kill Acrobat,
firebird comes back to normal. [this been discovere trying to confirm this bug
and has been reproduced several times by me]

But I could not crash Firebird by just closing the browser-window , if i close
only the tab I get the mentioned prompt and if I close Firebird entirely I still
get the prompt to exit acrobat.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
*** Bug 224550 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
Testing on 20040102 on WinXP indicates that upgrading to Acrobat Reader 6.0.1
fixes this bug.  

As such am resolving as Works For Me.  Please reopen this bug if problems persist.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 6

14 years ago
*** Bug 239177 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
I see this behavior on Firefox 0.9.1 with Acrobat Reader 6.0.

Try http://www.jsx.org/JSXmanual.pdf

Please reopen.

Comment 8

14 years ago
Consistently occurs in 0.9.1, Windows 2000, Acrobat 6.

Browser must be closed via Task Manager, as cannot move to a different tab and
continue browsing.  

Please reopen.
*** Bug 255419 has been marked as a duplicate of this bug. ***
Bug occurs on: 20040910 1.0PR Sweetlou, 6.0.0 5/19/2003
Bug does not occur on: 20040910 1.0PR Sweetlou, 6.0.2 5/18/2004
Verified WORKSFORME.

We may want a relnote for this? Adding relnote keyword. Proposed wording:

Windows: Older versions of Adobe Acrobat may hang when trying to close Firefox
with an inline PDF file. Please update Acrobat to the latest version.

CC'ing blake and ben to evaluate relnote.
Status: RESOLVED → VERIFIED
Keywords: relnote
*** Bug 237035 has been marked as a duplicate of this bug. ***
Keywords: relnote

Comment 12

13 years ago
*** Bug 304956 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.