Some mirrors are not updating reliably

RESOLVED FIXED

Status

mozilla.org
FTP: Mirrors
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Jerry Baker, Assigned: Scott Kveton)

Tracking

Details

(Reporter)

Description

15 years ago
Some of the ftp.mozilla.org mirrors are not updating in a reliable manner.
ftp://mozilla.ussg.indiana.edu/pub/mozilla.org/mozilla/nightly/latest-trunk/ has
10-16 builds,
ftp://mozilla.isc.org/pub/mozilla.org/mozilla/nightly/latest-trunk/ has 10-17
builds. The other mirrors that I know of (Oregon State and Georgia Tech) have
the correct 10-18 builds.
(Assignee)

Comment 1

15 years ago
Have notified ISC and Indiana of problems.  Will leave open until I hear back.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

15 years ago
Both ISC and Indiana have been fixed.  Problems from the updates to paths we did
last week.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

15 years ago
It appears that the synch issue has been resolved by a cron job to touch the
dates on files in the "latest" directories.

I did a little investigating. The MD5 signature of mozilla-win32-talkback.zip
taken from
ftp://ftp.oregonstate.edu/pub/mozilla.org/mozilla/nightly/latest-trunk/ is
0DF5D142EDA6305C8255591CB9B969FA. The server indicates that this file was
created at "10/25/2003 1:24:00 PM." When you actually install Mozilla from that,
the build reports itself as 2003102404 and NOT 20031025. So I downloaded a
20031024 build to compare MD5's with this one. Guess what: the MD5 of
mozilla-win32-talkback.zip taken from
ftp://ftp.oregonstate.edu/pub/mozilla.org/mozilla/nightly/2003-10-24-04-trunk/
is 0DF5D142EDA6305C8255591CB9B969FA. Look familiar? They are identical yet one
carries a date of 10/24 and the one in the "latest" directory carries a date of
10/25.

Why are the mirrors "touching" the date on files in the "latest" directories
when the files have not changed? It makes downloading an appropriate build more
difficult because you think you are getting today's build when, in fact, you
have no idea what you are getting.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

15 years ago
I'm not too clear on the update process for mozilla/nightly/latest-trunk/

It appears to me that its the latest build for the products specified in that
directory.  If there haven't been any changes since 10-24-2003, why would the
MD5 hash be different?

Can someone enlighten the mirrors as to the process of the builds in nightly/ ?
(Reporter)

Comment 5

15 years ago
If they aren't different, why would the server change the file creation time?
That did not used to happen. This morning is the first I have seen of that.
Perhaps the problem is at mozilla.org itself rather than the mirrors. That I
cannot tell.
(Reporter)

Comment 6

15 years ago
This is a problem with the ftpmoz.newaol.com server as well. Probably not a
problem specific to mirrors. Closing and opening new bug against FTP:Staging.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

15 years ago
See bug 223671.
You need to log in before you can comment on or make changes to this bug.