Closed Bug 223931 Opened 18 years ago Closed 17 years ago

Messages that are NOT in reply to one another are displayed in same thread

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 164115

People

(Reporter: torarvid, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Currently, it seems threads are defined from the "Subject" field of mails, which
often produce wrong results. Many mails are displayed as beeing in the same
thread, while the "In-Reply-To" and "References" headers clearly state that they
are NOT.

Reproducible: Always

Steps to Reproduce:
1. Just select thread view in a large mailbox...
2. Have two++ mails that have the same Subject (i.e "Hello")
3. Observe that they appear in the same thread regardless of mail-header info.

Actual Results:  
The problem described above occured

Expected Results:  
Threading should be based on the mail headers "In-Reply-To" and "References". It
should at least be an option to thread by these rules instead of the Subject field.
related to bug 180299 ? There's a patch there... not sure if it bitrotted...
Blocks: 236849
I don't think it is. This is an extremely irritating bug/feature. It would be
very nice to have an option to only have it sort by references/in reply to
headers - rather than subjects as well.
Also happens Thunderbird in Windows (0.7+ 20040629), please change OS :)

Please fix, this is reeeeally annoying on my .talk newsgroup where there are
many posts in different threads which start with "Good morning" or suchlike and
all get lumped into the same thread.
OS -> All
OS: Linux → All
*** Bug 253344 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 164115 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.