Closed Bug 224064 Opened 18 years ago Closed 17 years ago

Changing value in "View" combo box breaks sorting by threads

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 135326

People

(Reporter: vova, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031021 Firebird/0.7+
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

Messages in my news folder are sorted by threads (View | Messages | Threaded
option is on). If I'm changing value in "View" combobox to "unread" and after
that back to "All" then all messages are groupped by threads. It's OK. But if
I'm leaving news group and go back then all messages in the group are not sorted
by threads.

Reproducible: Always

Steps to Reproduce:
1. Ensure that View | Message | Threaded option is on
2. Open news group and change value in "View" combo box to "Unread"
3. Change value in "View" combobox back to "All"
4. Go to some other new group
5. Go back to the initial news group
Actual Results:  
All messages are not sorted

Expected Results:  
All messages should be sorted by theads
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Similar behaviour with newsgroups and fast serch with "Subject or sender
contains" input box. 

Reproducible: Always

Steps to Reproduce:
1. Ensure that View | Message | Threaded option is on
2. Open news group and type some search criterion into input box
3. Press "Clear" button beside - sorting by threads is present
4. Go to some other newsgroup
5. Go back to the initial news group

Actual Results:  
All messages are not sorted

Expected Results:  
All messages should be sorted by theads

If step 3 omitted, the same result appears.
Blocks: 236849
*** Bug 230773 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 135326 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.