Bookmark backup & restore

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Christian Flatscher, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Hi,

I have been searching through the bug database but was unable to find a similar
problem report.

This happened to me today on my Windows 2000 box - but it could happen on any
other system.

When a system freezes unrecoverably - which seems to be an attractive feature of
Windows - and you must either press the reset button or pull the power cord then
Mozilla may not be able to completely save the bookmarks.html file to disk.

Can you please implement a feature into a new version of Mozilla that allows the
user to reuglarily save the bookmarks.html file including at least tow levels of
backups?

This feature could be added to the "Edit / Preferences..." menu under Navigator
as an new menu item "Save Bookmarks" with the possiblity to set a time frame
between say one and 60 minutes where Mozilla refreshes the bookmarks.html file
in the current running profile and you should be able to select from a drop down
menu how many backups you want to create.

Also it'll be good to have in the Bookmarks drop down menu a new menu item
called Restore Bookmark Backup. I think this will fit neatly underneath the
entry Manage Bookmarks...

BTW: I am happy to test this featuer if you let me know when it is implemented.

Thanks!

--Christian

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Dupe of bug 193749?

Comment 2

14 years ago
IMHO this is a dupe of bug 131105. The other bug from comment 1 is for the loss
of all prefs and bookmarks.
(Reporter)

Comment 3

14 years ago
José,

I wouldn't call it a duplication of bug 193749.

My request falls into the same category. However I am suggesting a feature
change / update to overcome such an issue.

Do you want me to post my request into that bug and carry on working with 193749?

--Christian

Comment 4

14 years ago
See also bug 101319 (save bookmarks only when bookmarks are updated).

Updated

14 years ago
Blocks: 123929
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: system dies - bookmarks.html "damaged" → Bookmark backup & restore

Comment 5

14 years ago
See also bug 218636 (firebird) and bug 22689.
(Reporter)

Comment 6

14 years ago
Hi,

I suggest to add a feature to Mozilla / Firebird that allows to create backups
of files such as bookmarks.html, Personal toolbar, mail prefs, news prefs, etc.

How about adding a menu entry to the "Edit / Preferences..." menu underneath the
"Navigator" branch called "Settings backup"?

This should contain tick boxes of what somebody wants to backup, to where and
how often (time interval) this should happen. Also a restore feature should be
introduced with a selection option what and which backup should be restored.

This may solve some of the issues where an OS freezes or crashes unrecoverably.

--Christian

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 193567 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
oops, sorry, wrong tab
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 9

14 years ago
*** Bug 232297 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 237647
Product: Browser → Seamonkey

Comment 10

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody
Status: REOPENED → NEW
No comment in two years.
How (and when) to solve this bug may depend on whether the places.sqlite database will be ported to SeaMonkey, something not yet decided AFAIK.

Comment 12

10 years ago
When/if we switch to places bookmarks backend, this would be fixed there, as far as I know.
The relevant bugs for the FF2 solution (based on bookmarks.html) are bug 218636, bug 305004 and bug 307135.

Asking for blocking SM2 since I think this is a very important, basic functionality.
Flags: blocking-seamonkey2?

Updated

9 years ago
Blocks: 203343
No longer blocks: 123929

Comment 14

9 years ago
Not blocking 2.0 on this, see comment 12
Flags: blocking-seamonkey2? → blocking-seamonkey2-
Trunk (and 2.1a3) offers Backup/Restore using the JSON format directly in the Bookmarks Manager now, and creates up to five backups per day automatically. Thus this bug is done. Marking WFM for now; KaiRo, please resolve as you like.
Status: NEW → RESOLVED
Last Resolved: 14 years ago8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Depends on: 498596
You need to log in before you can comment on or make changes to this bug.