Content in text box changes as the browser window is resized

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
19 years ago
12 years ago

People

(Reporter: nisheeth_mozilla, Assigned: roc)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
1) Goto http://www.mozilla.org/newlayout/xml/books/books.xml
2) Click the "Toggle Style" button
3) Resize the window.

As you resize, content in the upper left table cell's text box gets swapped with
the content of the bottom right table cell's text box and then reverts to its
original content.  This keeps happening as you continue to resize the window.
When you stop resizing you end up with the original content.

This bug is part of the effort to break out the different problems reported in
bug 19612 into different bugs.

Comment 1

19 years ago
A detail: the bottom-right cell that matters is the bottom-rightmost
that is visible at the time, not the very bottom-rightmost. This can change
while resizing.

Also, the scrollbars on the upper-left textbox go wild while resizing,
but not the scrollbars on the bottom-right textbox.

Comment 2

19 years ago
*** Bug 22690 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: troy → nisheeth

Comment 3

19 years ago
The XML demo has been busted for quite a while, and it's not clear when/why it
no longer works well

Nisheeth, you're Mr. XML so re-assigning to you. If you can narrow it down or
come up with simpler test cases I will take another look
(Reporter)

Comment 4

19 years ago
Created attachment 4108 [details]
books.xml
(Reporter)

Comment 5

19 years ago
Created attachment 4110 [details]
common.css
(Reporter)

Updated

19 years ago
Assignee: nisheeth → troy
(Reporter)

Comment 6

19 years ago
- Save the attached books.xml and common.css to the same directory on your local
disk.
- Load books.xml.
- Resize the window.

The content of the first book gets swapped with the content of the second book
and then reverts to the original content.  This behavior repeats as you resize.

Troy, now that this bug has a simplified test case, assigning this back to you.
Thanks for your help with this!

Comment 7

19 years ago
*** Bug 22765 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 8

19 years ago
Problem is in block code and how it doesn't properly position floaters before
reflowing them, and so it places them in the wrong spit and then ends up moving
them
(Reporter)

Comment 9

19 years ago
*** Bug 24801 has been marked as a duplicate of this bug. ***

Comment 10

19 years ago
This is fixed. Eric Vaughan made a change to the compositor so it defers moving 
widgets until we're all done positioning views
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Fixed in the July 14th build.
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
Seeing this again using 2000-07-31-08-M18 (and -07-30-21-M18) on WinNT.

The Bill Gates <TEXTAREA> stutters with the contents of the 
84 Charing Cross Road <TEXTAREA> when the window is resized, and also
as the layout finishes up after pressing the [Toggle Style]. 

Bug 29195, "Text jumping around", looks related. It was previously marked a
DUP of bug 22685, but looks much more similar to this bug.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Troy no longer with us, reassigning to Buster. This won't get fixed for RTM
unless someone nominates it and says why it is more important than us leaking
more than the Military...
Assignee: troy → buster
Status: REOPENED → NEW

Comment 14

18 years ago
*** Bug 29195 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
minor display glitch.  not easy to fix.  future
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: --- → Future
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Status: ASSIGNED → NEW

Comment 17

17 years ago
Since there haven't been any comments for a year, I'll just say that this bug
still exists.  By the way, the rectangle containing the synopsis of each book
isn't a textarea, but rather a block element with fixed size and overflow:scroll.
Over to the right component....  This happens on Linux too.
Assignee: attinasi → roc+moz
Component: Layout → Layout: View Rendering
OS: Windows NT → All
Priority: P4 → --
QA Contact: petersen → ian
Hardware: PC → All
Target Milestone: Future → ---
This is probably something to do with native widget repositioning during reflow.
The content change only happens transiently during reflow; the "steady state" is
that the rendering is correct.

Probable fixes are to a) buffer native widget state changes (see bug 23742) or
b) make scroll areas not use a native wiget. The latter fix would be best but
I'm not sure we can do it on X11.

Updated

15 years ago
Keywords: testcase
Isn't this fixed now in current trunk builds (more than 2 years later)?
I'm not seeing anything unusual with the url testcase.

Comment 21

12 years ago
As far as I understand the testcase at http://www.mozilla.org/newlayout/xml/books/books.xml and the bug description, I get expected results with Firefox 2.0 RC2 rv:.1.8.1 build 20061003 under XP Pro SP2.
Marking WORKSFORME, if someone can still reproduce this bug, please reopen.
Status: NEW → RESOLVED
Last Resolved: 19 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.