Fails to move copy to Sent folder, then claims message wasn't sent, but it was

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Gunnlaugur Thor Briem, Unassigned)

Tracking

Trunk
x86
Windows XP
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wfm?])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla Thunderbird 0.4 (20031205)

I tried to send a message to myself, on a system where I've just set up Qmail
and bincimap server (so take note, mailserver configuration is definitely flawed).

The message got sent (I saw it in appear in the inbox, and the qmail-smtpd log
shows that it was sent), but the Compose window stayed open, waiting for the
"Sending Messages" dialog box, which had "Status: Copying message to Sent folder
...".

Now, the Sent folder did not exist. The only folder already created for this
user was the inbox. This was after a default bincimap installation on Gentoo.
This caused the dialog box to stay in that status for a sufficient amount of
time to be considered "forever". After the "forever" point, I checked the inbox,
and sure enough, the mail was there. I then hit Cancel in the dialog box. The
Compose window now stays open, but is read-only (header fields are greyed, and
text area is immutable) and pressing the Send button again does nothing.

When I now close the window, a dialog box says "Message has not been sent. Do
you want to save the message in the Drafts folder". (Of course, when I click
Save there, the analogous thing happens again, dialog stays in status "Copying
message to Drafts folder", because the Drafts folder doesn't exist either).

Now, there is at least one bug here: the message WAS sent, so the last message
is erroneous (and can cause people to send multiple copies of an email,
irritating the recipient and embarrassing themselves).

Whether the other behavior is a bug I guess depends on whether it is a valid or
an invalid assumption that the Sent folder and the Drafts folder will always
exist in an IMAP message store. Maybe that's valid (i.e. Thunderbird can
legitimately claim that "it's the other guy's fault" if this situation comes up,
because it never should if the mailserver admins have done their job), I don't
know -- but I tend to guess that Thunderbird should be robust to this. That's
your call though.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
This may be useful: it turns out that Binc IMAP apparently does not yet support
creating folders except as children of Inbox. Mozilla Thunderbird apparently
uses "Sent" folder and "Drafts" folder (not as children of Inbox) by default. I
was not able to use the New Folder action with the account node selected in the
left-pane folder tree ... but I was able to use it with the Inbox node selected.
So I created a folder Inbox/Sent, and changed the account settings to put copies
of sent messages in that instead, and all works fine now.

So:
1) maybe Thunderbird should create the Sent folder automatically when it needs
to copy something to it (presumably asking the user first)
2) maybe the above automatic folder creation is a little complicated by the fact
that it is not a safe assumption that the Sent folder can be a top-level folder
(i.e. can be created directly under the account node, as a sibling of Inbox)

Comment 2

14 years ago
I was also having this "Copying to Sent folder" problem.  I tried creating the
Sent folder as a subfolder of Inbox, and that worked briefly, but then also fell
victim to the Sent Mail bug.  Coincidentally, I was having trouble with some
other programs involving hard drive space on my computer.  After cleaning up the
drive and freeing up about 2.5 GB of space (there was about 500 MB prior to the
cleaning), the bug went away.  I was able to successfully redirect mail into the
normal Sent Mail folder.

Comment 3

14 years ago
I have to say, this bug doesn't seem to depend on the mail server or the OS, or
disk space, or the presence of folders. I have plenty of free space (currently
19.5 GB on a 38.1 GB HD), the default folders are all there, I'm using Windows
2000, and this has been happening to me since at least Mozilla 1.5 or before.
It's been at least 20 minutes now that I've been waiting for Thunderbird 0.7 to
copy 2 messages to the "SENT" folder. I'll find out if they've actually been
sent later; I'm never sure. The crazy thing is that it doesn't always happen,
and there's no predicting when it will or when it won't. I thought that it only
started happening on those occasions when I would mark a message as junk (using
the option to have it moved to the "Junk" folder) while the message was in the
process of being sent. But tonight I DIDN'T do that, Thunderbird hung (as
Mozilla was wont to do), and I'm still waiting for that copy to finish. If I try
to look at the "SENT" folder while this is hanging, which I just tried to do, I
see no listing of messages and just get the hourglass letting me know something
is going on. if I go to another folder (say, "JUNK") first, then I can go back
to the inbox, but otherwise, either I don't see any messages displyed, ot the
display is corrupted. Just now I saw the listing for about 2 out of every 5
messages - the rest was white space. When I went to another folder and then came
back to the INBOX, I was able to see all my messages, but now the bold font on
the unread messages changed to monospace from proportional. All the read
messages stayed in the proportional font.

BTW, I did clean installs of Thunderbird and Firefox because I was having SO
many problems with Mozilla 1.7. All I saved were my mail folder, bookmarks and
address book, and I made sure the GRE folder was removed. Not only that, but I
went through the registry and manually deleted every reference to Mozilla or
Netscape that I could.

I don't know if that's related or not, but I'm just about ready to dig out my
archive of Mozilla 1.3 and go back to a build I didn't have so much trouble with...

Comment 4

14 years ago
Can confirm exactly the same on W32/Tbird 0.7.2 and WU-Imap server (runnin' on
native linux, of course). My Sent folder definitely exists, has lots of messages
in it and I can browse through the folder even while the hereby explained bug is
happening. Yet my Mail Compose window stays infinitely in the "Copying message
to Sent folder..." status. I can confirm that the respective e-mail was in fact
sent correctly. This is happening when I've online connection to IMAP server.

To my experience IMAP support in Tbird seems to be really buggy, the most likely
source is the Offline extension. Synchronization of changes made offline don't
get synced to the server once you get on-line. Already deleted and/or flagged
and moved e-mails are downloaded once again from the server-side Inbox. Sending
e-mail when there's no connection to the IMAP server is a real pain. Messages
sometimes get lost when accidentaly moved from POP to IMAP folders while you are
offline etc...

Is there any better place where to report these bugs and to help with its
solving? It's a real pity, that such a cute and user-friendly mail client has so
weak support when it comes to road-warrior usage :-((
If this problem's in Seamonkey as well (as comments show), it's a backend
problem that belongs in MailNews, not Thunderbird.  Moving to what I believe is
a more correct product/component...

I'm also upping the severity, because with the UI effectively in a hang, the
user can't be sure whether the message has been sent or not.  If he cancels, he
risks the loss of the message.  If he then closes the window without attempting
ineffectively to save a copy to Drafts and there is indeed a real problem it's
dataloss.  If he waits on the sending, however, he either waits forever (as
apparently happens to others) or gets an error message after a while that's
effectively useless (as happens to me; I'll post the message here when I
encounter it next).  In any case the user is left in a state of uncertainty
about his messages and is greatly inconvenienced, which I believe deserves a
higher severity.

If there's *any* way at all I can help in resolving this, please let me know.  I
experience this bug quite frequently, and it's a trivial matter for me to
reproduce it.  I've tried extremely rudimentary analysis of this using Ethereal,
but I've gotten nowhere.  Is there a way to enable some sort of logging of mail
transactions to a file?  I may not be able to write a patch, but I can try to be
as helpful as I can with getting data for the person who can.  (Be forewarned
that the account I've used that experiences the problems is IMAP over SSL
[haven't used any other IMAP accounts ever], so I don't know if any data I get
would be useful or not.  I'm willing to test with other non-SSL servers if I can
get access to them, tho, so it's only a stumbling block.)
Severity: normal → major
Component: Message Compose Window → Networking: IMAP
Product: Thunderbird → MailNews
Version: unspecified → Trunk
Flags: blocking-aviary1.0?
The error message encountered is:

The current command did not succeed. The mail server responded: System I/O error.

It's admittedly pretty useless, it seems, but perhaps it'll help point towards
*something* that needs fixing.
Whiteboard: DUPEME - bug 123063?

Updated

14 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Product: MailNews → Core
*** Bug 298541 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 319366 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
xref bug 119142 (not the same circumstances, but the same basic problem).

Jeff Walden, do you really think this is a dupe of that (now-fixed) bug?  That problem is about the failure to copy, a symptom with a number of causes and many reported bugs.  This bug seems to me to be about the misphrased error message -- and not the one you cite in comment 5, but the one cited in the fourth paragraph of comment 0.

Updated

10 years ago
Assignee: mscott → nobody

Comment 10

9 years ago
I've seen this multiple times, or something like, within the last 2 weeks.
Severity: major → normal
QA Contact: networking.imap
Whiteboard: DUPEME - bug 123063?
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 11

9 years ago
(In reply to comment #10)
bug 28211, bug 298229 ?

Comment 12

9 years ago
(In reply to comment #11)
> (In reply to comment #10)
> bug 28211, bug 298229 ?

yes, like those

Updated

7 years ago
Duplicate of this bug: 298229

Comment 14

6 years ago
Do you still see this, and is anything in error console?
(Reporter)

Comment 15

6 years ago
I haven't used Thunderbird in years, so I'm afraid I can't be of help here.

Comment 16

6 years ago
Hi,
 I'm using currently a gmail account at my Thunderbird and this bug does not happen to me now, but one note: sometimes email is sent but the copy to 'sent folder' fails, Thunderbird say me what happens succesfully ('your email was sent but could not be copy to the sent folder', or something similar -I use es-ES locale, I translate myself quickly-), let me retry or cancel the copy, I press 'retry' and works fine.
 For me this bug is solved, because if the copy-to-sent problem happen, at least the error message is good.

Comment 17

6 years ago
anyone else?

(In reply to Wayne Mery (:wsmwk) from comment #10)
> I've seen this multiple times, or something like, within the last 2 weeks.

I have no clear recollection of seeing (or not seeing) this since comment 10
Whiteboard: [wfm?]

Comment 18

5 years ago
so then, WFM
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.