Misleading error message

RESOLVED DUPLICATE of bug 227995

Status

RESOLVED DUPLICATE of bug 227995
13 years ago
12 years ago

People

(Reporter: elharo, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051130 Firefox/1.5
Build Identifier: Thunderbird 1.5 RC1

This bug is exposed by 206408, but is not the same thing. When Thunderbird hangs while trying to copy a message to the Sent folder as in 206408, one can quit Thunderbird. In this case one is presented with a dialog saying "Message has not been sent. Do you want to save the message in the drafts folder?"

This message is inaccurate. The message more often than not has been sent but has not been saved in the Sent Folder. This inaccurate message could cause someone to later resend a message that has already been sent.

Thunderbird needs to distinguish the cas of a message not being sent from it merely not being saved. 

Reproducible: Always

Actual Results:  
"Message has not been sent. Do you want to save the message in the drafts folder?"

Expected Results:  
"Message has not been saved. Do you want to quit anyway?"

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 227995 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.