Closed Bug 228389 Opened 17 years ago Closed 17 years ago

Autoscroll-icon is visible in the dom

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 215762

People

(Reporter: martijn.martijn, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031212 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031212 Firebird/0.7+

The autoscroll-icon becomes also visible in the dom, when it is active. 

Reproducible: Always

Steps to Reproduce:
1.Middle-click in a page (even a blank page will do)
2. View the dom (with the generated source bookmarklet for example -
http://www.squarefree.com/bookmarklets/webdevel.html) or save the page.
3. 

Actual Results:  
The generated source shows the img code for the autoscroll-icon. 
The saved file would also show that same source code.

Expected Results:  
It should not show that code. The auto-scroll feature is browser-specific.
Sorry, I´m just seeing this is probably a duplicate of 215762
I'd doubt it's a duplicate, but since we already have specific info like this
shown in the DOM Inspector (select an element, switch to Javascript Object
view), specifically the all-caps NS* functions, this is probably WONTFIX.

Unless we actually DON'T want this showing to the outside, perhaps because it's
part of the chrome and foreign Javascripts are supposed to run in a sandbox that
wouldn't affect the chrome...
Same cause as bug 215762, bug 215825, etc.

*** This bug has been marked as a duplicate of 215762 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.