Closed Bug 215762 Opened 17 years ago Closed 13 years ago

autoscroll (middle click) causes "XML pretty print" to unformat (disappear, clear)

Categories

(Firefox :: General, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: rune, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030810 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030810 Mozilla Firebird/0.6.1+

When I look at an XML document, e.g. an RSS feed, it has a somewhat pretty
default formatting. However, when I press the scrollbutton on my mouse, it goes
back to plaintext format without the extra stylesheet.

Reproducible: Always

Steps to Reproduce:
1. Surf to http://www.mozillazine.org/contents.rdf
2. Look at pretty formatting (well, almost)
3. Press the scrollbutton, imagine you want to scroll down the page fast
4. Where did all my colors go???

Actual Results:  
The XML tags are gone, the content is still there... Like in the bad old days...

Expected Results:  
The XML tags should still be there, I should be able to scroll down by pressing
my scrollwheel...
Works for me with the same build on the same platform.
Rune, did you use a new profile? Do you use additional themes and extensions?
QA Contact: asa → bugzilla
I see this bug on XP with Gecko/20030809 Mozilla Firebird/0.6.1+.  The bug makes
some sense -- the coloring is supposed to go away when certain things happen to
the xml document, such as the application of a style sheet.  ccing
bugmail@sicking.cc, since I think he's involved with pretty printing.  But it is
pretty wacky that autoscroll adds an IMG element to the document.
I have no idea how autoscrolling is implemented, but if it adds images to the
document DOM then the prettyprint side of things work as designed. It sounds
really scary to me that we modify the document DOM for autoscrolling, that can
send off all sorts of wierd things in the document (mutation events will be
notified, scripts executing on a timer will see a modified DOM).

Personally i would prefer to see autoscoll insert things into the chrome instead
which would take care of all of the above problems. There are other
alternatives, but I won't suggest them here since I think they will just add to
the current wrong-ness
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "XML pretty format" gone when pressing scroll wheel button → autoscroll causes "XML pretty print" to unformat
Autoscroll adds an image to the document.  I can tell because the "ancestors"
and "generated source" bookmarklets show it, and because it is often affected by
page style sheets.
Re Comment 1: Yes, this happens using a new profile. The only installed
extension is the WebBar.

(I always have a new profile, because I'm on a restricted network, and the
Documents and Settings folder is deleted every time I log out).

Sorry I'm late, turns out I turned off all my bugmail a while ago. But it seems
like you are on to something anyway!
Reproduceable on 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925 Firebird/0.7
*** Bug 223933 has been marked as a duplicate of this bug. ***
*** Bug 225026 has been marked as a duplicate of this bug. ***
*** Bug 226550 has been marked as a duplicate of this bug. ***
See also bug 215825, "autoscroll cursor is affected by page stylesheets".  Both
bugs would be fixed if the autoscroll circle IMG were not part of the document.
*** Bug 226661 has been marked as a duplicate of this bug. ***
*** Bug 231657 has been marked as a duplicate of this bug. ***
*** Bug 233086 has been marked as a duplicate of this bug. ***
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040128 Firebird/0.8.0+

To see this effect you have to enable "Use autoscrolling" within the advanced
options. Otherwise my middle mousebutton doesn't destroy the format.
OS: Windows 2000 → All
*** Bug 233788 has been marked as a duplicate of this bug. ***
*** Bug 234495 has been marked as a duplicate of this bug. ***
*** Bug 234669 has been marked as a duplicate of this bug. ***
In FireFox .8, the xml pages clears completely when I go into autoscroll. 
http://www.mapjunction.com/places/Test_BRA/cgi-view/search.pl?s=mark&type=xml is
an example of where this happents.   Click the middle scroll button down, and
after the image pops up of the autoscoll all of the XML text disappears.  A
refresh brings the page back.
(In reply to comment #18)
> In FireFox .8, the xml pages clears completely when I go into autoscroll. 
> http://www.mapjunction.com/places/Test_BRA/cgi-view/search.pl?s=mark&type=xml
> is an example of where this happents.   Click the middle scroll button down,
> and after the image pops up of the autoscoll all of the XML text disappears.
> A refresh brings the page back.

This is no different from anything exhibited in the rest of the bug.  When the 
XML unformats, only the contents of tags are shown (in a straight line of 
text), as attributes and such have no inherent style attributes.  In this case 
attributes will be ignored because they aren't content.  As not a single tag in 
the document has any content (other than tags and whitespace), nothing will be 
displayed.  If you try loading an XML file with no style information and tags 
that have contents (and therefore all info isn't just in attributes), you'll 
see unformatted text.  An example: http://www.mezzoblue.com/rss/index.rdf
Perhpas the suggested http://www.mozillazine.org/contents.rdf is not the best
link to test this bug against at present. Firefox 0.8 displays it as plain text
with no special XML formating. On my system (Win XP Pro), the mouse scroll
button does not mess up the display for this page.

Many examples here: http://blogs.gotdotnet.com/ . Each and every one of the RSS
files display with special XML formating, and the text is messed up when the
mouse scroll button is pressed. Also I loose the context menu. The source of
course all there when you look at it. And refresh corrects the display until you
scroll again with the mouse. Some may notice the .ASPX extention at the end of
these XML files (which shouldn't matter), but it's still the same with all other
XML files with .XML extensions as well, such as here:
http://rssnewsapps.ziffdavis.com/eweekwindows.xml
there are some bugs with that autoscroll-icon because it uses styles.  Isn't it
better if the icon could be overlayed or something so it doesn't affect the
document?
*** Bug 228389 has been marked as a duplicate of this bug. ***
Blocks: 212273
Per comment 3, fixing Bug 242621 would make this easier/take care of it.
Depends on: 242621
*** Bug 249321 has been marked as a duplicate of this bug. ***
First off, updating link to point to a real XML feed
(http://www.mozillazine.org/atom.xml).

Second, this bug only seems to affect unstyled XML feeds. Styled XML feeds such as:
http://aebrahim.blogspot.com/atom.xml
don't appear to suffer from this bug (though they do suffer from bug 242466).

Also nominating for 1.0, since this bug is obviously highly visible (see number
of dupes), and second, since we're getting an RSS reader, it makes sense to have
other RSS/XML related stuff work too.
Flags: blocking-aviary1.0RC1-
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
*** Bug 252972 has been marked as a duplicate of this bug. ***
*** Bug 255020 has been marked as a duplicate of this bug. ***
This bug is still present with Firefox 0.9.3 on Windows XP.
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.3

This bug still exists.  It has a slightly different implication than those
comments above though:

For example, I load http://www.hutteman.com/weblog/rss.xml
When I middle-click (auto-scroll), all the XML tags disappear and I CANNOT
disable auto-scroll!  If I middle click again, nothing happens.  I must close
that particular tab and reenable it if I want to scroll through the unformatted
text normally.

This occurs ONLY when the XML document is in a multi-tabbed environment and it
isn't the first tab.

For example, open up a new window and browse to the XML above.  The middle-click
will kill the formatting but you will be able to stop auto-scroll by middle
clicking again.  However, if you open up a new tab and open the above link and
middle-click, you lose formatting AND you can't stop autoscroll until you kill
the tab.

Quite an annoying bug considering the usefulness of auto-scroll while at the
same time having very sensitive middle mouse buttons nowadays.


/sylikc
Reproducable with Firefox 0.9.3, Win XP SP1...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
comon people, we're well aware that the bug still exists. That is why this bug
is still open. Noone has claimed anything else.
*** Bug 255661 has been marked as a duplicate of this bug. ***
*** Bug 259382 has been marked as a duplicate of this bug. ***
Reproducable on Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
I have the same problem on 1.0PR WinXP SP1
What I also find interesting is that a text/plain page can show the autoscroll
image on it without problems.
This bug appears on FireFox 1.0PR & 1.0RC (WinXP, new installation)

I did found this bug for a long time (in 0.9 or 0.8 I think)
(In reply to comment #30)

Reproduceable on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

AutoScroll: ON

It's too badly, that this bug is still in the first major release of Firefox.
*** Bug 270595 has been marked as a duplicate of this bug. ***
*** Bug 269798 has been marked as a duplicate of this bug. ***
*** Bug 274250 has been marked as a duplicate of this bug. ***
*** Bug 272854 has been marked as a duplicate of this bug. ***
Attached patch patch (obsolete) — Splinter Review
Something like this fixes the bug for me.
It adds the autoscroll image by adding a binding to div#header (which is
generated by the xslt stylesheet). This doesn't cause an unfolding of the
document.

I've also removed this line:
-	       this._autoScrollMarkerImage.style.display = 'none';  // seems to
avoid blocking when autoscroll is initited during pageload
I'm not sure if that's allowed, but it doesn't seem to 'do' anything.
Attached patch patch2 (obsolete) — Splinter Review
Same patch, but fixes a glaring error.
Attachment #171637 - Attachment is obsolete: true
*** Bug 281491 has been marked as a duplicate of this bug. ***
Summary: autoscroll causes "XML pretty print" to unformat → autoscroll (middle click) causes "XML pretty print" to unformat
Flags: blocking-aviary1.1?
+ing for review. 
Flags: blocking-aviary1.1? → blocking-aviary1.1+
Warning, my patch is more a hack than anything else.
*** Bug 285968 has been marked as a duplicate of this bug. ***
*** Bug 286831 has been marked as a duplicate of this bug. ***
I can confirm the Bug on Win XP, Firefox 1.0.2.

On my Linux machine with Firefox 1.0.1 (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7.6) Gecko/20050311 Firefox/1.0.1) it works great, but the
"Autoscroll-Icon", which normally appears, doesn't appear.
(In reply to comment #50)
> I can confirm the Bug on Win XP, Firefox 1.0.2.
> 
> On my Linux machine with Firefox 1.0.1 (Mozilla/5.0 (X11; U; Linux i686; en-US;
> rv:1.7.6) Gecko/20050311 Firefox/1.0.1) it works great, but the
> "Autoscroll-Icon", which normally appears, doesn't appear.

I can confirm the Bug on W2k, Firefox 1.0.3.  
On some XML files, the format simply disappear and left with the content without
the pretty color formatting.  

On some XML files, the page just turn blank when the middle scroll mouse button
is clicked. 
*** Bug 293968 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.1+ → blocking-aviary1.1-
for me when middle clicking the document disappears, could it have something to
do with adblock plugin? 
 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6  w/ bugmenot and forecastfox extensions

Pages are turning to blank pages now when middle clicked instead of going to
plaintext formatting as before.
changing url, because rss/atom feeds are now transformed into something readable
by something called 'feedview' in current trunk builds.
Assignee: firefox → nobody
QA Contact: bugzilla → general
*** Bug 306186 has been marked as a duplicate of this bug. ***
*** Bug 308649 has been marked as a duplicate of this bug. ***
(In reply to comment #55)
> changing url, because rss/atom feeds are now transformed into something readable
> by something called 'feedview' in current trunk builds.

Not anymore. Feedview got pulled.
*** Bug 311348 has been marked as a duplicate of this bug. ***
*** Bug 313538 has been marked as a duplicate of this bug. ***
As of Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 this bug is still occuring
*** Bug 324778 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

This bug is still occurring.

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.8.0.1) Gecko/20060209 Debian/1.5.dfsg+1.5.0.1-2 Firefox/1.5.0.1

Still happening here.
*** Bug 334457 has been marked as a duplicate of this bug. ***
*** Bug 340797 has been marked as a duplicate of this bug. ***
I just noticed this for the first time today, using 20060609 trunk nightly.  I have a feeling I wasn't affected before, but I'm not really at liberty to go testing old versions.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

This bug is still occurring.
It seems like the problem still persists.. But now, in newer version it isn't just deformatting the page, but the page becomes completely blank.
This is a little screen-video I took: http://rapidshare.de/files/25299603/demo.xml.html
I'm experiencing this problem since I know Firefox.. Both on the home and the work  computer..
Still persisting in Firefox 1.5.0.6 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6)...
(In reply to comment #69)
> Still persisting in Firefox 1.5.0.6...

Of course it is.  This bug hasn't even been marked as fixed yet.  There is no need to leave such comments.
(In reply to comment #70)
> (In reply to comment #69)
> > Still persisting in Firefox 1.5.0.6...
> 
> Of course it is.  This bug hasn't even been marked as fixed yet.  There is no
> need to leave such comments.
> 

Au contraire! As we can see from comment #68, the status and description of bugs can change without anybody specifically making a change to this area. If someone had inadvertently fixed it without realising, it being tested for and written here would be beneficial to everyone
(In reply to comment #71)
> Au contraire! As we can see from comment #68, the status and description of
> bugs can change without anybody specifically making a change to this area. If
> someone had inadvertently fixed it without realising, it being tested for and
> written here would be beneficial to everyone

If the bug had been inadvertently fixed, commenting would be acceptable.  However, in 99% of cases reporting that a bug still exists, *even in a slightly different yet still very broken way*, is unnecessary.  The default assumption should always be that a bug still exists and that the continuing existence of a bug is only very rarely comment-worthy; this instance is not such a case.
Updated the patch, it's a total hack, but it fixes the bug.
Not sure, if this is an acceptable solution.  I think it is reasonably safe.
Attachment #171647 - Attachment is obsolete: true
Is this behavior related?
Load http://www.docbook.org/xsd/4.4/docbook.xsd on a tab.
Make sure to have autoscroll enabled
Middle-click on the page: POUF! content is no longer displayed!

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 BonEcho/2.0b2 - Build ID: 2006082104
(In reply to comment #74)
> Is this behavior related?
> Load http://www.docbook.org/xsd/4.4/docbook.xsd on a tab.
> Make sure to have autoscroll enabled
> Middle-click on the page: POUF! content is no longer displayed!
> 
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821
> BonEcho/2.0b2 - Build ID: 2006082104
> 

Yes, this is what this bug is about.  The reason that your example page is going completely blank is because when that page is interpreted as HTML there are no valid tags that would cause something to be displayed.
*** Bug 350714 has been marked as a duplicate of this bug. ***
Summary: autoscroll (middle click) causes "XML pretty print" to unformat → autoscroll (middle click) causes "XML pretty print" to unformat (disappear, clear)
Here's a page somebody posted, which nicely displays this bug; http://www.w3schools.com/xml/cd_catalog.xml

When you middle-click the page, all the formatting disappears.  See Mozillazine thread here: http://forums.mozillazine.org/viewtopic.php?p=2511797#2511797
can you make patch for 2.0?
(In reply to comment #78)
> can you make patch for 2.0?

Firefox2 is already out. It is likely that bug 242621 gets fixed for Firefox3, so this will then also be fixed for Firefox3.
Duplicate of this bug: 375518
Duplicate of this bug: 376771
This should be fixed with my checkin for bug 242621.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 430507
Duplicate of this bug: 435701
Attached file bug (obsolete) —
Attachment #329055 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.