Update Mozilla 1.7 Bookmarks

RESOLVED DUPLICATE of bug 237340

Status

SeaMonkey
Bookmarks & History
--
blocker
RESOLVED DUPLICATE of bug 237340
14 years ago
6 years ago

People

(Reporter: Daniel Wang, Assigned: Pierre Chanial)

Tracking

Trunk
mozilla1.7alpha
Bug Flags:
blocking1.7a -
blocking1.7b -
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

4.07 KB, text/html
Details
(Reporter)

Description

14 years ago
not usre if 1.5 bookmarks ever makes it to 1.6 branch. Anyway, these URLs need
to be updated: Support & Release Notes

Set to blocker since we should have this in 1.6 release

Comment 1

14 years ago
1.6 is already released, so I assume this bug is INVALID.

pi
(Reporter)

Comment 2

14 years ago
gerv, it looks like change in bug 218326 is never ported to Mozilla 1.6 final.
Can we keep a separate bookmark.html and have the installer script or whatever
choose the right file?
Severity: blocker → normal
Summary: Update Mozilla 1.6 Bookmarks → Update Mozilla 1.7 Bookmarks
Grr. That's annoying.

We need to check the bookmark changes into the trunk. And perhaps the 1.6 branch
too, if we are going to do another release.

Just to summarise: the work of this bug is getting the user-oriented bookmarks
file from 1.5 and checking it into the 1.7 trunk (primarily) and the 1.6 branch
(secondarily.) That is what the blocker nomination relates to.

Gerv
Severity: normal → blocker
Flags: blocking1.7a?
Target Milestone: --- → mozilla1.7alpha
(Reporter)

Comment 4

14 years ago
Created attachment 140136 [details]
bookmarks.html

changes from 1.4 bookmarks:
  removed hardcoded link to release notes releases/mozilla1.4/
  updated support page to /support
  change /get-involved.html to about/get-involved.html
  removed ADD_DATE, LAST_CHARSET, etc. information
  www.dmoz.org -> dmoz.org (preferred address, see Home link in
    http://search.dmoz.org/cgi-bin/advanced_search.html
Daniel: why is your file based on the 1.4 bookmarks and not the new,
user-friendly 1.5 bookmarks checked in under bug 218326?

Gerv
(Reporter)

Comment 6

14 years ago
no idea. The attachment is based on your file at bug 218326.

btw, I'd like to see vivisimo.com listed under Search (I really miss
Northernlight Search)
(Reporter)

Comment 7

14 years ago
gerv, bug 51193 and this bug, which one should be fixed?
Daniel: this one :-)

Vivisimo have a Mozilla search plugin on their front page if you are using
Mozilla, so I say we include them as a mutual back-scratching exercise.

Gerv
Comment on attachment 140136 [details]
bookmarks.html

Asa: this is the same as the 1.5 bookmarks you reviewed before.

Gerv
Attachment #140136 - Flags: review?(asa)
(Reporter)

Comment 10

14 years ago
*** Bug 51193 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

14 years ago
*** Bug 115567 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
can  someone post a diff of the delta's between this file and the currently
shipping file?

Comment 13

14 years ago
going to - this,  we can take the change if it gets reviewed, but we probly
won't hold the alpha for it.
Flags: blocking1.7a? → blocking1.7a-
(Reporter)

Comment 14

14 years ago
Created attachment 141283 [details]
bookmarks.html

Vivismo search and community/ page added
Added the same Quick Searches in Firefox, except the URLs are converted to
Javascript: so that they don't perform invalid searches when accessed from the
Bookmarks menu.
(Reporter)

Updated

14 years ago
Attachment #140136 - Attachment is obsolete: true
(Reporter)

Updated

14 years ago
Attachment #140136 - Flags: review?(asa)
Comment on attachment 141283 [details]
bookmarks.html

Asa - is now an OK time to do this? If so, please review/approve.

Gerv
Attachment #141283 - Flags: review?(asa)

Comment 16

14 years ago
I'm not sure Asa reads bugmail - has someone asked him about this? could someone
else do the review?

and, in response to chofmann's comment, it's not really worth having a diff - i
just did it and the only significant line that matches is the doctype.  there
are a couple of sites from the old file with new labels, but pretty much all of
the existing bookmarks are removed in favour of the new selection.
Flags: blocking1.7b?
Flags: blocking1.7?

Comment 17

14 years ago
looks like we did this in bug http://bugzilla.mozilla.org/show_bug.cgi?id=237340
Flags: blocking1.7b?
Flags: blocking1.7b-
Flags: blocking1.7?
Flags: blocking1.7-
Actually, that's quite a different set. For example, it's missing the useful
QuickSearches and the range of search engines.

Is anyone up for merging, in consultation with Asa, the best bits of the two?

Gerv

Comment 19

14 years ago
well if anything further is going to be done, probably best to do it in the bug
that overtook this one...

*** This bug has been marked as a duplicate of 237340 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Attachment #141283 - Flags: review?(asa)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.