Infinite loop occurs when anti-virus deletes attachment during import from Eudora

RESOLVED DUPLICATE of bug 116443

Status

MailNews Core
Import
--
critical
RESOLVED DUPLICATE of bug 116443
14 years ago
9 years ago

People

(Reporter: neilr8133, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

When trying to import mail messages from Eudora (5.1R) my anti-virus triggered
on an attachment it thought was a virus.  My AV program automatically deleted
the file (D:\DOCUME~1\NEIL\LOCALS~1\TEMP), at which point Mozilla immediately
popped up an error window saying that it could not write a temporary file. 
However, this window cannot be dismissed: it re-opens, even when the import
dialog is closed.  In one case, even after all visible Mozilla windows were
closed, the dialog continued to pop up, but in another case, it popped up a few
times and then disapppeared.  The only reliable way I found to stop the messag
is to "End Process" on mozilla.exe.

Reproducible: Always

Steps to Reproduce:
1. Tools | Import | Mail | Eudora
2. Anti-virus triggers (Norton Anti-Virus 2003 Pro, in this case) on discovery
that a worm was attached.  (The extension was changed so it could not run, but
the a/v triggered on the content.)  A/V automatically deletes the file.
3. Alert window appears and cannot be dismissed.

Actual Results:  
Mozilla immediately popped up an error window saying that it could not write a
temporary file.  This window cannot be dismissed (it re-opens itself, even after
import has been Cancel'ed.

Expected Results:  
Show the message and abort the Import.

* Default theme being used.

Comment 1

14 years ago
I'm guessing this is WONTFIX or INVALID, since the problem is unusual, hard to
reproduce, and caused in part by a 3rd party product.

Perhaps it should be an RFE: 
     Add warning to mail import wizard: Disable antivirus before importing mail

Comment 2

14 years ago
I had a similar infinite loop when Norton antivirus detected a virus in incoming
email.  I could not exit Mozilla. Windows XP task manager could not kill
Mozilla! I had to pull the power plug. Mozilla said some error with incoming
mail '... delete file INBOSX.msf'  but I searched all of C: drive without
finding it. Restarting windows XP kept causing the problem until I disbaled
Norton anti-virus.
about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -nologo -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -nologo -Gy -Fd$(PDBFILE)

Configure arguments
--without-system-jpg --without-system-zlib --enable-extensions=default,irc,tasks
--enable-crypto --disable-auto-deps --disable-debug --enable-optimize=-O1

Updated

13 years ago
Blocks: 213562
Status: UNCONFIRMED → NEW
Depends on: 116443
Ever confirmed: true

Comment 3

13 years ago
*** Bug 256034 has been marked as a duplicate of this bug. ***

Updated

13 years ago
No longer depends on: 116443

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 116443 ***
No longer blocks: 213562
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core

Updated

11 years ago
Duplicate of this bug: 317511

Updated

11 years ago
Duplicate of this bug: 316788
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.