Closed Bug 229691 Opened 19 years ago Closed 16 years ago

"This operation not allowed." error with Adobe Acrobat Reader 6.0 plugin

Categories

(Plugins Graveyard :: PDF (Adobe), defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: shankarunni, Assigned: peterlubczynski-bugs)

References

()

Details

(Whiteboard: upgrade to at least v7.0.7)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031228 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031228 Firebird/0.7+

With Adobe Reader 6.0 (or 6.0.1) installed, using almost any version of Mozilla
newer than 1.4 (I've tried this using Netscape 7.1 and the latest Firebird
nightly), some PDF files cause the Adobe Reader plugin to throw up a "This
operation is not allowed." and not get loaded.


Reproducible: Always

Steps to Reproduce:
1. Visit http://www.corda.com/examples/popchart/
2. click on the "Build your own" example. 
3. In the example that pops up, click on the "PDF" button in the Image Type row. 

Actual Results:  
An error dialog with the title "Acrobat plugin.", and the message "This
operation is not allowed.".

Expected Results:  
Load the plugin and display the PDF file.


This may or may not be a bug in Mozilla itself, but instead, may just be some
change in the plugin API that Adobe runs afoul of. 

But there is no way of knowing what has changed and what Adobe is doing wrong
(if they are doing something wrong), which is important if I want to collect
enough info to file a good bug with Adobe (assuming it's their fault).
Confirmed on Mozilla Nightly Build 2003122809, XP
We're also having this problem. (using Acrobat Reader 6.0.2 + Mozilla 1.7.1). IE
has no problem displaying the same pdf. Hope this gets fixed soon :-)
Shouldn't this bug be marked CONFIRMED by now? It still happens on Firething
0.9.2, and comment #1 and comment #2 seem to provide enough confirmation..
(In reply to comment #3)
> Shouldn't this bug be marked CONFIRMED by now? It still happens on Firething
> 0.9.2, and comment #1 and comment #2 seem to provide enough confirmation..
> 

Yes, it should be marked confirmed by now imho. :-)
(In reply to comment #4)
> (In reply to comment #3)
> > Shouldn't this bug be marked CONFIRMED by now? It still happens on Firething
> > 0.9.2, and comment #1 and comment #2 seem to provide enough confirmation..
> > 
> 
> Yes, it should be marked confirmed by now imho. :-)

Tested and confirmed that Firefox 1.0 still has this bug.
Also updating Acrobat Reader to version 6.0.2 didn't help.

Wim
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > Shouldn't this bug be marked CONFIRMED by now? It still happens on Firething
> > > 0.9.2, and comment #1 and comment #2 seem to provide enough confirmation..
> > > 
> > 
> > Yes, it should be marked confirmed by now imho. :-)
> 
> Tested and confirmed that Firefox 1.0 still has this bug.
> Also updating Acrobat Reader to version 6.0.2 didn't help.
> 
> Wim


Still unconfirmed ? 

:-( 
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > (In reply to comment #3)
> > > > Shouldn't this bug be marked CONFIRMED by now? It still happens on Firething
> > > > 0.9.2, and comment #1 and comment #2 seem to provide enough confirmation..
> > > > 
> > > 
> > > Yes, it should be marked confirmed by now imho. :-)
> > 
> > Tested and confirmed that Firefox 1.0 still has this bug.
> > Also updating Acrobat Reader to version 6.0.2 didn't help.
> > 
> > Wim
> 
> 
> Still unconfirmed ? 
> 
> :-( 


Acrobat Reader 7.0.0 ... still the same bug.

I wonder if this will ever get fixed... nobody seems to care. I guess we'll have
to continue use Internet Explorer here at work.

Wim
This error message appears when PDF file is embedded with <object>, <iframe>,
etc, and is really annoying.

But I think it's the problem of Acrobat plugin, not Mozilla.
*** Bug 312659 has been marked as a duplicate of this bug. ***
*** Bug 281878 has been marked as a duplicate of this bug. ***
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031228 Firebird/0.7+
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031228 Firebird/0.7+
> 
> With Adobe Reader 6.0 (or 6.0.1) installed, using almost any version of Mozilla
> newer than 1.4 (I've tried this using Netscape 7.1 and the latest Firebird
> nightly), some PDF files cause the Adobe Reader plugin to throw up a "This
> operation is not allowed." and not get loaded.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Visit http://www.corda.com/examples/popchart/
> 2. click on the "Build your own" example. 
> 3. In the example that pops up, click on the "PDF" button in the Image Type row. 
> 
> Actual Results:  
> An error dialog with the title "Acrobat plugin.", and the message "This
> operation is not allowed.".
> 
> Expected Results:  
> Load the plugin and display the PDF file.
> 
> 
> This may or may not be a bug in Mozilla itself, but instead, may just be some
> change in the plugin API that Adobe runs afoul of. 
> 
> But there is no way of knowing what has changed and what Adobe is doing wrong
> (if they are doing something wrong), which is important if I want to collect
> enough info to file a good bug with Adobe (assuming it's their fault).


This problem has been there for as long as I can recall; I have tried Adobe
Reader 6 as well as 7, although I use Adobe Acrobat Pro 6 [+ updates]; and I
have tried all versions of Firefox from 1 to the latest. IE works like a charm
as far as opening pdf is concerned. 
(In reply to comment #2)
> We're also having this problem. (using Acrobat Reader 6.0.2 + Mozilla 1.7.1). IE
> has no problem displaying the same pdf. Hope this gets fixed soon :-)


parikshan@gmail.com: 
This problem has been there for as long as I can recall; I have tried Adobe
Reader 6 as well as 7, although I use Adobe Acrobat Pro 6 [+ updates]; and I
have tried all versions of Firefox from 1 to the latest. IE works like a charm
as far as opening pdf is concerned. 
I see this with version 7.0.0 and 7.0.3.  But it works with version 7.0.7 of the adobe reader plugin. Fixed?
(In reply to comment #13)
> I see this with version 7.0.0 and 7.0.3.  But it works with version 7.0.7 of
> the adobe reader plugin. Fixed?
> 

Don't see in version 7.0.7 too. Probably fixed by Adobe. It's Adobe's bug anyway.
WFM - agree with comment 13 and comment 14.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
The Adobe® Reader® 7.0.7 

The 7.0.7 Update states "will update Adobe Reader 7.0.5.  This update provides bug fixes, support for viewing Adobe® Acrobat® 3D files, and improved security.  Adobe recommends all Adobe Reader users install this update."
Whiteboard: upgrade to at least v7.0.7
-> WFM per the above comments.  And it works with version 8 too.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 212964
Component: Plug-ins → PDF (Adobe)
Product: Core → Plugins
QA Contact: adobe-reader
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.