Closed Bug 230363 Opened 16 years ago Closed 15 years ago

CVS-move session history code

Categories

(mozilla.org :: CVS: Copy, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: justdave)

References

Details

Attachments

(1 file)

justdave: I'm cleaning up history stuff, and I would like to move the session
history code to the proper location (it is really part of docshell). Can I get
you to do a CVS-copy of files:

Current location: mozilla/xpfe/components/shistory
New location: mozilla/docshell/shistory

When that's done, I can flip the Makefile switches and do the CVS remove on the
old location.
bz: you concur?
Looks correct to me, since it's linked into docshell...

Adam, do you see any issues with this?
No, looks like a good idea to me.
*** Bug 197488 has been marked as a duplicate of this bug. ***
Erf, this is a directory, not just a bunch of files.  You can't move a directory
in CVS, it just doesn't work.  The directory structure needs to be recreated
from scratch at the new location (cvs add).  Then each of the individual files
in the entire tree needs to be copied into the new tree, at the same location
within the tree.  Fortunately there's only 2 subdirectories involved here, so
it's probably only a half an hour of work or so.  I don't have a half hour at
the moment though.  Ping me again on the weekend or see if someone else will do
it if you're in a hurry.
Product: Browser → Seamonkey
Uh, this seems ancient.  You guys still need this?
Priority: -- → P2
yes please
Comment 6 is irrelevant now, we have scripts for this stuff now. :)  Just a
matter of feeding the script (because I need to list all the files individually,
not just the directory).

If someone can generate a text file for me with a full path to the source file
and a full path to the destionation file (with mozilla/ at the begining of each)
for each file in that directory, that would help a lot.  One pair per line, a
space between the source file and destination file.

That's the input the script needs, then I can just feed it to it.
-> chase
Assignee: justdave → chase
Product: Mozilla Application Suite → Core
Priority: P2 → --
Target Milestone: --- → mozilla1.9alpha
Assignee: chase → justdave
Component: Build Config → CVS: Copy
Product: Core → mozilla.org
QA Contact: build-config → chase
Target Milestone: mozilla1.9alpha → ---
Version: Trunk → other
completed.  You'll need to cvs remove the files from the old location.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Blocks: 305090
You need to log in before you can comment on or make changes to this bug.