wrong url in location bar when following links in mail messages

VERIFIED FIXED in M13

Status

P2
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: endico, Assigned: rpotts)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The URL in the location bar isn't updated to the current page when a
page is loaded by clicking on a link in a mail message. Nor is the new
URL added to the browser's history under the Go menu.

Comment 1

19 years ago
Hmm this used to work just fine before I left on vacation =). I wonder if it
broke due to rick's changes to the doc loader over the holidays...Adding rick to
the cc list.
(Reporter)

Comment 2

19 years ago
The history dialog under tasks->tools->history doesn't detect urls clicked

from mail messages either.



After I filed this bug and clicked the link to display it the url in the

location bar was wrong. It still showed the enter_bug url. Maybe the mail

thing messes up subsequent pages as well?

Comment 3

19 years ago
*** Bug 23088 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: mscott → rpotts
Severity: normal → critical
Priority: P3 → P2

Comment 4

19 years ago
I thought I added rick potts to the cc list but apparently not.

Rick, it looks like uri dispatching from the mail window to the browser window
got pretty broken with the big doc loader clean up you did over the holidays.
I'm seeing the following problems that used to work:
1) the url bar in the browser window is not getting set to the url that got
dispatched to this window
2) stop and forward buttons are not being updated properly either in fact they
are both getting disabled.

bouncing over to you 'cause I think it's related to the doc loader changes.
Lemme know if you want some help debugging this.

When I first got uri loading going, this was one of the first problems I had and
I think at the time I finally tracked it down to not issuing a on end document load.

Comment 5

19 years ago
*** Bug 23553 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Target Milestone: M13

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
Rick fixed this before he left.

Updated

19 years ago
Blocks: 24206

Updated

19 years ago
No longer blocks: 24206

Comment 7

19 years ago
Linux (2000-08-25-08 M18)
Win32 (2000-08-25-08 M18)
Mac (2000-08-25-04 M18)
This bug has been fixed.
Status: RESOLVED → VERIFIED
QA Contact: lchiang → fenella
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.