bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

compose window won't close

RESOLVED FIXED

Status

MailNews Core
Composition
--
major
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Felix Miata, Assigned: Ganesh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
OS/2 trunk 2004011808. IIRC, Friday the 16th was OK, and this started on the 17th.

To reproduce:
1-compose or reply to a message
2a-attempt to close the window (click X widget), or
2b-attempt to send (click send button)

Actual results:
1a-window does not close, or
1b-message is sent and copied to sent folder, but window does not close

Expected results:
1-compose window closes

Comments:
1-The compose window can be closed, but only by exiting Seamonkey entirely.
2-I normally compose and send in plain text format. I only tried sending with my
normal profile, not killing any messages prior to sending. A brand new profile
did not change the behavior.  With the new profile, I didn't bother to change
any prefs, and when the compose window came up in the HTML editor, I tried,
unsuccessfully, to close the window immediately.
3-The window remaining is not complete. After hitting send, the message body, 
destination, and subject fields are emptied, and portions of chrome are corrupted.

Comment 1

15 years ago
I confirm this on Thunderbird 0.5a
This message appears in the JavaScript console :

Error: gMsgCompose has no properties
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2096
(Reporter)

Comment 2

15 years ago
What OS are you running Thunderbird 0.5a on?

Comment 3

15 years ago
Oh sorry. It's on Linux.
(Reporter)

Comment 4

15 years ago
Christian & David, are you not seeing this on something other than OS/2? Do
comments 1 & 3 indicate this isn't OS/2-only?

Comment 5

15 years ago
No, can't confirm with 20040119 on Linux or Win98.
(Reporter)

Comment 6

15 years ago
Created attachment 139480 [details]
screenshot of compose window after clicking send

No improvement in 2004011908.
(Reporter)

Comment 7

15 years ago
I tried 2004011908 tar.gz on Fedora Core and couldn't duplicate the problem.

Comment 8

15 years ago
In this morning Thunderbird build on Linux the problem is still here with this
error messages in the JavaScript console :

Error: gMsgCompose has no properties
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 2101
(Assignee)

Comment 9

15 years ago
This is working fine on 20040116 and fails after that. I am now going to narrow
down the bug which introduces this bug. 
Assignee: sspitzer → grajaman

Comment 10

15 years ago
my guess would be this bug:

http://bugzilla.mozilla.org/show_bug.cgi?id=230649

It messed with prefs, and one of the prefs it messed with is reuse mail window.

Maybe something strange happened.

Comment 11

15 years ago
this works fine on both seamonkey and thunderbird for me. Do you have re-use
compose windows turned off?
(Reporter)

Comment 12

15 years ago
In my user.js is:
     // user_pref("mail.compose.max_recycled_windows", 0);

about:config shows mail.compose.max_recycled_windows default integer 1

The new profile I created to test this had absolutely nothing changed from the
defaults.
(Reporter)

Comment 13

15 years ago
Changing mail.compose.max_recycled_windows from 1 to 0 solves the problem.
(Assignee)

Comment 14

15 years ago
The following pref is missing in the current nightlies which could be causing
the problem
pref ("mail.compose.max_recycled_windows",0). 

This could be because of the bug #224578. We might need the following unix
specific fix for OS/2 aswell
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/mailnews&command=DIFF_FRAMESET&file=mailnews.js&rev1=3.207&rev2=3.208&root=/cvsroot
Kaply, let me know what do you think?
Status: NEW → ASSIGNED

Comment 15

15 years ago
we should just add the recycled windows pref to os2pref.js for now.

Comment 16

15 years ago
and shouldn't the value be 1, so that we cache one compose window?

Comment 17

15 years ago
OS/2 can't cache compose windows at all last time I checked. We had trouble with
the concept of a half used window around - the user could still get to it
accidentally.
(Assignee)

Comment 18

15 years ago
There is no os2pref.js in the present nightlies. Looks like all platform
specific *pref.js files have been removed and the files (preferences)  are made
global. So might have to do #ifdef XP_OS2 in mailnews.js itself?.

Comment 19

15 years ago
yep, that's what we should do.
(Assignee)

Comment 20

15 years ago
Created attachment 140042 [details] [diff] [review]
Patch for review

Comment 21

15 years ago
Did you test this and verify it worked?
(Assignee)

Comment 22

15 years ago
Yep I verified.

Comment 23

15 years ago
Comment on attachment 140042 [details] [diff] [review]
Patch for review

r=mkaply, sr=blizzard (platform specific code)
Attachment #140042 - Flags: superreview+
Attachment #140042 - Flags: review+

Comment 24

15 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 25

15 years ago
*** Bug 232921 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.