M17x FF10x: absolute positioning crashes when root is 'display: table' [@ nsIFrame::GetView ]

RESOLVED FIXED

Status

()

Core
Layout
P2
critical
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: dbaron)

Tracking

({crash, css2, testcase})

Trunk
crash, css2, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.7b -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Talkback ID: TB75328Q, TB75329K, TB75330G, crash signature, URL)

Attachments

(1 attachment)

here's the stack:

nsIFrame::GetStateBits() line 791 + 10 bytes
nsIFrame::GetView() line 2303 + 8 bytes
nsHTMLContainerFrame::CreateViewForFrame(nsIFrame * 0x0467f874, nsIFrame *
0x04670de8, int 0x00000000) line 544 + 8 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x046805dc, nsIContent * 0x04675cf8, int 0x00000003, nsIAtom *
0x00eb4708, nsIFrame * 0x04670de8, nsStyleContext * 0x04671070, nsFrameItems &
{...}) line 6207 + 15 bytes
nsCSSFrameConstructor::ConstructFrameInternal(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x04675cf8, nsIFrame * 0x04670de8, nsIAtom * 0x00eb4708, int 0x00000003,
nsStyleContext * 0x04671070, nsFrameItems & {...}, int 0x00000000) line 7184 +
53 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x046228d8, nsIPresContext
* 0x046216d8, nsFrameConstructorState & {...}, nsIContent * 0x04675cf8, nsIFrame
* 0x04670de8, nsFrameItems & {...}) line 7040 + 51 bytes
nsCSSFrameConstructor::ProcessChildren(nsIPresShell * 0x046228d8, nsIPresContext
* 0x046216d8, nsFrameConstructorState & {...}, nsIContent * 0x0466d470, nsIFrame
* 0x04670de8, int 0x00000001, nsFrameItems & {...}, int 0x00000001,
nsTableCreator * 0x00000000) line 11592 + 66 bytes
nsCSSFrameConstructor::ConstructTableCellFrame(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x0466d470, nsIFrame * 0x04680228, nsStyleContext * 0x04670fd8, nsTableCreator &
{...}, int 0x00000000, nsFrameItems & {...}, nsIFrame * & 0x04680468, nsIFrame *
& 0x04670de8, int & 0x00000001) line 2916 + 40 bytes
nsCSSFrameConstructor::TableProcessChild(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x0466d470, nsIContent * 0x0461f5d8, nsIFrame * 0x04680228, nsIAtom *
0x00eb4fd0, nsStyleContext * 0x04670c5c, nsTableCreator & {...}, nsFrameItems &
{...}, nsIFrame * & 0x00000000) line 3173 + 59 bytes
nsCSSFrameConstructor::TableProcessChildren(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x0461f5d8, nsIFrame * 0x04680228, nsTableCreator & {...}, nsFrameItems & {...},
nsIFrame * & 0x00000000) line 3068 + 63 bytes
nsCSSFrameConstructor::ConstructTableFrame(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x0461f5d8, nsIFrame * 0x0465dbbc, nsIFrame * 0x0465dbbc, nsStyleContext *
0x04670c5c, nsTableCreator & {...}, int 0x00000000, nsFrameItems & {...},
nsIFrame * & 0x04680168, nsIFrame * & 0x04680228, int & 0x00000000) line 2526 +
42 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x0467ff08, nsIContent * 0x0461f5d8, int 0x00000003, nsIAtom *
0x00eb47a8, nsIFrame * 0x0465dbbc, nsStyleContext * 0x04670c5c, nsFrameItems &
{...}) line 6368 + 67 bytes
nsCSSFrameConstructor::ConstructFrameInternal(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x0461f5d8, nsIFrame * 0x0465dbbc, nsIAtom * 0x00eb47a8, int 0x00000003,
nsStyleContext * 0x04670c5c, nsFrameItems & {...}, int 0x00000000) line 7184 +
53 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x046228d8, nsIPresContext
* 0x046216d8, nsFrameConstructorState & {...}, nsIContent * 0x0461f5d8, nsIFrame
* 0x0465dbbc, nsFrameItems & {...}) line 7040 + 51 bytes
nsCSSFrameConstructor::ConstructDocElementTableFrame(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsIContent * 0x0461f5d8, nsIFrame * 0x0465dbbc,
nsIFrame * & 0x00000000, nsILayoutHistoryState * 0x04671e20) line 3249
nsCSSFrameConstructor::ConstructDocElementFrame(nsIPresShell * 0x046228d8,
nsIPresContext * 0x046216d8, nsFrameConstructorState & {...}, nsIContent *
0x0461f5d8, nsIFrame * 0x0465dbbc, nsStyleContext * 0x0467fdf4, nsIFrame * &
0x00000000) line 3399 + 43 bytes
nsCSSFrameConstructor::ReconstructDocElementHierarchy(nsCSSFrameConstructor *
const 0x04622780, nsIPresContext * 0x046216d8) line 7295 + 48 bytes
nsCSSFrameConstructor::RecreateFramesForContent(nsIPresContext * 0x046216d8,
nsIContent * 0x0461f5d8) line 11475
nsCSSFrameConstructor::ProcessRestyledFrames(nsCSSFrameConstructor * const
0x04622780, nsStyleChangeList & {...}, nsIPresContext * 0x046216d8) line 9914
PresShell::ReconstructStyleData(PresShell * const 0x046228d8) line 5429
PresShell::EndUpdate(PresShell * const 0x046228f4, nsIDocument * 0x0452b8c8,
unsigned int 0x00000002) line 3608 + 16 bytes
nsDocument::EndUpdate(unsigned int 0x00000002) line 1664
CSSStyleSheetImpl::SetComplete(CSSStyleSheetImpl * const 0x046661b8) line 1932
CSSLoaderImpl::SheetComplete(SheetLoadData * 0x04666508, int 0x00000001) line 1498
CSSLoaderImpl::ParseSheet(nsIUnicharInputStream * 0x04635cb8, SheetLoadData *
0x04666508, int & 0x00000001) line 1444
SheetLoadData::OnStreamComplete(SheetLoadData * const 0x04666508,
nsIUnicharStreamLoader * 0x04664250, nsISupports * 0x00000000, unsigned int
0x00000000, nsIUnicharInputStream * 0x04635cb8) line 793 + 23 bytes
nsUnicharStreamLoader::OnStopRequest(nsUnicharStreamLoader * const 0x04664254,
nsIRequest * 0x04666590, nsISupports * 0x00000000, unsigned int 0x00000000) line 196
nsStreamListenerTee::OnStopRequest(nsStreamListenerTee * const 0x04621080,
nsIRequest * 0x04666590, nsISupports * 0x00000000, unsigned int 0x00000000) line 66
nsHttpChannel::OnStopRequest(nsHttpChannel * const 0x04666598, nsIRequest *
0x04664c48, nsISupports * 0x00000000, unsigned int 0x00000000) line 3392
nsInputStreamPump::OnStateStop() line 499
nsInputStreamPump::OnInputStreamReady(nsInputStreamPump * const 0x04664c4c,
nsIAsyncInputStream * 0x046649fc) line 339 + 11 bytes
nsInputStreamReadyEvent::EventHandler(PLEvent * 0x04653a9c) line 117
PL_HandleEvent(PLEvent * 0x04653a9c) line 671 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00f1cf58) line 606 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0004018e, unsigned int 0x0000c1cf, unsigned int
0x00000000, long 0x00f1cf58) line 1412 + 9 bytes
USER32! 77e3a2d0()
USER32! 77e145e5()
USER32! 77e1a816()
nsAppShellService::Run(nsAppShellService * const 0x00f6cda8) line 484
main1(int 0x00000002, char * * 0x00262d50, nsISupports * 0x00f2afd0) line 1291 +
32 bytes
main(int 0x00000002, char * * 0x00262d50) line 1678 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 7c5987e7()

in nsHTMLContainerFrame::CreateViewForFrame(), we are dereferencing null (parent
is null).

we assert, and then crash.

  // Create a view
  nsIFrame* parent = aFrame->GetAncestorWithView();
  NS_ASSERTION(parent, "GetParentWithView failed");

  nsIView* parentView = parent->GetView();
  NS_ASSERTION(parentView, "no parent with view");
Summary: nsIFrame::GetStateBits() crashes seamonkey and firebird ( → nsIFrame::GetStateBits() crashes seamonkey and firebird
Severity: normal → major
Keywords: crash
(Assignee)

Comment 1

14 years ago
In the doc element table frame codepath, we're not setting the absolute and fix
containing blocks in the frame constructor state, so the frame is ending up with
a null parent when it shouldn't.
(Assignee)

Comment 2

14 years ago
We should really be creating a wrapper around the root element anyway (to
represent the initial containing block as described in CSS).  This isn't too
hard to fix, but I want to land bug 231787 first.  (That's what happens when you
make me look at this code.)
Priority: -- → P2
Target Milestone: --- → mozilla1.7alpha
(Assignee)

Updated

14 years ago
Depends on: 231787
(Assignee)

Updated

14 years ago
Summary: nsIFrame::GetStateBits() crashes seamonkey and firebird → absolute positioning crashes when root is 'display: table'
(Assignee)

Comment 3

14 years ago
*** Bug 229263 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
*** Bug 236077 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
Crash on Mac OS X 10.3.2 running Mozilla 1.6 (final)

Crash log:
Date/Time:      2004-03-02 20:23:23 -0500
OS Version:     10.3.2 (Build 7D24)
Report Version: 2

Command: mozilla-bin

Version: 1.6 (1.6)
PID:     2217
Thread:  0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000024

Thread 0 Crashed:
0   libgklayout.dylib   	0x02023ce4 nsIFrame::GetView() const + 0x1c
1   libgklayout.dylib   	0x0202fe7c
nsHTMLContainerFrame::CreateViewForFrame(nsIFrame*, nsIFrame*, int) + 0x54
2   libgklayout.dylib   	0x020a0c50
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsStyleDisplay const*, nsIContent*,
int, nsIAtom*, nsIFrame*, nsStyleContext*, nsFrameItems&) + 0x530
3   libgklayout.dylib   	0x020a29bc
nsCSSFrameConstructor::ConstructFrameInternal(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsIAtom*, int,
nsStyleContext*, nsFrameItems&, int) + 0x454
4   libgklayout.dylib   	0x020a24f4
nsCSSFrameConstructor::ConstructFrame(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsFrameItems&) + 0x180
5   libgklayout.dylib   	0x020aaddc
nsCSSFrameConstructor::ProcessChildren(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, int, nsFrameItems&, int,
nsTableCreator*) + 0x204
6   libgklayout.dylib   	0x0209a4d0
nsCSSFrameConstructor::ConstructTableCellFrame(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsStyleContext*,
nsTableCreator&, int, nsFrameItems&, nsIFrame*&, nsIFrame*&, int&) + 0x2ac
7   libgklayout.dylib   	0x0209aea4
nsCSSFrameConstructor::TableProcessChild(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIContent*, nsIFrame*, nsIAtom*,
nsStyleContext*, nsTableCreator&, nsFrameItems&, nsIFrame*&) + 0x38c
8   libgklayout.dylib   	0x0209aa40
nsCSSFrameConstructor::TableProcessChildren(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsTableCreator&,
nsFrameItems&, nsIFrame*&) + 0x208
9   libgklayout.dylib   	0x020995b8
nsCSSFrameConstructor::ConstructTableFrame(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsIFrame*, nsStyleContext*,
nsTableCreator&, int, nsFrameItems&, nsIFrame*&, nsIFrame*&, int&) + 0x248
10  libgklayout.dylib   	0x020a1384
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsStyleDisplay const*, nsIContent*,
int, nsIAtom*, nsIFrame*, nsStyleContext*, nsFrameItems&) + 0xc64
11  libgklayout.dylib   	0x020a29bc
nsCSSFrameConstructor::ConstructFrameInternal(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsIAtom*, int,
nsStyleContext*, nsFrameItems&, int) + 0x454
12  libgklayout.dylib   	0x020a24f4
nsCSSFrameConstructor::ConstructFrame(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsFrameItems&) + 0x180
13  libgklayout.dylib   	0x0209b0fc
nsCSSFrameConstructor::ConstructDocElementTableFrame(nsIPresShell*,
nsIPresContext*, nsIContent*, nsIFrame*, nsIFrame*&, nsILayoutHistoryState*) + 0x74
14  libgklayout.dylib   	0x0209b5a8
nsCSSFrameConstructor::ConstructDocElementFrame(nsIPresShell*, nsIPresContext*,
nsFrameConstructorState&, nsIContent*, nsIFrame*, nsStyleContext*, nsIFrame*&) +
0x448
15  libgklayout.dylib   	0x020a2c48
nsCSSFrameConstructor::ReconstructDocElementHierarchy(nsIPresContext*) + 0x218
16  libgklayout.dylib   	0x020aa93c
nsCSSFrameConstructor::RecreateFramesForContent(nsIPresContext*, nsIContent*) +
0x254
17  libgklayout.dylib   	0x020a7920
nsCSSFrameConstructor::ProcessRestyledFrames(nsStyleChangeList&,
nsIPresContext*) + 0x160
18  libgklayout.dylib   	0x0205c4e4 PresShell::ReconstructStyleData() + 0x148
19  libgklayout.dylib   	0x02151ea0 nsDocument::EndUpdate(unsigned) + 0x90
20  libgklayout.dylib   	0x0226b1cc CSSStyleSheetImpl::SetComplete() + 0x90
21  libgklayout.dylib   	0x0224c694 CSSLoaderImpl::SheetComplete(SheetLoadData*,
int) + 0x98
22  libgklayout.dylib   	0x0224c5cc
CSSLoaderImpl::ParseSheet(nsIUnicharInputStream*, SheetLoadData*, int&) + 0x188
23  libgklayout.dylib   	0x0224b0c0
SheetLoadData::OnStreamComplete(nsIUnicharStreamLoader*, nsISupports*, unsigned,
nsIUnicharInputStream*) + 0x678
24  libnecko.dylib      	0x0102c034
nsUnicharStreamLoader::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 0x1a8
25  libnecko.dylib      	0x010953d4 nsHttpChannel::OnStopRequest(nsIRequest*,
nsISupports*, unsigned) + 0x228
26  libnecko.dylib      	0x01013eb0 nsInputStreamPump::OnStateStop() + 0xa0
27  libnecko.dylib      	0x01013ae0
nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) + 0x80
28  libxpcom.dylib      	0x003a6040 0x314000 + 0x92040
29  libxpcom.dylib      	0x00358f48 PL_HandleEvent + 0x24
30  libxpcom.dylib      	0x00358e6c PL_ProcessPendingEvents + 0x80
31  libxpcom.dylib      	0x00359350 _md_EventReceiverProc + 0x74
32  com.apple.HIToolbox 	0x927d2384 DispatchEventToHandlers + 0x150
33  com.apple.HIToolbox 	0x927d25f8 SendEventToEventTargetInternal + 0x174
34  com.apple.HIToolbox 	0x927d6a60 SendEventToEventTargetWithOptions + 0x28
35  com.apple.HIToolbox 	0x927e30f8
ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*,
void*) + 0x2b8
36  com.apple.HIToolbox 	0x927d2440 DispatchEventToHandlers + 0x20c
37  com.apple.HIToolbox 	0x927d25f8 SendEventToEventTargetInternal + 0x174
38  com.apple.HIToolbox 	0x927e4a88 SendEventToEventTarget + 0x28
39  com.apple.HIToolbox 	0x927e8980 ToolboxEventDispatcher + 0x5c
40  com.apple.HIToolbox 	0x927f8ba0 TryEventDispatcher + 0x6c
41  com.apple.HIToolbox 	0x927d9154 GetOrPeekEvent + 0x134
42  com.apple.HIToolbox 	0x927d9430 GetNextEventMatchingMask + 0x1c8
43  com.apple.HIToolbox 	0x927ecebc WNEInternal + 0xa0
44  com.apple.HIToolbox 	0x927fdb90 WaitNextEvent + 0x4c
45  libwidget_mac.dylib 	0x016df828 nsMacMessagePump::GetEvent(EventRecord&) + 0x74
46  libwidget_mac.dylib 	0x016df704 nsMacMessagePump::DoMessagePump() + 0x30
47  libwidget_mac.dylib 	0x016d3258 nsAppShell::Run() + 0x38
48  org.mozilla.mozilla 	0x000053f0 main1(int, char**, nsISupports*) + 0x6c4
49  org.mozilla.mozilla 	0x0000594c main + 0x13c
50  org.mozilla.mozilla 	0x0000229c _start + 0x17c
51  org.mozilla.mozilla 	0x0000211c start + 0x30

Thread 1:
0   libSystem.B.dylib   	0x9000b30c select + 0xc
1   libnspr4.dylib      	0x000d1934 poll + 0x188
2   libnspr4.dylib      	0x000ce128 _pr_poll_with_poll + 0x340
3   libnecko.dylib      	0x0102982c nsSocketTransportService::Run() + 0x1c4
4   libxpcom.dylib      	0x0035b89c nsThread::Main(void*) + 0x38
5   libnspr4.dylib      	0x000cf590 _pt_root + 0xa8
6   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 2:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9253c68c JNI_CreateJavaVM_Impl + 0x173c
3   libjvm.dylib        	0x9253c624 JNI_CreateJavaVM_Impl + 0x16d4
4   libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
5   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 3:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9249a89c JVM_NewInstance + 0x1fcc
3   libjvm.dylib        	0x924b9f18 JVM_FillInStackTrace + 0x2b8
4   libjvm.dylib        	0x924bf948 JVM_Send + 0x42e8
5   libjvm.dylib        	0x9255173c JNI_CreateJavaVM_Impl + 0x167ec
6   libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
7   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 4:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9249a808 JVM_NewInstance + 0x1f38
3   libjvm.dylib        	0x924a2a20 JVM_ArrayCopy + 0x4d0
4   libjvm.dylib        	0x924b8b48 JVM_MonitorNotify + 0x778
5   libjvm.dylib        	0x924b97a8 JVM_MonitorWait + 0xd8
6   <<00000000>> 	0x062bb668 0 + 0x62bb668
7   <<00000000>> 	0x062b968c 0 + 0x62b968c
8   <<00000000>> 	0x062b968c 0 + 0x62b968c
9   <<00000000>> 	0xa24a3720 typeinfo name for std::bad_exception + 0x6e7c
10  libjvm.dylib        	0x9249808c JVM_CurrentTimeMillis + 0x136c
11  libjvm.dylib        	0x924cd518 JVM_GetCPClassNameUTF + 0x1798
12  libjvm.dylib        	0x924d2ce4 JVM_FindClassFromClass + 0x9e4
13  libjvm.dylib        	0x924ec170 JVM_IsSameClassPackage + 0xfc0
14  libjvm.dylib        	0x924e66d8 JVM_GetMethodIxExceptionTableEntry + 0x2058
15  libjvm.dylib        	0x92577054 JVM_UnloadLibrary + 0x85c4
16  libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
17  libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 5:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9249a808 JVM_NewInstance + 0x1f38
3   libjvm.dylib        	0x924a2a20 JVM_ArrayCopy + 0x4d0
4   libjvm.dylib        	0x924b8b48 JVM_MonitorNotify + 0x778
5   libjvm.dylib        	0x924b97a8 JVM_MonitorWait + 0xd8
6   <<00000000>> 	0x062bb668 0 + 0x62bb668
7   <<00000000>> 	0x062b968c 0 + 0x62b968c
8   <<00000000>> 	0x062b95cc 0 + 0x62b95cc
9   <<00000000>> 	0x062b95cc 0 + 0x62b95cc
10  <<00000000>> 	0xa24a3720 typeinfo name for std::bad_exception + 0x6e7c
11  libjvm.dylib        	0x9249808c JVM_CurrentTimeMillis + 0x136c
12  libjvm.dylib        	0x924cd518 JVM_GetCPClassNameUTF + 0x1798
13  libjvm.dylib        	0x924d2ce4 JVM_FindClassFromClass + 0x9e4
14  libjvm.dylib        	0x924ec170 JVM_IsSameClassPackage + 0xfc0
15  libjvm.dylib        	0x924e66d8 JVM_GetMethodIxExceptionTableEntry + 0x2058
16  libjvm.dylib        	0x92577054 JVM_UnloadLibrary + 0x85c4
17  libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
18  libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 6:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9249a89c JVM_NewInstance + 0x1fcc
3   libjvm.dylib        	0x924a1a04 JVM_GetClassLoader + 0x1824
4   libjvm.dylib        	0x924a17a4 JVM_GetClassLoader + 0x15c4
5   libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
6   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 7:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9249a808 JVM_NewInstance + 0x1f38
3   libjvm.dylib        	0x924b9f70 JVM_FillInStackTrace + 0x310
4   libjvm.dylib        	0x92553b20 JVM_InitProperties + 0x1b10
5   libjvm.dylib        	0x92553920 JVM_InitProperties + 0x1910
6   libjvm.dylib        	0x92577054 JVM_UnloadLibrary + 0x85c4
7   libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
8   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 8:
0   libSystem.B.dylib   	0x900075c8 mach_msg_trap + 0x8
1   libSystem.B.dylib   	0x90007118 mach_msg + 0x38
2   libjvm.dylib        	0x9249a808 JVM_NewInstance + 0x1f38
3   libjvm.dylib        	0x924b9f70 JVM_FillInStackTrace + 0x310
4   libjvm.dylib        	0x924e22b0 JVM_StartThread + 0x580
5   libjvm.dylib        	0x924d0e04 JVM_FindLoadedClass + 0xa44
6   libjvm.dylib        	0x92577054 JVM_UnloadLibrary + 0x85c4
7   libjvm.dylib        	0x924fdc9c JVM_GetClassMethodsCount + 0x21c
8   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 9:
0   libSystem.B.dylib   	0x90018ce8 semaphore_timedwait_signal_trap + 0x8
1   libSystem.B.dylib   	0x9000e888 _pthread_cond_wait + 0x268
2   libnspr4.dylib      	0x000ca444 pt_TimedWait + 0xa8
3   libnspr4.dylib      	0x000ca694 PR_WaitCondVar + 0x88
4   libxpcom.dylib      	0x0035e5d8 TimerThread::Run() + 0x1b4
5   libxpcom.dylib      	0x0035b89c nsThread::Main(void*) + 0x38
6   libnspr4.dylib      	0x000cf590 _pt_root + 0xa8
7   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 10:
0   libSystem.B.dylib   	0x90018ce8 semaphore_timedwait_signal_trap + 0x8
1   libSystem.B.dylib   	0x9000e888 _pthread_cond_wait + 0x268
2   libnspr4.dylib      	0x000ca444 pt_TimedWait + 0xa8
3   libnspr4.dylib      	0x000ca694 PR_WaitCondVar + 0x88
4   libnecko.dylib      	0x010357e0
nsHostResolver::GetHostToLookup(nsHostRecord**) + 0x84
5   libnecko.dylib      	0x01035ae4 nsHostResolver::ThreadFunc(void*) + 0x60
6   libnspr4.dylib      	0x000cf590 _pt_root + 0xa8
7   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

Thread 11:
0   libSystem.B.dylib   	0x90018ce8 semaphore_timedwait_signal_trap + 0x8
1   libSystem.B.dylib   	0x9000e888 _pthread_cond_wait + 0x268
2   libnspr4.dylib      	0x000ca444 pt_TimedWait + 0xa8
3   libnspr4.dylib      	0x000ca694 PR_WaitCondVar + 0x88
4   libnecko.dylib      	0x0100c430 nsIOThreadPool::ThreadFunc(void*) + 0x70
5   libnspr4.dylib      	0x000cf590 _pt_root + 0xa8
6   libSystem.B.dylib   	0x900247e8 _pthread_body + 0x28

PPC Thread State:
  srr0: 0x02023ce4 srr1: 0x0200f030                vrsave: 0x00000000
    cr: 0x2402442c  xer: 0x00000004   lr: 0x02023cd8  ctr: 0x021d9e48
    r0: 0x0202fe7c   r1: 0xbfffd730   r2: 0x2402242c   r3: 0x00000000
    r4: 0x00000004   r5: 0xbfffd4b0   r6: 0xbfffd500   r7: 0xbfffd4b0
    r8: 0x023b1134   r9: 0x00000000  r10: 0x00000001  r11: 0x00000000
   r12: 0x2402442c  r13: 0xbfffdda0  r14: 0xbfffd870  r15: 0x023b072c
   r16: 0xbfffd874  r17: 0x01c2da74  r18: 0x00000001  r19: 0x00000000
   r20: 0x0a0e6270  r21: 0x08c49090  r22: 0x01bdd400  r23: 0x01c2f42c
   r24: 0x01c9ec00  r25: 0x01801e88  r26: 0x01c2d7f4  r27: 0x01c2d7f4
   r28: 0xbfffd8a0  r29: 0x01c2e67c  r30: 0xbfffd8d0  r31: 0x02023cd8

Binary Images Description:
    0x1000 -     0xffff org.mozilla.mozilla 1.6
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/mozilla-bin
   0x21000 -    0x213c2 Java Applet Plugin EnablerIns 	PEF binary: Java Applet
Plugin EnablerIns/
   0x2d000 -    0x3afff libplds4.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libplds4.dylib
   0x56000 -    0x64fff libplc4.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libplc4.dylib
   0xb2000 -    0xe4fff libnspr4.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libnspr4.dylib
  0x205000 -   0x26dfff libmozjs.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libmozjs.dylib
  0x2dd000 -   0x2e7fff libmozz.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libmozz.dylib
  0x2fb000 -   0x306fff ??? ??? (0.0.1d1)	/Applications/MyUtil/CodeTek
VirtualDesktop
Pro.app/Contents/Resources/patch.bundle/Contents/Resources/thePatchCarbon.bundle/Contents/MacOS/thePatchCarbon
  0x314000 -   0x3adfff libxpcom.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libxpcom.dylib
  0x423000 -   0x441fff libgkgfx.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libgkgfx.dylib
  0x457000 -   0x46bfff libtypeaheadfind.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libtypeaheadfind.dylib
  0x477000 -   0x48dfff libjsd.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libjsd.dylib
  0x49a000 -   0x4c4fff libembedcomponents.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libembedcomponents.dylib
  0x55c4c0 -   0x55c572 CFMPriv_CoreFoundation 	PEF binary: CFMPriv_CoreFoundation
  0x55cb40 -   0x55cbb7 CFMPriv_System 	PEF binary: CFMPriv_System
  0x55ce40 -   0x55cf10 CFMPriv_CarbonSound 	PEF binary: CFMPriv_CarbonSound
  0x55cf90 -   0x55d063 CFMPriv_CommonPanels 	PEF binary: CFMPriv_CommonPanels
  0x55d140 -   0x55d1fb CFMPriv_Help 	PEF binary: CFMPriv_Help
  0x55d200 -   0x55d2ca CFMPriv_HIToolbox 	PEF binary: CFMPriv_HIToolbox
  0x55d350 -   0x55d426 CFMPriv_HTMLRendering 	PEF binary: CFMPriv_HTMLRendering
  0x55d4a0 -   0x55d573 CFMPriv_ImageCapture 	PEF binary: CFMPriv_ImageCapture
  0x55d600 -   0x55d6e5 CFMPriv_NavigationServices 	PEF binary:
CFMPriv_NavigationServices
  0x55d760 -   0x55d836 CFMPriv_OpenScripting&#63743;MacBLib 	PEF binary:
CFMPriv_OpenScripting&#63743;MacBLib
  0x55d910 -   0x55d9ce CFMPriv_Print 	PEF binary: CFMPriv_Print
  0x55d9f0 -   0x55dabd CFMPriv_SecurityHI 	PEF binary: CFMPriv_SecurityHI
  0x55db40 -   0x55dc22 CFMPriv_SpeechRecognition 	PEF binary:
CFMPriv_SpeechRecognition
  0x55dca0 -   0x55dd73 CFMPriv_CarbonCore 	PEF binary: CFMPriv_CarbonCore
  0x55ddf0 -   0x55dec3 CFMPriv_OSServices 	PEF binary: CFMPriv_OSServices
  0x55dfa0 -   0x55e062 CFMPriv_AE 	PEF binary: CFMPriv_AE
  0x55e070 -   0x55e135 CFMPriv_ATS 	PEF binary: CFMPriv_ATS
  0x55e1b0 -   0x55e287 CFMPriv_ColorSync 	PEF binary: CFMPriv_ColorSync
  0x55e310 -   0x55e3f3 CFMPriv_FindByContent 	PEF binary: CFMPriv_FindByContent
  0x55e470 -   0x55e54a CFMPriv_HIServices 	PEF binary: CFMPriv_HIServices
  0x55e5c0 -   0x55e6a0 CFMPriv_LangAnalysis 	PEF binary: CFMPriv_LangAnalysis
  0x55e730 -   0x55e816 CFMPriv_LaunchServices 	PEF binary: CFMPriv_LaunchServices
  0x55e8f0 -   0x55e9c7 CFMPriv_PrintCore 	PEF binary: CFMPriv_PrintCore
  0x55e9d0 -   0x55ea92 CFMPriv_QD 	PEF binary: CFMPriv_QD
  0x55eb90 -   0x55ec79 CFMPriv_SpeechSynthesis 	PEF binary: CFMPriv_SpeechSynthesis
  0x605000 -   0x61bfff libpref.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libpref.dylib
  0x62b000 -   0x643fff libcaps.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libcaps.dylib
  0x665000 -   0x670fff libxpcom_compat_c.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libxpcom_compat_c.dylib
  0x67e000 -   0x698fff libxpcom_compat.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libxpcom_compat.dylib
  0x6aa000 -   0x6ae84f DRM Plugin 	PEF binary: DRM Plugin
  0x6be000 -   0x6f7fff libxpconnect.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libxpconnect.dylib
  0x72b000 -   0x766fff libi18n.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libi18n.dylib
  0x785000 -   0x7affff librdf.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/librdf.dylib
  0x7cc000 -   0x7e7fff libprofile.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libprofile.dylib
  0x7f4000 -   0x7f6fff com.apple.textencoding.unicode 1.6.4
/System/Library/TextEncodings/Unicode Encodings.bundle/Contents/MacOS/Unicode
Encodings
 0x1008000 -  0x10befff libnecko.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libnecko.dylib
 0x1120000 -  0x1150fff libimglib2.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libimglib2.dylib
 0x1162000 -  0x11a2fff libnsappshell.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libnsappshell.dylib
 0x16d2000 -  0x1710fff libwidget_mac.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libwidget_mac.dylib
 0x1767000 -  0x1782fff libchrome.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libchrome.dylib
 0x2008000 -  0x23acfff libgklayout.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libgklayout.dylib
 0x3673000 -  0x36b3fff libdocshell.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libdocshell.dylib
 0x36f1000 -  0x3745fff libhtmlpars.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libhtmlpars.dylib
 0x3770000 -  0x377dfff libpipboot.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libpipboot.dylib
 0x37b8000 -  0x37e3fff libgfx_mac.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libgfx_mac.dylib
 0x3802000 -  0x381efff libjsj.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libjsj.dylib
 0x384f000 -  0x390afff libuconv.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libuconv.dylib
 0x44af000 -  0x44cbfff liboji.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/liboji.dylib
 0x4514000 -  0x4520fff com.apple.JavaAppletPlugin 1.2.0	/Library/Internet
Plug-Ins/Java Applet.plugin/Contents/MacOS/Java Applet
 0x4531000 -  0x457bfff libjsdom.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libjsdom.dylib
 0x45b4000 -  0x45d7fff libgkplugin.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libgkplugin.dylib
 0x466e000 -  0x4679fff com.netscape.DefaultPlugin ??? (1.0)
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/plugins/Default
Plugin.plugin/Contents/MacOS/Default Plugin
 0x46a4000 -  0x46ef9b1 CarbonLibpwpc 	PEF binary: CarbonLibpwpc
 0x47091f0 -  0x470af7b Apple;Carbon;Networking 	PEF binary: Apple;Carbon;Networking
 0x470b000 -  0x49246d7 Windows Media Plugin 	PEF binary: Windows Media Plugin
 0x82c9000 -  0x82d8fff libcookie.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libcookie.dylib
 0x82e5000 -  0x82f5fff libjar50.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libjar50.dylib
 0x830d000 -  0x8323fff libwebbrwsr.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libwebbrwsr.dylib
 0x8335000 -  0x8340fff libtxmgr.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libtxmgr.dylib
 0x83c0000 -  0x83c2fff org.mozilla.pde.MOZZ 1.0
/Users/riscky/Desktop/Mozilla.app/Contents/Plug-ins/PrintPDE.plugin/Contents/MacOS/PrintPDE
 0x83cc000 -  0x8431fff libappcomps.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libappcomps.dylib
 0x84c7000 -  0x84d4fff libp3p.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libp3p.dylib
 0x8656000 -  0x8685fff libmork.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libmork.dylib
 0x8d05000 -  0x8da8fff libeditor.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libeditor.dylib
 0xa5fe000 -  0xa607fff libwalletviewers.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libwalletviewers.dylib
 0xa621000 -  0xa643fff libwallet.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libwallet.dylib
 0xa866000 -  0xa89dfff libmsgbaseutil.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/libmsgbaseutil.dylib
 0xaa8b000 -  0xaae5fff libmsgcompose.dylib 
/Users/riscky/Desktop/Mozilla.app/Contents/MacOS/components/libmsgcompose.dylib
0x72fe0000 - 0x72ff0fff com.apple.Accelerate.vecLib 3.0.1 (vecLib 3.0.1)
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
0x7fb70000 - 0x7fc9dfff com.apple.vImage 1.0.0
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
0x81b30000 - 0x81b3bfff com.apple.agl 2.4 (AGL-2.4)
/System/Library/Frameworks/AGL.framework/Versions/A/AGL
0x86b90000 - 0x86bbafff com.apple.QuickTime Plugin.plugin 6.5	/Library/Internet
Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime Plugin
0x86e30000 - 0x86e52fff libCFilter.A.dylib 
/System/Library//Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Resources/libCFilter.A.dylib
0x8b0c0000 - 0x8b70efff com.apple.QuickTimeComponents.component 6.5
/System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
0x8df60000 - 0x8df76fff libJapaneseConverter.dylib 
/System/Library/CoreServices/Encodings/libJapaneseConverter.dylib
0x8e250000 - 0x8e25efff com.apple.JavaEmbedding 1.0.4
/System/Library/Frameworks/JavaEmbedding.framework/Versions/A/JavaEmbedding
0x8fc90000 - 0x8fc90fff com.apple.Accelerate 1.0.1 (Accelerate 1.0.1)
/System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x8fe00000 - 0x8fe4ffff dyld 	/usr/lib/dyld
0x90000000 - 0x90122fff libSystem.B.dylib 	/usr/lib/libSystem.B.dylib
0x90190000 - 0x9023dfff com.apple.CoreFoundation 6.3.1 (299.2)
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x90280000 - 0x904f9fff com.apple.CoreServices.CarbonCore 10.3.2
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x90570000 - 0x905ddfff com.apple.framework.IOKit 1.3 (???)
/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x90610000 - 0x90699fff com.apple.CoreServices.OSServices 3.0 (3.0.0)
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x90700000 - 0x90700fff com.apple.CoreServices 10.3 (???)
/System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x90720000 - 0x90787fff com.apple.audio.CoreAudio 2.1.2
/System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x907f0000 - 0x907f9fff com.apple.DiskArbitration 2.0.2
/System/Library/PrivateFrameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x90810000 - 0x90810fff com.apple.ApplicationServices 1.0 (???)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x90830000 - 0x9089ffff libobjc.A.dylib 	/usr/lib/libobjc.A.dylib
0x90910000 - 0x90983fff com.apple.DesktopServices 1.2
/System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
0x909f0000 - 0x90b4afff com.apple.Foundation 6.3.3 (500.53)
/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x90c30000 - 0x90c47fff libGL.dylib 
/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
0x90c60000 - 0x90cc2fff libGLU.dylib 
/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLU.dylib
0x90d00000 - 0x90d19fff com.apple.SystemConfiguration 1.4.1 (???)
/System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x90d40000 - 0x90d40fff com.apple.Carbon 10.3 (???)
/System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x90d60000 - 0x90d81fff com.apple.opengl 1.3.0
/System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x90df0000 - 0x90df4fff com.apple.JavaVM 1.4.2 (1.4.2 Release 1)
/System/Library/Frameworks/JavaVM.framework/Versions/A/JavaVM
0x910b0000 - 0x910fffff com.apple.bom 1.2.3 (62.1)
/System/Library/PrivateFrameworks/Bom.framework/Versions/A/Bom
0x912a0000 - 0x912bdfff com.apple.audio.SoundManager 3.8
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
0x912e0000 - 0x912f7fff com.apple.LangAnalysis 1.5.4
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
0x91320000 - 0x913defff ColorSync 
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
0x91460000 - 0x91473fff com.apple.speech.synthesis.framework 3.2
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x914a0000 - 0x91509fff com.apple.htmlrendering 1.1.2
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering.framework/Versions/A/HTMLRendering
0x91560000 - 0x91619fff com.apple.QD 3.4.62 (???)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
0x91670000 - 0x916a8fff com.apple.AE 1.3.2
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x916e0000 - 0x91773fff com.apple.print.framework.PrintCore 3.1
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
0x917e0000 - 0x917f0fff com.apple.speech.recognition.framework 3.3
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
0x91810000 - 0x9182afff com.apple.openscripting 1.2.1 (???)
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
0x91850000 - 0x91860fff com.apple.ImageCapture 2.1.0
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/ImageCapture
0x91890000 - 0x9189cfff com.apple.help 1.0.1
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framework/Versions/A/Help
0x918c0000 - 0x918cdfff com.apple.CommonPanels 1.2.1 (1.0)
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels.framework/Versions/A/CommonPanels
0x918f0000 - 0x9193dfff com.apple.print.framework.Print 3.0 (3.1)
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framework/Versions/A/Print
0x91990000 - 0x9199bfff com.apple.securityhi 1.2 (90)
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
0x919c0000 - 0x91a32fff com.apple.NavigationServices 3.3
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
0x91a90000 - 0x91a90fff com.apple.audio.units.AudioUnit 1.3.1
/System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
0x91ab0000 - 0x91ac4fff libCGATS.A.dylib 
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGATS.A.dylib
0x91ae0000 - 0x91aebfff libCSync.A.dylib 
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
0x91b10000 - 0x91b2afff libPDFRIP.A.dylib 
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libPDFRIP.A.dylib
0x91b50000 - 0x91b5ffff libPSRIP.A.dylib 
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libPSRIP.A.dylib
0x91b80000 - 0x91b93fff libRIP.A.dylib 
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
0x91bb0000 - 0x91d44fff com.apple.QuickTime 6.5.0
/System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime
0x92070000 - 0x92096fff com.apple.FindByContent 1.4 (1.2)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/FindByContent.framework/Versions/A/FindByContent
0x920c0000 - 0x922a6fff com.apple.security 2.1 (163.1)
/System/Library/Frameworks/Security.framework/Versions/A/Security
0x92430000 - 0x92468fff com.apple.LaunchServices 10.3 (84)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x92490000 - 0x92616fff libjvm.dylib 
/System/Library/Frameworks/JavaVM.framework/Versions/1.3.1/Libraries/libjvm.dylib
0x92740000 - 0x92777fff com.apple.CFNetwork 1.2.1 (7)
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x927d0000 - 0x92b53fff com.apple.HIToolbox 1.3.1 (???)
/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x92d30000 - 0x92d80fff com.apple.HIServices 1.4.0 (0.0.1d1)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
0x935d0000 - 0x938a6fff com.apple.CoreGraphics 1.203.12 (???)
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics

Comment 6

14 years ago
if this isn't too hard, perhaps we could hold 1.7b for it
Flags: blocking1.7b?
OS: Windows 2000 → All
Hardware: PC → All
I don't think this has ever worked in Mozilla. I don't think this is the time to
do a real fix. Maybe a bandaid fix to stop crashing, if we can find one.

Comment 8

14 years ago
beta train is pulling out.  renominate if patch appears for final
Flags: blocking1.7b? → blocking1.7b-
*** Bug 239419 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Blocks: 222220

Comment 10

14 years ago
Created attachment 147856 [details]
Testcase

This is a testcase I added in Bug 233940 (which I just closed after finding
this one): switching the stylesheet (away from and back to Orange) will cause
the given crash.

I see that this bug seems to be pretty well documented, so I am sorry if this
is just unnecessary spam, but I figured a testcase here couldn't be all that
bad.
(Assignee)

Updated

14 years ago
Depends on: 63895
(Assignee)

Updated

14 years ago
Depends on: 243519

Updated

14 years ago
Keywords: css2, testcase

Comment 11

14 years ago
*** Bug 233940 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Whiteboard: Talkback ID: TB75328Q, TB75329K, TB75330G

Updated

14 years ago
Severity: major → critical
Summary: absolute positioning crashes when root is 'display: table' → absolute positioning crashes when root is 'display: table' [@ nsIFrame::GetView ]
*** Bug 251914 has been marked as a duplicate of this bug. ***
*** Bug 258862 has been marked as a duplicate of this bug. ***
*** Bug 259764 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
*** Bug 261048 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 16

14 years ago
would need a well tested patch to take on the aviary branch at this point. 
renominate if a patch appears.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 17

13 years ago
*** Bug 267030 has been marked as a duplicate of this bug. ***
*** Bug 267057 has been marked as a duplicate of this bug. ***
*** Bug 267385 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
testcase worksforme with linux trunk 2005021305
Testcase is also WFM using a home-built Windows build -- switching back and
forth between the stylesheets did not generate a crash.  It seems the crash has
been inadvertently fixed, although I for one would want confirmation from a Mac
tester and possibly a competent user running a debug build before I'd mark it as
WFM.

I also tested the original page where I first found this bug (hixie's site,
Orange stylesheet), and it worked properly too.  Also, that stylesheet hasn't
been fixed (note that the html selector has the property "display: table"), so
it's still a valid testcase:

Testcase   -- http://ln.hixie.ch/ (switch over to the Orange stylesheet to test)
Stylesheet -- http://ln.hixie.ch/resources/style/orange/

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050212 Firefox/1.0+

Comment 22

13 years ago
Testcase and original site WFM with Mozilla trunk build 2005021614 on WinNT4.
Currently I don't see any crash reports with that signature for Moz-/FF-Trunk
(but a lot for Moz17/FF10) so I guess it is fixed on trunk. I don't know if this
bug should nevertheless be fixed on the Mozilla1.7 and Aviary1.0 branch.
Summary: absolute positioning crashes when root is 'display: table' [@ nsIFrame::GetView ] → M17x FF10x: absolute positioning crashes when root is 'display: table' [@ nsIFrame::GetView ]
Target Milestone: mozilla1.7alpha → ---

Comment 23

13 years ago
testcase and hixie test no longer crash on Mac with latest mozilla and firefox
nightlies

(aside: when loading the test case, the 'switch to orange' text does not appear
until I switch style - that seems wrong??)
*** Bug 289765 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Blocks: 289765

Comment 25

13 years ago
On my GNU+Linux there's no crash with this and all testcases from
#137216 and #131008.

cvs trunk Gecko/20050523.

Is there gtk/unix gurus ?

Why not to try to make some kind of crash safety, like GIMP has.
When subprocess is crashes it catch this with notice about posibility
of internal inconsistency, but not just segfaults.
Here's new bug with this kind of crash #296086, and maybe it may be
avoided with that.

Comment 26

13 years ago
no crash with linux trunk 2005060102

resolving WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Confirmed, no crash with the testcase, http://spam.hixie.ch/ and
http://ln.hixie.ch/ also work fine now. SeaMonkey trunk 20050506 and Deer Park
Alpha 1 (Firefox 20050531) on Win XP.

Comment 28

13 years ago
still crashing here with the attached testcase, using Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050518 Firefox/1.0.4 on Win2000
This was apparently fixed on the trunk somewhere between 2004-10-10 (crashes)
and 2004-10-29 (WFM). Builds between these two dates are missing from the archive.
This was "fixed" by simply disabling absolute positioning altogether in
documents where the root is display:table as a side effect of a different patch.
 Please don't resolve this bug unless you file a followup to track the
underlying problem (which is alive and well) and transfer all dependencies.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 31

12 years ago
I think the patch bzbarsky was referring to is on bug 263406.
(Assignee)

Comment 32

12 years ago
I filed bug 320865; marking this as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Blocks: 340946
Crash Signature: [@ nsIFrame::GetView ]
You need to log in before you can comment on or make changes to this bug.