Closed Bug 232164 Opened 19 years ago Closed 19 years ago

"Bugs reported Today" link on Bugzilla panel no longer works

Categories

(Bugzilla :: Query/Bug List, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: bzbarsky, Assigned: myk)

References

()

Details

Attachments

(1 file)

It seems that the backwards-compat stuff is not handling the "bugs filed since"
link that the bugzilla sidebar at
http://people.netscape.com/granrose/panels/bugzilla/bugzillapanel.html uses...
I'm not sure whether this was purposeful or not, but I figured I should file it.

*** This bug has been marked as a duplicate of 232163 ***
No longer blocks: bmo-regressions-old
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
No, wrong bug
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This should work now, BTW. If it doesn't, add &debug=1 to the params, and paste
that output in.

*** This bug has been marked as a duplicate of 231949 ***
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
It doesn't work.  The output is:

SELECT bugs.bug_id, bugs.bug_severity, bugs.priority, bugs.bug_status,
bugs.resolution, bugs.priority, map_assigned_to.login_name, bugs.resolution,
bugs.target_milestone, bugs.short_desc FROM bugs, profiles AS map_assigned_to
LEFT JOIN bug_group_map ON bug_group_map.bug_id = bugs.bug_id AND
bug_group_map.group_id NOT IN (9,10) LEFT JOIN cc ON cc.bug_id = bugs.bug_id AND
cc.who = 20209 WHERE bugs.assigned_to = map_assigned_to.userid AND
(bugs.bug_status IN ('UNCONFIRMED','NEW','ASSIGNED','REOPENED','RESOLVED')) AND
(bugs.product_id IN (1,6)) AND ((to_days(now()) - to_days(bugs.delta_ts)) < '2')
AND ((bug_group_map.group_id IS NULL) OR (bugs.reporter_accessible = 1 AND
bugs.reporter = 20209) OR (bugs.cclist_accessible = 1 AND cc.who IS NOT NULL) OR
(bugs.assigned_to = 20209) OR (bugs.qa_contact = 20209) ) GROUP BY bugs.bug_id
ORDER BY bugs.bug_id
I stand by the original dupe.  The website he's pointing at is not under
mozilla.org control.  The only way WE can fix it is with the backward
compatibility code.  The bug you duped this to was specific to the link on the
index page which was changed to use the new syntax.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 232163 ***
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
The bug you duped this against was so that query.cgi displayed the query
properly after 'edit' was used.

We already have compat code for changedin - thats what bug 231949 was about.

Except that bug 231949 got fixed by fixing the query, not the compat code. so
someone needs to fix the compat code.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Here's some code that special-cases searches where changedin is defined,
chfieldfrom and chfieldto are not, and chfield is [Bug creation].  That's the
query on the Bugzilla panel and in Mozilla's "QA" menu.  I also simplify the
code a bit in the process of moving it around.
Assignee: justdave → myk
Status: REOPENED → ASSIGNED
Attachment #139893 - Flags: review?(bbaetz)
Whiteboard: [applied to b.m.o]
Note that the original code says:

push(@specialchart, ["changedin", "lessthan", $changedin + 1]);

But I do:

push(@specialchart, ["changedin", "lessthan", $changedin]);

That's because if changedin=1 you want today's bugs (AFAICT), but $changedin+1
gives you yesterday's and today's.
Comment on attachment 139893 [details] [diff] [review]
patch v1: hacks a fix for problem into Search.pm

Hmm. I'll buy the change, but note that since 'days' is actually 'time since
midnight', you're under-reporting rather than over reporting.

I'd prefer to keep it the way it was, but r=bbaetz either way
Attachment #139893 - Flags: review?(bbaetz) → review+
Checking in Bugzilla/Search.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Search.pm,v  <--  Search.pm
new revision: 1.51; previous revision: 1.50
done

Note: added back the +1 after bbaetz determined that's the way it was in 2.16. 
That doesn't affect the special case, which still shows only today's created bugs.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Flags: approval+
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
*** Bug 231315 has been marked as a duplicate of this bug. ***
I had a much simpler patch ready for bug 231315, which unfortunately did not
make it for yesterday's upgrade. But it's worth considering because (except for
its simplicity) it reproduces exactly the (erroneous) behavior of the previous
version of the code, and is thus likely to break fewer existing erroneous insane
queries.

I also have a patch for the release notes there.
for the record, I'm no longer at AOL so I can't fix or remove the code on my
people.netscape.com page...
Whiteboard: [applied to b.m.o]
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.