Problem with some Microsoft Word attachments

RESOLVED FIXED in Thunderbird0.5

Status

RESOLVED FIXED
15 years ago
8 years ago

People

(Reporter: EGNg, Assigned: mscott)

Tracking

unspecified
Thunderbird0.5
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

When I send a message under Thunderbird 0.4 with an attachment of a Microsoft
Word document, the recipient sometimes does not see the attachment.  This
happens to some Microsoft Word documents, but not all.

If I repeat the same exercise under Thunderbird 0.3, the attachment appears to
show up okay; the system may not recognize the filetype, but the attachment is
always there.

Reproducible: Always
Steps to Reproduce:
1. Compose the message.
2. Use "attach" to attach a Microsoft Word document.
3. Hit "send" to send the message.

Actual Results:  
The message gets sent.  However, when the message is sent under Thunderbird 0.4,
some Microsoft Word documents do not get detected as attachments when the
recipients open the message.  When I examine the body of the message, the
Microsoft Word document is encoded, but somehow it is not recognized by the mail
clients.

Expected Results:  
The encoded Microsoft Word documents should be detected.

If the same message is sent using Thunderbird 0.3, the same Microsoft Word
documents are recognized by mail clients.

I can provide a couple of Microsoft Word documents or the encoded messages if
needed.

Comment 1

15 years ago
I can confirm this behaviour - it has stopped the use of thunderbird in our organisation until it is 
fixed.

I tried to change the severity of this bug but was denied.  I think this is a blocker.
(Reporter)

Comment 2

15 years ago
I have created a simple Microsoft Word document that contains only 1 line: 
"This is a test".

The first few lines of the message (with the headers removed) sent using
Thunderbird 0.3 are:

MIME-version: 1.0
Content-type: multipart/mixed; boundary=------------060702010003080702090207
X-Accept-Language: en-us, en
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5)
 Gecko/20031013 Thunderbird/0.3
Original-recipient: rfc822;egng@imapd.lbl.gov

This is a multi-part message in MIME format.
--------------060702010003080702090207
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

Test.

--------------060702010003080702090207
Content-Type: multipart/appledouble;
 boundary="------------ad020308030607080704050801"; x-mac-type="5738424E";
x-mac-creator="4D535744";
 name="Test_File.doc"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
 filename="Test_File.doc"

--------------ad020308030607080704050801
Content-Type: application/applefile
Content-Transfer-Encoding: base64

AAUWBwACAAAAAAAAAAAAAAAAAAAAAAAAAAUAAAADAAAAVgAAAA0AAAAJAAAAYwAAACAAAAAI
AAAAgwAAABAAAAAEAAAAkwAAAAAAAAACAAAAkwAAAR5UZXN0X0ZpbGUuZG9jVzhCTk1TV0QA
AAAAAAAAAAAAAAAAAAAAgAAAAAAAAAAHsYc7B7GHO0ttDAAHsYqEAAABAAAAAQAAAAAAAAAA
HgAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAQAAAAEAAAAAAAAAAB4AAAAAAAAAAAAcAB7/
/w==

--------------ad020308030607080704050801
Content-Type: application/octet-stream; name="Test_File.doc"
Content-Transfer-Encoding: base64
Content-Disposition: inline; filename="Test_File.doc"

0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7/CQAGAAAAAAAAAAAAAAABAAAAIQAAAAAA
AAAAEAAAIwAAAAEAAAD+////AAAAACAAAAD/////////////////////////////////////
////////////////////////////////////////////////////////////////////////

The first few lines of the message (with the headers removed) sent using
Thunderbird 0.4 are:

MIME-version: 1.0
Content-type: multipart/mixed; boundary=------------080708090607000508050603
X-Accept-Language: en-us, en
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b)
 Gecko/20031205 Thunderbird/0.4
Original-recipient: rfc822;egng@imapd.lbl.gov

This is a multi-part message in MIME format.
--------------080708090607000508050603
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

Test.

--------------080708090607000508050603
Content-Type: multipart/appledouble;
 boundary="------------ad020702070407000708030205"; x-mac-type="5738424E";
x-mac-creator="4D535744";
 name="Test_File.doc"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
 filename="Test_File.doc"

LS0tLS0tLS0tLS0tLS1hZDAyMDcwMjA3MDQwNzAwMDcwODAzMDIwNQ0KQ29udGVudC1UeXBl
OiBhcHBsaWNhdGlvbi9hcHBsZWZpbGUKQ29udGVudC1UcmFuc2Zlci1FbmNvZGluZzogYmFz
ZTY0CgpBQVVXQndBQ0FBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBVUFBQUFEQUFBQVZnQUFB

It looks like some of the parameters or keywords (not sure what they are called
since I am not an MIME expert) are missing using Thunderbird 0.4.


(Assignee)

Comment 3

15 years ago
Related to Bug #229855, Bug #229879 ?

I'm curious to see if I fixed this in the upcoming 0.5 release which is coming
out in a couple days.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.6
Seems to be caused by patch of Bug 229855.
It seems to have stopped application/applefile part creation in
multipart/appledouble, and seems to have also stopped boundary data creation for
following data folk part.
I think whole appledouble part creation should be inhibited if resource folk is
not required. 
(Assignee)

Comment 5

15 years ago
WADA: I wasn't clear from your comment, are you saying the patch that went in
for Bug 229855 yesterday is causing more problems than it is solving or it is
ok? Need to know ASAP if that needs backed out of the 0.5 branch. 
Change by attachment 140754 [details] [diff] [review] by Bug 229855 Comment #9 looks to stop applefile
part creation in the multipart/appledouble creation block when MS Word file. 
So, if and only if the latter mail data in Comment #2 was the result of this
patch, your patch could be the cause of Comment #2, I thought.
However, the mail data in Comment #2 looks to be created by older Thunderbird. 
> User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b)
>  Gecko/20031205 Thunderbird/0.4is Gecko/20031205 Thunderbird/0.4
Your patch can not be included in 20031205 build.

As I said in Bug 229879 Comment #3, invalid appledouble mail creation problem
has already resolved by newer builds, I think.
Can someone test with Thunderbird just before fix for Bug 229855 and after fix
for Bug 229855?
(Reporter)

Comment 7

15 years ago
I just installed Thunderbird 0.5b (build 20040204).  The problem with Microsoft
Word document attachment seems to have gone away.
(Assignee)

Comment 8

15 years ago
Yeah!!!!
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: Thunderbird0.6 → Thunderbird0.5

Comment 9

14 years ago
I encountered this problem using Thunderbird 0.5 under Widnows. Today I updated
to Thunderbird 0.7 (20040616), and the problem remained, i.e., attached Word
documents are sent as multipart/appledouble.

I found the problem in the google groups archive (the thread around message id
<4093D86D.5010900@kuestner.org>, in German). As mentioned in this thread, I
deleted my profiles directory and recreated the account, and now it seems to
work fine.
You need to log in before you can comment on or make changes to this bug.