Last Comment Bug 234110 - Setting history to 0 no longer disables autocomplete
: Setting history to 0 no longer disables autocomplete
Status: RESOLVED INVALID
: helpwanted, regression
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: unspecified
: All All
: -- normal with 16 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 252382 269719 275542 316231 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 18:28 PST by Mike Pesce (:By-Tor)
Modified: 2009-02-07 06:11 PST (History)
15 users (show)
bugs: blocking‑aviary1.0-
bugs: blocking‑aviary1.5-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mike Pesce (:By-Tor) 2004-02-12 18:28:26 PST
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040212 Firebird/0.8.0+

In trunk builds post 20040210, setting the history to 0 no longer disables
autocomplete or the history dropdown as in previous versions.  If this is
intentional, then there needs to be an option to disable the autocomplete and
dropdown.

Reproducible: Always
Steps to Reproduce:
1. Set history to 0
2. Type an URL in the Location Bar
3.

Actual Results:  
If another URL is input in the Location Bar, autocomplete will be activated.

Expected Results:  
If history is set to 0, autocomplete should not be active.
Comment 1 Melissa M. Strader 2004-02-26 11:25:49 PST
These comments are based on the assumption that the “auto-complete” feature
mentioned in the report refers to the ability of the location bar to drop down
and display previously-visited URLs if part of the URL is typed in the location
bar. 
I was able to follow your steps to achieve the same results. My history is
usually set to 7 days. If I set the history to 0 and type the URL of somewhere
that I have visited before making changes to the history, such as google.com,
the location bar drops down to offer me the option. 

However, if I set the history to 0, type in the address of a place I have never
visited, leave the site, and then try to type in that URL again, the location
bar does not offer me this option. The browser only remembers the sites that
were visited prior to requesting that the history be disabled, which is
consistent with the behavior of IE 6. 

Also, if I clear my history, then set my history to 0, the browser will not
remember any of the sites I have visited, or any of the sites that I visit after
changing my history settings. This behavior is also consistent with the behavior
of IE 6. In summary, the location bar drop down seems to be disabled by setting
the history to 0 and clearing the history. 
I tried this on a Win XP system, and the behavior was the same for both Firebird
0.7 build 20040210, and Firefox 0.8.
Comment 2 Mike Pesce (:By-Tor) 2004-02-27 16:08:29 PST
This however wasn't the behavior in previous builds.  My history is now set to
0, yet I will still get a dropdown box for URLs typed during this session.  This
is also not the behavior of Firefox 0.8 Milestone.  In regards to IE's behavior,
disabling "Use inline AutoComplete," will also disable the dropdown.  Setting
the history to 0 in Firebird/fox used to have the same effect.
Comment 3 Chris 2004-02-27 23:12:08 PST
I have been able to systematically reproduce this bug with builds Post 0.8
(Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040227
Firefox/0.8.0+) firefox release. All nightlys past the release demonstrate the
behavior where sites that I manually type in (not bookmarks) are stored in the
drop down URL location bar, and then if I begin to type the site that I had
previously manually entered, then the drop down menu occurs. 

This does not occur on the firefox 0.8 milestone. No matter what URL I manually
type into the location bar, none are saved in the drop down "history" of sites
that I have previously typed. 
Comment 4 J.B. Nicholson-Owens 2004-04-29 20:16:19 PDT
Shouldn't history and autocomplete be two separate things?  I understand the
privacy issue with autocomplete (and I agree with it--not being able to disable
autocomplete is one of the few issues keeping me from switching away from
Mozilla suite), but I would not want to lose track of where I've been.
Comment 5 Mike Pesce (:By-Tor) 2004-04-30 09:57:28 PDT
Agreed, history and autocomplete should be two separate settings, but as it
stands, the only way to disable the autocomplete is/was to disable the history.
Comment 6 Hari Kumar G 2004-06-17 22:52:37 PDT
Why could not the user be given an option for disabling autocomplete for forms,
passwords, and urls separately from the Options Dialog.  
Comment 7 Mike Pesce (:By-Tor) 2004-06-19 09:57:02 PDT
Separate options would also be welcomed.  But, with the existing code it doesn't
seem likely.
Comment 8 José Jeria 2004-07-21 04:11:08 PDT
*** Bug 252382 has been marked as a duplicate of this bug. ***
Comment 9 Dan 2004-09-02 14:51:18 PDT
any chance that it will have separate options like seamonkey before 1.0?
Comment 10 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-11-14 02:54:56 PST
*** Bug 269719 has been marked as a duplicate of this bug. ***
Comment 11 sairuh (rarely reading bugmail) 2004-12-08 11:58:47 PST
comparing with mozilla (seamonkey), it looks like the equivalent of
browser.urlbar.autocomplete.enabled (boolean) no longer exists in firefox.
Comment 12 Jo Hermans 2004-12-21 07:18:23 PST
*** Bug 275542 has been marked as a duplicate of this bug. ***
Comment 13 Aaron Lehmann 2005-06-24 10:34:34 PDT
IMHO this is a HUGE problem. It's what's keeping me from switching to Firefox.
Not only is there a privacy issue, but I find the dropdown really annoying.
There's an option in the prefs dialog to disable autocomplete in HTML forms and
the search bar - why can't it apply to the URI field too?
Comment 14 Akkana Peck 2005-06-24 11:19:09 PDT
> There's an option in the prefs dialog to disable autocomplete in HTML forms and
> the search bar

Is that new? I don't have such an option in my prefs dialog, and I'm not seeing
anything that looks related in about:config searching for auto, complete, for
form. What's the pref?

> I find the dropdown really annoying.

Me too, and since it seemed pretty clear this regression isn't going to get
fixed, I turned it off locally. If you're willing to hack the XUL source, it's
easy. In browser/base/content/browser.xul, look for the lines (around line 200):

         <textbox id="urlbar" flex="1"
                  type="autocomplete"
                  autocompletesearch="history" 
                  autocompletepopup="PopupAutoComplete"
                  completeselectedindex="true"
                  tabscrolling="true"
                  showcommentcolumn="true"

and remove the autocompletesearch and autocompletepopup lines. Voila, no more
focus-stealing popup menu.

If you don't build your own, you'll have to explode (unzip) browser.jar in the
firefox install directory, make the change to browser.xul, and then zip the jar
back up.
Comment 15 Elmar Ludwig 2005-11-13 01:54:03 PST
*** Bug 316231 has been marked as a duplicate of this bug. ***
Comment 16 didouche9 2005-12-15 06:04:23 PST
hi, in my case the history used to be at 9 days and was never reset. now it is resetted as soon as I close firefox. Therefore on the location bar the browser remembers nothing... since this problem has occured firefox has been slower
thanks for checking it out
I've tried putting the history at 0 and it doesn't change anything. I'm using firefox 1.5
Comment 17 David P James 2006-06-16 11:41:06 PDT
Mass edit: Changing QA to default QA Contact
Comment 18 David P James 2006-06-16 11:56:15 PDT
Mass edit: Setting correct QA for location bar/autocomplete. My bad. I forgot I had once been Autocomplete QA too. Hmm, why can't I just set the QA of bugs to the default QA of the component in a mass edit rather than having to do it manually...?
Comment 19 Ivan Ičin 2008-07-16 14:13:50 PDT
As settings in Firefox 3 have changed, this should be resolved invalid.
Comment 20 Marco Bonardo [::mak] (Away 6-20 Aug) 2009-02-07 06:11:46 PST
resolving because:
1. browser.urlbar.autocomplete.enabled allows to disable autocomplete
2. the new locationbar allows to search through bookmarks, tags, and so on
3. the user can easily set locationbar to search only history, and clear history, that would not return any result (3.1).
4. autocomplete code and preferences are quite different now

Note You need to log in before you can comment on or make changes to this bug.