Closed Bug 235451 Opened 16 years ago Closed 16 years ago

Search criteria panel in both SearchMessages and Filter->New dialogs initially displayed blank

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird0.6

People

(Reporter: superbiskit, Assigned: mscott)

References

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040221 Firefox/0.8.0+

Mozilla Thunderbird 0.5+ (20040221)
WindowsXP pro
Upon selecting either SearchMessages or Tools->Filters->New, the (upper) dialog
panel that should be the search criteria is displayed blank.
The situation can be corrected by selecting "More" to cause a display action
that puts up a second criterion line under a blank line, then "Less".  In the
SearchMessages dialog, selecting "Clear" also does the trick.  Looks like
anything that causes the display to be rebuilt will correct this.

Reproducible: Always
Steps to Reproduce:
1. Select Tools->SearchMessages: OBSERVE upper panel is blank.
2. Select Tools->Filters->New: OBSERVE upper panel is blank;
3. Select "More" button: OBSERVE the added criterion selector is on the second
line below a blank entry;
4. Select "Less" button: OBSERVE the display is now 'correct' with a single
criterion selector in the first line.


Actual Results:  
As stated.

Expected Results:  
The display after step.4 should be the initial display.
I see this too.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.6
this is in seamonkey too. Hopefully we can narrow down when this first showed up.
I finally tracked this down. Sorry it took so long.

This was caused by Neil's checkin for Bug #235451...

Neil can you take a look?

Thanks...

Depends on: 120410
err Bug #132561 rather.... :)
No longer depends on: 120410
Depends on: 120410
Hmm... for some reason the top index is being set to 1, which is silly, as there
is only one item (index 0, of course...)
*** Bug 235714 has been marked as a duplicate of this bug. ***
This seems to be fixed (tested with a CVS build from today).
Fixed by the patch to bug 120410.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.