buglist.cgi: Use of uninitialized value in string eq at C:\Bugzilla\buglist.cgi line at 97 and 307

RESOLVED DUPLICATE of bug 226249

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 226249
14 years ago
5 years ago

People

(Reporter: Alex Yu, Assigned: justdave)

Tracking

2.17.7
x86
Windows Server 2003

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: 

I am running Bugzilla Version 2.17.6.  I would see the error when every time 
user submits the query.  This is a Windows server.

C:\Perl\bin\PerlIS-Err.log

*** 'C:\Bugzilla\buglist.cgi' error message at: 2004/02/25 23:42:17
[Wed Feb 25 23:42:16 2004] buglist.cgi: Use of uninitialized value in string 
eq at C:\Bugzilla\buglist.cgi line 97.
[Wed Feb 25 23:42:16 2004] buglist.cgi: Use of uninitialized value in string 
eq at C:\Bugzilla\buglist.cgi line 307.
[Wed Feb 25 23:42:16 2004] buglist.cgi: Use of uninitialized value in string 
eq at C:\Bugzilla\buglist.cgi line 307.


Reproducible: Always
Steps to Reproduce:
1. Go to Bugzilla
2. Click Search
3. Click Submit
4. Check C:\Perl\bin\PerlIS-Err.log

Actual Results:  
I still see bugs being listing.

Expected Results:  
No error?

Comment 1

14 years ago
same thing with Linux under Apache 1.3.29 (Unix), perl v5.8.2 built for i486-linux and Bugzilla 
2.17.6

==> /var/log/apache/error_log.bugzilla <==
[Fri Feb 27 17:41:38 2004] buglist.cgi: Use of uninitialized value in string eq at /var/www/
bugzilla/buglist.cgi line 97.
[Fri Feb 27 17:41:38 2004] buglist.cgi: Use of uninitialized value in string eq at /var/www/
bugzilla/buglist.cgi line 307.
[Fri Feb 27 17:41:38 2004] buglist.cgi: Use of uninitialized value in string eq at /var/www/
bugzilla/buglist.cgi line 307.
(Reporter)

Comment 2

14 years ago
It seems like the error messages have gone away after I upgraded Bugzilla to 
version 2.17.7.  However, I am getting this message now:

*** 'C:\Bugzilla\buglist.cgi' error message at: 2004/03/15 20:18:03
[Mon Mar 15 20:18:03 2004] buglist.cgi: Use of uninitialized value in 
concatenation (.) or string at Bugzilla/CGI.pm line 121.

BTW, it is running on a Windows Server with ActivePerl 5.8.
OS: Windows XP → Windows Server 2003
Version: unspecified → 2.17.7
Summary: uglist.cgi: Use of uninitialized value in string eq at C:\Bugzilla\buglist.cgi line at 97 and 307 → buglist.cgi: Use of uninitialized value in string eq at C:\Bugzilla\buglist.cgi line at 97 and 307

Comment 3

14 years ago
(In reply to comment #2)
> It seems like the error messages have gone away after I upgraded Bugzilla to 
> version 2.17.7.  However, I am getting this message now:
> 
> *** 'C:\Bugzilla\buglist.cgi' error message at: 2004/03/15 20:18:03
> [Mon Mar 15 20:18:03 2004] buglist.cgi: Use of uninitialized value in 
> concatenation (.) or string at Bugzilla/CGI.pm line 121.
> 
> BTW, it is running on a Windows Server with ActivePerl 5.8.

That's because of the extra $ sign after boundary as explained in bug 238683.

Comment 4

13 years ago
i just checked that again in some more detail. buglist.cgi with any non-empty 
query string will return all bugs in the database. 
 
best solution to me would be an adjustable limit in params. 
 

Comment 5

13 years ago
(In reply to comment #4) 
> i just checked that again in some more detail. buglist.cgi with any 
non-empty  
> query string will return all bugs in the database.  
>   
> best solution to me would be an adjustable limit in params.  
>   
sorry, this should have gone to #255606. 
i don't know what happened. i am sure to have clicked on the correct id... 
 

Updated

13 years ago
Blocks: 231570

Comment 6

13 years ago
Both errors have been fixed between 2.17.6 and 2.17.7, by bug 226249 (line 97)
and bug 233645 (line 307). Marking as a dupe of the first one (I can't mark it
as a dupe of both :) ).


*** This bug has been marked as a duplicate of 226249 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.