Closed Bug 235968 Opened 17 years ago Closed 16 years ago

macromedia flash hogging cpu - tabbed browsing freeze

Categories

(Core :: Plug-ins, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 106397

People

(Reporter: mozilla, Assigned: info)

References

()

Details

(Keywords: perf)

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040218
MultiZilla/1.6.2.0c
using :
    File name: Shockwave Flash NP-PPC
    Shockwave Flash 7.0 r19

The website in question has a logo on each page.
If you only open one page you don't have a problem, but try opening several
pages from the site in tabs, and you get the spinning beach-ball. 

  PID COMMAND      %CPU   TIME   #TH #PRTS #MREGS RPRVT  RSHRD  RSIZE  VSIZE
22149 mozilla-bi  32.3%  1:02.87  12   207   434  19.2M  29.8M  52.4M   327M
21985 Safari      18.0%  4:16.30   7   130   367  18.2M  18.9M  51.8M   154M

Above the results of >top -o cpu
Mozilla has 1 tab  with the website
Safari  has 4 tabs with the website (different pages)

Mozilla isn't completely frozen - you might get lucky and catch it at the right
moment to get some action.
Keywords: perf
I get this happening on 1.7rc1 downloaded yesterday:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040421

The http://afl.com.au/ website has this exact effect.  I'm running the same
flash version (7.0 r19).
Similar bugs: bug 233702, bug 172312 and bug 106397.

I think we should focus in one of these, and mark the others as duplicates.
Here is a thread backtrace from gdb during this lockup period. The browser is
not completely unresponsive as I can eventually get the offending tab closed.
Doing so makes the problem go away completely. The odd thing about my issue is
that it doesn't usually occur until the system has been idle for a while. As
you can see from the output, the freeze is a semaphore wait.
I get this too with 1.7rc2 and the same version of Flash listed by others.

Can we get the "hang" keyword added?
FWIW I get the same behavior in Safari and have submitted a bug report to
Macromedia. If someone can figure out a way to work around the issue in the mean
time, I'm sure everyone would greatly appreciate it.
I'm seeing Flash 7.0r19 hogging the CPU even without using tabs--using 40-50% of
the CPU while displaying some pages containing Flash ads, with spikes up to 90%.
(On the other hand, Safari is at 24% when loading the same page, which decreases
then to 0.5%.) An example page is www.macosrumors.com

This results in a few behaviors--Mozilla will hang. Or, I'll get a spinning
pinwheel for 10 seconds, then the page is OK. Or, I'll get the spinning pinwheel
for 10 seconds, and then each line of text I scroll down, all of the Flash
animations will move one frame.
Looks like a dupe of bug 238935.
That bug is specific to Firefox, although the bug is probably in the main
Mozilla codebase somewhere. Very annoying. I've had it slowdown so much it's
unusable and even crash on occasion with flash animation ads.
Assignee: peterlubczynski-bugs → spage

*** This bug has been marked as a duplicate of 106397 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.