Unable to save attachment of attached E-mail(message/rfc822 part)

RESOLVED FIXED

Status

MailNews Core
Attachments
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Robert Rothenberg, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

A friend received a jpg attachment to her Yahoo account, and forwarded it to me.

I received the E-mail, which had the original forwarded E-mail as an attachment.
I could click on the attachment to view the E-mail.  That E-mail has an attached
jpg.

I can click on the jpg and view it in Mozilla.  But if I use "Save As", I get an
Alert that says "Unable to save attachent. Please check your file name and try
again later."

The folder where I intended to save the file has no file by the same name.  And
I have write perms to that folder.  Changing the name or folder does nothing. (I
tried saving to C:\TEMP but it didn't like that either.)

When I view it in Mozilla, I can use the File | Save to save it, though.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Robert Rothenberg, please save the email (or another showing the same problem -- 
a smaller file is preferred!) as a .EML file and attach it to this bug, using 
the Create a New Attachment link above.
(Reporter)

Comment 2

14 years ago
Created attachment 143011 [details]
Sample E-mail duplicating this bug

The original message had a not-so-appropriate image.  And there's the issue of
including my friends' friends' E-mails in a public database.

However, I was able to replicate the bug:
1. I forwarded the Buzilla notification to a Yahoo account
2. I attached a small PNG image to that forward before sending it
3. In Yahoo web mail I forwarded the message back as an attachment

Comment 3

14 years ago
OK.  What I am seeing with that posted email is that if I open the attached 
email into its own standalone window, then try Save As from the attachment 
panel, I cannot save it, as described by reporter.  This is true with 1.6 Final, 
1.7a-0301, under Windows 2000.

This looks to be yet another symptom of bug 204350.

As a tenuous workaround: the image attachment is also seen in the attachment 
panel of the message *containing* the forwarded message (which is itself bug 
35587; see also bug 203570).  Selecting the image from there, it can be saved.
Blocks: 204350
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Product: MailNews → Core
Add "message/rfc822" in summary for ease of search.
Summary: Unable to save attachment of attached E-mail → Unable to save attachment of attached E-mail(message/rfc822 part)
Depends on: 269826
Blocks: 269826
No longer depends on: 269826

Comment 5

13 years ago
This bug has been fixed by the patch for bug 204350.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
*** Bug 349546 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.